aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-10-12 02:36:20 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-10-12 02:36:20 +0000
commit4f93516e898eaf4864323b7367aad1f70dcebca6 (patch)
tree056e63902c9ba97fd321471daf0a28a8109baffb
parent4ba2071a79a341fa57c1d46457ca331de60827c7 (diff)
downloadports-4f93516e898eaf4864323b7367aad1f70dcebca6.tar.gz
ports-4f93516e898eaf4864323b7367aad1f70dcebca6.zip
Guichan is a portable C++ GUI library designed for
games using Allegro, SDL and/or OpenGL. WWW: http://guichan.sourceforge.net/ PR: 86954 Submitted by: Tobias Gion <freebsd@gionet.de>
Notes
Notes: svn path=/head/; revision=145058
-rw-r--r--devel/Makefile1
-rw-r--r--devel/guichan/Makefile38
-rw-r--r--devel/guichan/distinfo2
-rw-r--r--devel/guichan/files/patch-configure.in20
-rw-r--r--devel/guichan/files/patch-src__sdl__sdlimageloader.cpp11
-rw-r--r--devel/guichan/pkg-descr5
-rw-r--r--devel/guichan/pkg-plist52
7 files changed, 129 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 420f2ee4b7c9..5525c304ca00 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -346,6 +346,7 @@
SUBDIR += gstreamer-plugins-sdl
SUBDIR += gtgt
SUBDIR += gtranslator
+ SUBDIR += guichan
SUBDIR += guikachu
SUBDIR += gvd
SUBDIR += gwenhywfar
diff --git a/devel/guichan/Makefile b/devel/guichan/Makefile
new file mode 100644
index 000000000000..8a4e4713dfea
--- /dev/null
+++ b/devel/guichan/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: guichan
+# Date created: 2005-10-03
+# Whom: Tobias Gion <freebsd@gionet.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= guichan
+PORTVERSION= 0.4.0
+CATEGORIES= devel games
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= freebsd@gionet.de
+COMMENT= A small, efficient C++ GUI library designed for games
+
+LIB_DEPENDS= SDL-1.1.7:${PORTSDIR}/devel/sdl12 \
+ SDL_image.10:${PORTSDIR}/graphics/sdl_image
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_GMAKE= yes
+USE_GCC= 3.2+
+USE_LIBTOOL_VER=15
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-allegro
+INSTALLS_SHLIB= yes
+LDCONFIG_DIRS= %%LOCALBASE%%/lib
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/SDL11 \
+ -I${X11BASE}/include" LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib \
+ ${PTHREAD_LIBS}"
+
+pre-configure:
+ @(cd ${WRKSRC} && ./autogen.sh)
+
+.include <bsd.port.mk>
diff --git a/devel/guichan/distinfo b/devel/guichan/distinfo
new file mode 100644
index 000000000000..f1cf1ac714a2
--- /dev/null
+++ b/devel/guichan/distinfo
@@ -0,0 +1,2 @@
+MD5 (guichan-0.4.0-src.tar.gz) = f68b6c603c4fb3d70a8737f916214a35
+SIZE (guichan-0.4.0-src.tar.gz) = 1274735
diff --git a/devel/guichan/files/patch-configure.in b/devel/guichan/files/patch-configure.in
new file mode 100644
index 000000000000..017d91725e1d
--- /dev/null
+++ b/devel/guichan/files/patch-configure.in
@@ -0,0 +1,20 @@
+--- configure.in.orig Tue Oct 11 21:57:06 2005
++++ configure.in Tue Oct 11 21:57:33 2005
+@@ -170,7 +170,7 @@
+ , enable_force_sdlimage=no)
+ if test x$enable_sdlimage = xyes; then
+ if test x$enable_force_sdlimage = xno; then
+- AC_CHECK_HEADERS([SDL/SDL_image.h])
++ AC_CHECK_HEADERS([SDL_image.h])
+ AC_CHECK_LIB([SDL_image], [IMG_Load], HaveSDLImage, NoSDLImage)
+ else
+ ForceSDLImage
+@@ -205,7 +205,7 @@
+ , enable_force_sdl=no)
+ if test x$enable_sdl = xyes; then
+ if test x$enable_force_sdl = xno; then
+- AC_CHECK_HEADERS(SDL/SDL.h)
++ AC_CHECK_HEADERS(SDL.h)
+ AC_CHECK_PROG(HAVE_SDL, sdl-config, yes)
+ if test "x$HAVE_SDL" != "xyes"; then
+ SDL="no"
diff --git a/devel/guichan/files/patch-src__sdl__sdlimageloader.cpp b/devel/guichan/files/patch-src__sdl__sdlimageloader.cpp
new file mode 100644
index 000000000000..f907e449829b
--- /dev/null
+++ b/devel/guichan/files/patch-src__sdl__sdlimageloader.cpp
@@ -0,0 +1,11 @@
+--- src/sdl/sdlimageloader.cpp.orig Tue Oct 11 21:58:04 2005
++++ src/sdl/sdlimageloader.cpp Tue Oct 11 21:58:18 2005
+@@ -56,7 +56,7 @@
+ * For comments regarding functions please see the header file.
+ */
+
+-#include <SDL/SDL_image.h>
++#include <SDL_image.h>
+
+ #include "guichan/sdl/sdlimageloader.hpp"
+ #include "guichan/exception.hpp"
diff --git a/devel/guichan/pkg-descr b/devel/guichan/pkg-descr
new file mode 100644
index 000000000000..351ac2c6fc9d
--- /dev/null
+++ b/devel/guichan/pkg-descr
@@ -0,0 +1,5 @@
+Guichan is a portable C++ GUI library designed for
+games using Allegro, SDL and/or OpenGL.
+
+WWW: http://guichan.sourceforge.net/
+Author: Tobias Gion <info@gionet.de>
diff --git a/devel/guichan/pkg-plist b/devel/guichan/pkg-plist
new file mode 100644
index 000000000000..14ce71365fe2
--- /dev/null
+++ b/devel/guichan/pkg-plist
@@ -0,0 +1,52 @@
+include/guichan.hpp
+include/guichan/actionlistener.hpp
+include/guichan/allegro.hpp
+include/guichan/basiccontainer.hpp
+include/guichan/cliprectangle.hpp
+include/guichan/color.hpp
+include/guichan/defaultfont.hpp
+include/guichan/exception.hpp
+include/guichan/focushandler.hpp
+include/guichan/font.hpp
+include/guichan/graphics.hpp
+include/guichan/gui.hpp
+include/guichan/image.hpp
+include/guichan/imagefont.hpp
+include/guichan/imageloader.hpp
+include/guichan/input.hpp
+include/guichan/key.hpp
+include/guichan/keyinput.hpp
+include/guichan/keylistener.hpp
+include/guichan/listmodel.hpp
+include/guichan/mouseinput.hpp
+include/guichan/mouselistener.hpp
+include/guichan/opengl.hpp
+include/guichan/opengl/openglgraphics.hpp
+include/guichan/opengl/openglimageloader.hpp
+include/guichan/platform.hpp
+include/guichan/rectangle.hpp
+include/guichan/sdl.hpp
+include/guichan/widget.hpp
+include/guichan/widgets/button.hpp
+include/guichan/widgets/checkbox.hpp
+include/guichan/widgets/container.hpp
+include/guichan/widgets/dropdown.hpp
+include/guichan/widgets/icon.hpp
+include/guichan/widgets/label.hpp
+include/guichan/widgets/listbox.hpp
+include/guichan/widgets/radiobutton.hpp
+include/guichan/widgets/scrollarea.hpp
+include/guichan/widgets/slider.hpp
+include/guichan/widgets/textbox.hpp
+include/guichan/widgets/textfield.hpp
+include/guichan/widgets/window.hpp
+include/guichan/x.hpp
+lib/libguichan.a
+lib/libguichan.so
+lib/libguichan.so.0
+lib/libguichan_opengl.a
+lib/libguichan_opengl.so
+lib/libguichan_opengl.so.0
+@dirrm include/guichan/widgets
+@dirrm include/guichan/opengl
+@dirrm include/guichan