aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug White <dwhite-freebsd-bugs@gumbysoft.com>2024-11-21 13:34:26 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-11-21 13:39:54 +0000
commit4fbf489f56e600cd2aea598be2dac18977611dc8 (patch)
treee2f43e019e3ad75fcdf6ab0d522aa9c5a817067b
parent4c6dcb621687cc8c0ef09c5480714f3e1dfe6dac (diff)
downloadports-4fbf489f56e600cd2aea598be2dac18977611dc8.tar.gz
ports-4fbf489f56e600cd2aea598be2dac18977611dc8.zip
mail/py-pyspf: Add lifetime argument back
- Fix 2920ddff74980fdebe12c0ff4d48b067c2e5ebe9 - Bump PORTREVISION for package change PR: 282388
-rw-r--r--mail/py-pyspf/Makefile2
-rw-r--r--mail/py-pyspf/files/patch-spf.py2
2 files changed, 2 insertions, 2 deletions
diff --git a/mail/py-pyspf/Makefile b/mail/py-pyspf/Makefile
index ccae8db7cd2b..82ef66b65ca3 100644
--- a/mail/py-pyspf/Makefile
+++ b/mail/py-pyspf/Makefile
@@ -1,6 +1,6 @@
PORTNAME= pyspf
PORTVERSION= 2.0.14
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= mail python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/mail/py-pyspf/files/patch-spf.py b/mail/py-pyspf/files/patch-spf.py
index 2ce960adfed7..cf3f978085f2 100644
--- a/mail/py-pyspf/files/patch-spf.py
+++ b/mail/py-pyspf/files/patch-spf.py
@@ -5,7 +5,7 @@
try:
# FIXME: how to disable TCP fallback in dnspython if not tcpfallback?
- answers = dns.resolver.query(name, qtype, lifetime=timeout)
-+ answers = dns.resolver.resolve(name, qtype)
++ answers = dns.resolver.resolve(name, qtype, lifetime=timeout)
for rdata in answers:
if qtype == 'A' or qtype == 'AAAA':
retVal.append(((name, qtype), rdata.address))