aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:03:11 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-05-07 16:03:11 +0000
commit4fd677b1f68ddf5fac449dbba35ff883f181ab4a (patch)
tree68a3d19a4990ebf82e575d58060997a88a5af3f3
parent2013ec8f1860d4dc89ceb2b19e0b199e48ebceab (diff)
downloadports-4fd677b1f68ddf5fac449dbba35ff883f181ab4a.tar.gz
ports-4fd677b1f68ddf5fac449dbba35ff883f181ab4a.zip
devel/libpci: Update to 3.10.0
- Convert FreeBSD 12 extra patch to a normal patch Changes: https://github.com/pciutils/pciutils/blob/master/ChangeLog
-rw-r--r--devel/libpci/Makefile8
-rw-r--r--devel/libpci/distinfo6
-rw-r--r--devel/libpci/files/patch-Makefile16
-rw-r--r--devel/libpci/files/patch-lib-ecam.c14
-rw-r--r--devel/libpci/files/patch-lib-mmio-ports.c (renamed from devel/libpci/files/extra-patch-freebsd12)9
-rw-r--r--devel/libpci/files/patch-lib-pci.h4
6 files changed, 36 insertions, 21 deletions
diff --git a/devel/libpci/Makefile b/devel/libpci/Makefile
index 4437a5fd36c0..71ff576a9d7d 100644
--- a/devel/libpci/Makefile
+++ b/devel/libpci/Makefile
@@ -1,5 +1,5 @@
PORTNAME= libpci
-PORTVERSION= 3.9.0
+PORTVERSION= 3.10.0
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/utils/pciutils \
LOCAL/sunpoet
@@ -32,12 +32,6 @@ LIBPCI_FILES= include/pci/config.h \
lib/libpci.so.3 \
libdata/pkgconfig/libpci.pc
-.include <bsd.port.options.mk>
-
-.if ${OSVERSION} < 1300000
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-freebsd12
-.endif
-
post-patch:
@${LN} -s . ${WRKSRC}/lib/pci
diff --git a/devel/libpci/distinfo b/devel/libpci/distinfo
index bfcd4e97c95c..68aaca78013d 100644
--- a/devel/libpci/distinfo
+++ b/devel/libpci/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1674589494
-SHA256 (pciutils-3.9.0.tar.xz) = cdea7ae97239dee23249a09c68a19a287a3f109fbeb2c232ebb616cb38599012
-SIZE (pciutils-3.9.0.tar.xz) = 431624
+TIMESTAMP = 1683227581
+SHA256 (pciutils-3.10.0.tar.xz) = 238a2e27166730e53a17fe07bfad229e07fa39b618117e5944b6d7eda9fbb0e9
+SIZE (pciutils-3.10.0.tar.xz) = 444080
diff --git a/devel/libpci/files/patch-Makefile b/devel/libpci/files/patch-Makefile
index b4ea1e23a3be..07189e5d7cc7 100644
--- a/devel/libpci/files/patch-Makefile
+++ b/devel/libpci/files/patch-Makefile
@@ -1,16 +1,16 @@
---- Makefile.orig 2022-11-20 11:58:03 UTC
+--- Makefile.orig 2023-05-01 12:59:54 UTC
+++ Makefile
@@ -1,8 +1,8 @@
# Makefile for The PCI Utilities
- # (c) 1998--2022 Martin Mares <mj@ucw.cz>
+ # (c) 1998--2023 Martin Mares <mj@ucw.cz>
-OPT=-O2
-CFLAGS=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
+#OPT=-O2
+CFLAGS+=$(OPT) -Wall -W -Wno-parentheses -Wstrict-prototypes -Wmissing-prototypes
- VERSION=3.9.0
- DATE=2022-11-20
+ VERSION=3.10.0
+ DATE=2023-05-01
@@ -32,11 +32,11 @@ HWDB=
ABI_VERSION=3
@@ -25,18 +25,22 @@
MANDIR:=$(shell if [ -d $(PREFIX)/share/man ] ; then echo $(PREFIX)/share/man ; else echo $(PREFIX)/man ; fi)
INCDIR=$(PREFIX)/include
LIBDIR=$(PREFIX)/lib
-@@ -46,11 +46,11 @@ PKGCFDIR=$(LIBDIR)/pkgconfig
+@@ -45,13 +45,13 @@ PKGCFDIR=$(LIBDIR)/pkgconfig
+ # Commands
INSTALL=install
DIRINSTALL=install -d
- STRIP=-s
-ifdef CROSS_COMPILE
+-STRIP=--strip-program $(CROSS_COMPILE)-strip
-CC=$(CROSS_COMPILE)gcc
-else
+-STRIP=-s
-CC=cc
-endif
+#ifdef CROSS_COMPILE
++#STRIP=--strip-program $(CROSS_COMPILE)-strip
+#CC=$(CROSS_COMPILE)gcc
+#else
++#STRIP=-s
+#CC=cc
+#endif
AR=$(CROSS_COMPILE)ar
diff --git a/devel/libpci/files/patch-lib-ecam.c b/devel/libpci/files/patch-lib-ecam.c
new file mode 100644
index 000000000000..0dab14c851c3
--- /dev/null
+++ b/devel/libpci/files/patch-lib-ecam.c
@@ -0,0 +1,14 @@
+--- lib/ecam.c.orig 2023-03-05 13:45:24 UTC
++++ lib/ecam.c
+@@ -924,7 +924,11 @@ ecam_init(struct pci_access *a)
+ if (!validate_addrs(addrs))
+ a->error("Option ecam.addrs has invalid address format \"%s\".", addrs);
+
++#if defined(O_DSYNC)
+ a->fd = open(devmem, (a->writeable ? O_RDWR : O_RDONLY) | O_DSYNC);
++#else
++ a->fd = open(devmem, (a->writeable ? O_RDWR : O_RDONLY));
++#endif
+ if (a->fd < 0)
+ a->error("Cannot open %s: %s.", devmem, strerror(errno));
+
diff --git a/devel/libpci/files/extra-patch-freebsd12 b/devel/libpci/files/patch-lib-mmio-ports.c
index 23421a6b0491..a357cc2c1406 100644
--- a/devel/libpci/files/extra-patch-freebsd12
+++ b/devel/libpci/files/patch-lib-mmio-ports.c
@@ -1,11 +1,14 @@
---- lib/mmio-ports.c.orig 2022-11-18 13:59:51 UTC
+--- lib/mmio-ports.c.orig 2023-03-04 15:27:09 UTC
+++ lib/mmio-ports.c
-@@ -298,7 +298,7 @@ conf1_init(struct pci_access *a)
+@@ -298,7 +298,11 @@ conf1_init(struct pci_access *a)
if (!validate_addrs(addrs))
a->error("Option %s has invalid address format \"%s\".", addrs_param_name, addrs);
-- a->fd = open(devmem, O_RDWR | O_DSYNC); /* O_DSYNC bypass CPU cache for mmap() on Linux */
++#if defined(O_DSYNC)
+ a->fd = open(devmem, O_RDWR | O_DSYNC); /* O_DSYNC bypass CPU cache for mmap() on Linux */
++#else
+ a->fd = open(devmem, O_RDWR); /* O_DSYNC bypass CPU cache for mmap() on Linux */
++#endif
if (a->fd < 0)
a->error("Cannot open %s: %s.", devmem, strerror(errno));
}
diff --git a/devel/libpci/files/patch-lib-pci.h b/devel/libpci/files/patch-lib-pci.h
index addbf8787c7f..479459659a66 100644
--- a/devel/libpci/files/patch-lib-pci.h
+++ b/devel/libpci/files/patch-lib-pci.h
@@ -1,4 +1,4 @@
---- lib/pci.h.orig 2022-11-20 11:58:19 UTC
+--- lib/pci.h.orig 2023-05-01 13:00:07 UTC
+++ lib/pci.h
@@ -10,11 +10,11 @@
#define _PCI_LIB_H
@@ -13,5 +13,5 @@
+#include "pci/header.h"
+#include "pci/types.h"
- #define PCI_LIB_VERSION 0x030900
+ #define PCI_LIB_VERSION 0x030a00