aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-12-12 09:25:24 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-12-12 09:25:24 +0000
commit506e4ece925777ec59739fab3448104613e08b44 (patch)
tree0dfea0b8b145a4110806e11ac1407c1abfd9fa0d
parentca323aed9461a8d3d695e53b243053fbef56595c (diff)
downloadports-506e4ece925777ec59739fab3448104613e08b44.tar.gz
ports-506e4ece925777ec59739fab3448104613e08b44.zip
- Changed quake-data/Makefile.include to be more similar to bsd.*.mk files,
also it doesn't override port's variables. - Change dependant ports. PR: ports/90145 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=150963
-rw-r--r--games/fuhquake/Makefile2
-rw-r--r--games/quake-data/Makefile3
-rw-r--r--games/quake-data/Makefile.include37
-rw-r--r--games/quake-dpmod/Makefile3
-rw-r--r--games/quake-reaper/Makefile3
-rw-r--r--games/tenebrae/Makefile2
6 files changed, 21 insertions, 29 deletions
diff --git a/games/fuhquake/Makefile b/games/fuhquake/Makefile
index 91e5ec7939bd..f408d0c28ec5 100644
--- a/games/fuhquake/Makefile
+++ b/games/fuhquake/Makefile
@@ -39,6 +39,8 @@ OPTIONS= GLX "Build GLX client" on \
X86_ASM "Enable x86 assembly code" on \
XMMS "Enable MP3 Player feature" off
+DATADIR= ${Q1DIR}
+
.include "${.CURDIR}/../quake-data/Makefile.include"
.include <bsd.port.pre.mk>
diff --git a/games/quake-data/Makefile b/games/quake-data/Makefile
index 29dba8a222a9..3be6138d46f4 100644
--- a/games/quake-data/Makefile
+++ b/games/quake-data/Makefile
@@ -9,6 +9,7 @@ PORTNAME= data
PORTVERSION= 1.0.6
CATEGORIES= games
MASTER_SITES= http://www.libsdl.org/projects/quake/data/:qs
+PKGNAMEPREFIX= ${Q1PKGNAMEPREFIX}
DISTNAME= quakesw-${PORTVERSION}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:qs
DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
@@ -26,6 +27,8 @@ OPTIONS= FULL "Install full version" off \
QUAKEWORLD "Install QuakeWorld data" on \
QUAKEWORLD_SKINS "Install QuakeWorld skins" on
+DATADIR= ${Q1DIR}
+
PROGFILE= qwsv-2.30-glibc-i386-unknown-linux2.0.tar.gz
SKINFILES= skinbase.zip qw_skins.zip
diff --git a/games/quake-data/Makefile.include b/games/quake-data/Makefile.include
index 5e2e3d5afe78..523db43902e4 100644
--- a/games/quake-data/Makefile.include
+++ b/games/quake-data/Makefile.include
@@ -1,39 +1,18 @@
# Makefile for defining variables used by other Quake related ports.
-# Determine if the port is a Quake engine.
+# Set variables.
-Q1ENGINES= quakeforge darkplaces fuhquake tenebrae
+Q1PKGNAMEPREFIX?=quake-
+Q1DIR?= ${LOCALBASE}/share/quake
-.for f in ${Q1ENGINES}
-. if ${PORTNAME} == ${f}
-ENGINE= yes
-. endif
-.endfor
+# Add them to the environment.
-# Package name prefix.
+MAKE_ENV+= Q1DIR="${Q1DIR}"
+PLIST_SUB+= Q1DIR="${Q1DIR:S/${LOCALBASE}\///}"
+SUB_LIST+= Q1DIR="${Q1DIR}"
-Q1PKGNAMEPREFIX=quake-
-
-.if !defined(ENGINE)
-PKGNAMEPREFIX?= ${Q1PKGNAMEPREFIX}
-.endif
-
-# Dependency to "games/quake-data".
+# Add the dependency.
.if ${PORTNAME} != "data"
RUN_DEPENDS+= ${Q1DIR}/id1/pak0.pak:${PORTSDIR}/games/quake-data
.endif
-
-# Installation directories.
-
-Q1DIR= ${LOCALBASE}/share/quake
-
-.if defined(ENGINE) || ${PORTNAME} == "data"
-DATADIR?= ${Q1DIR}
-.else
-DATADIR?= ${Q1DIR}/${PORTNAME}
-.endif
-
-DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-
-PLIST_SUB+= Q1DIR="${Q1DIR}"
diff --git a/games/quake-dpmod/Makefile b/games/quake-dpmod/Makefile
index 7f2b4fb3ac30..0949dd433efe 100644
--- a/games/quake-dpmod/Makefile
+++ b/games/quake-dpmod/Makefile
@@ -9,6 +9,7 @@ PORTNAME= dpmod
PORTVERSION= 20050818
CATEGORIES= games
MASTER_SITES= http://offload1.icculus.org/twilight/darkplaces/files/
+PKGNAMEPREFIX= ${Q1PKGNAMEPREFIX}
DISTNAME= darkplacesmod${PORTVERSION}
MAINTAINER= alejandro@varnet.biz
@@ -20,6 +21,8 @@ USE_ZIP= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
+DATDAIR= ${Q1DIR}/${PORTNAME}
+
post-extract:
# Remove CVS directories
@${FIND} ${WRKDIR} -type d -name CVS -print0 | \
diff --git a/games/quake-reaper/Makefile b/games/quake-reaper/Makefile
index ceaaf2ef9d5d..fe077b7a23ab 100644
--- a/games/quake-reaper/Makefile
+++ b/games/quake-reaper/Makefile
@@ -9,6 +9,7 @@ PORTNAME= reaper
PORTVERSION= 0.81
CATEGORIES= games
MASTER_SITES= http://www.mindspring.com/~win32ch/
+PKGNAMEPREFIX= ${Q1PKGNAMEPREFIX}
DISTNAME= reaprb81
MAINTAINER= alejandro@varnet.biz
@@ -19,6 +20,8 @@ USE_REINPLACE= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
+DATADIR= ${Q1DIR}/${PORTNAME}
+
do-install:
@${MKDIR} ${DATADIR}
.for f in Autoexec.cfg PROGS.DAT
diff --git a/games/tenebrae/Makefile b/games/tenebrae/Makefile
index 4eb4896fe767..9bfc10c66d5b 100644
--- a/games/tenebrae/Makefile
+++ b/games/tenebrae/Makefile
@@ -26,6 +26,8 @@ USE_SDL= yes
USE_REINPLACE= yes
ONLY_FOR_ARCHS= i386
+DATADIR= ${Q1DIR}
+
WRKSRC= ${WRKDIR}/${PORTNAME}_0
BUILD_WRKSRC= ${WRKSRC}/linux
MAKE_ENV= DATADIR="${DATADIR}" \