aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2023-03-08 20:52:24 +0000
committerMatthias Andree <mandree@FreeBSD.org>2023-03-08 20:52:24 +0000
commit50d615894fb6551a1265c9dec9e5e407c4ea8ce0 (patch)
tree3da88fbd3ce96be15becdaa01a8837aab66263c4
parentbc733dffe09ceb5c4e8c158f80b647bb0dbed474 (diff)
downloadports-50d615894fb6551a1265c9dec9e5e407c4ea8ce0.tar.gz
ports-50d615894fb6551a1265c9dec9e5e407c4ea8ce0.zip
security/openvpn: remove header file that now ships with 2.6.1 tarball
Since this is identical to what's in the tarball, no PORTREVISION bump is required.
-rw-r--r--security/openvpn/Makefile3
-rw-r--r--security/openvpn/files/ovpn_dco_freebsd.h71
2 files changed, 1 insertions, 73 deletions
diff --git a/security/openvpn/Makefile b/security/openvpn/Makefile
index 417abba7f421..3956e7db6b84 100644
--- a/security/openvpn/Makefile
+++ b/security/openvpn/Makefile
@@ -46,7 +46,7 @@ OPTIONS_EXCLUDE_FreeBSD_12= DCO # FreeBSD 14 only
OPTIONS_EXCLUDE_FreeBSD_13= DCO # FreeBSD 14 only
ASYNC_PUSH_DESC= Enable async-push support
-DCO_DESC= Build with Data Channel Offload (ovpn(4)) support
+DCO_DESC= Build with Data Channel Offload (ovpn(4)) support
EASYRSA_DESC= Install security/easy-rsa RSA helper package
LZO_DESC= LZO compression (incompatible with LibreSSL)
PKCS11_DESC= Use security/pkcs11-helper, needs same SSL lib!
@@ -110,7 +110,6 @@ post-patch:
${WRKSRC}/sample/sample-config-files/*.conf \
${WRKSRC}/doc/man-sections/generic-options.rst
# this header file was missed from the 2.6.0 tarball
- ${CP} ${FILESDIR}/ovpn_dco_freebsd.h ${WRKSRC}/src/openvpn/ # FIXME remove for 2.6.1
pre-configure:
# just too many of sign-compare; bitwise-instead-of-logical was audited and is intentional,
diff --git a/security/openvpn/files/ovpn_dco_freebsd.h b/security/openvpn/files/ovpn_dco_freebsd.h
deleted file mode 100644
index fec33835f007..000000000000
--- a/security/openvpn/files/ovpn_dco_freebsd.h
+++ /dev/null
@@ -1,71 +0,0 @@
-/*-
- * SPDX-License-Identifier: BSD-2-Clause-FreeBSD
- *
- * Copyright (c) 2021 Rubicon Communications, LLC (Netgate)
- *
- * Redistribution and use in source and binary forms, with or without
- * modification, are permitted provided that the following conditions
- * are met:
- * 1. Redistributions of source code must retain the above copyright
- * notice, this list of conditions and the following disclaimer.
- * 2. Redistributions in binary form must reproduce the above copyright
- * notice, this list of conditions and the following disclaimer in the
- * documentation and/or other materials provided with the distribution.
- *
- * THIS SOFTWARE IS PROVIDED BY THE PROJECT AND CONTRIBUTORS ``AS IS'' AND
- * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
- * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
- * ARE DISCLAIMED. IN NO EVENT SHALL THE PROJECT OR CONTRIBUTORS BE LIABLE
- * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
- * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
- * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
- * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
- * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
- * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
- * SUCH DAMAGE.
- */
-
-#ifndef _NET_IF_OVPN_H_
-#define _NET_IF_OVPN_H_
-
-#include <sys/types.h>
-#include <netinet/in.h>
-
-/* Maximum size of an ioctl request. */
-#define OVPN_MAX_REQUEST_SIZE 4096
-
-enum ovpn_notif_type {
- OVPN_NOTIF_DEL_PEER,
-};
-
-enum ovpn_del_reason {
- OVPN_DEL_REASON_REQUESTED = 0,
- OVPN_DEL_REASON_TIMEOUT = 1
-};
-
-enum ovpn_key_slot {
- OVPN_KEY_SLOT_PRIMARY = 0,
- OVPN_KEY_SLOT_SECONDARY = 1
-};
-
-enum ovpn_key_cipher {
- OVPN_CIPHER_ALG_NONE = 0,
- OVPN_CIPHER_ALG_AES_GCM = 1,
- OVPN_CIPHER_ALG_CHACHA20_POLY1305 = 2
-};
-
-#define OVPN_NEW_PEER _IO('D', 1)
-#define OVPN_DEL_PEER _IO('D', 2)
-#define OVPN_GET_STATS _IO('D', 3)
-#define OVPN_NEW_KEY _IO('D', 4)
-#define OVPN_SWAP_KEYS _IO('D', 5)
-#define OVPN_DEL_KEY _IO('D', 6)
-#define OVPN_SET_PEER _IO('D', 7)
-#define OVPN_START_VPN _IO('D', 8)
-#define OVPN_SEND_PKT _IO('D', 9)
-#define OVPN_POLL_PKT _IO('D', 10)
-#define OVPN_GET_PKT _IO('D', 11)
-#define OVPN_SET_IFMODE _IO('D', 12)
-#define OVPN_GET_PEER_STATS _IO('D', 13)
-
-#endif /* ifndef _NET_IF_OVPN_H_ */