aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-07-11 01:44:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-07-11 01:45:36 +0000
commit510c1361b9887f48c39ab517271e39421b751447 (patch)
tree7ea29fcf22840c2d4e04f51aaac07c1cf607a775
parent79d5c3bdc647cf12d2ded767c957b3eab409fee3 (diff)
downloadports-510c1361b9887f48c39ab517271e39421b751447.tar.gz
ports-510c1361b9887f48c39ab517271e39421b751447.zip
cad/xyce: Correct license; Add/update comments
-rw-r--r--cad/xyce/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/cad/xyce/Makefile b/cad/xyce/Makefile
index cbd54a568a8d..3d5acf9411a5 100644
--- a/cad/xyce/Makefile
+++ b/cad/xyce/Makefile
@@ -9,7 +9,7 @@ DIST_SUBDIR= ${PORTNAME}-${DISTVERSION}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Xyce electronic simulator
-LICENSE= GPLv2
+LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libblas.so:math/blas \
@@ -24,10 +24,9 @@ LIB_DEPENDS= libblas.so:math/blas \
libumfpack.so:math/suitesparse-umfpack
TEST_DEPENDS= git:devel/git \
${PYNUMPY} \
- ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR} \
- # also needs pycompadre
+ ${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-USES= autoreconf bison gmake fortran libtool localbase perl5 python:test # GNU tools should be used for 7.5 and on until the cmake cbuild is declared stable
+USES= autoreconf bison gmake fortran libtool localbase perl5 python:test # GNU tools should be used for 7.5 and on until the cmake build is declared stable
USE_CXXSTD= c++14 # otherwise configure fails because of c++14 features like std::conditional_t
USE_LDCONFIG= yes
USE_PERL5= test
@@ -45,7 +44,7 @@ INSTALL_TARGET= install-strip
BINARY_ALIAS= python=${PYTHON_CMD} # only for tests
-do-test:
+do-test: # one test is known to fail, see https://github.com/Xyce/Xyce/issues/67#issuecomment-1179857728
# checkout tests
@cd ${WRKDIR} && \
${ECHO} "cloning git repository ..." && \