aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2023-12-05 18:07:50 +0000
committerThierry Thomas <thierry@FreeBSD.org>2023-12-05 18:11:27 +0000
commit510dbd1e2012877cbbdc37a38f6189ce7b38d1ba (patch)
tree77c7bea3c31bf8d58f54280164f3356ffe40d827
parentdd37ac872d5164606777732108cdf24f68210688 (diff)
downloadports-510dbd1e2012877cbbdc37a38f6189ce7b38d1ba.tar.gz
ports-510dbd1e2012877cbbdc37a38f6189ce7b38d1ba.zip
lang/gcc12+: forward the installation of ISO_Fortran_binding.h in a separate dir
PR: 275431 Approved by: salvadore@ (maintainer)
-rw-r--r--lang/gcc12-devel/Makefile5
-rw-r--r--lang/gcc12-devel/pkg-plist1
-rw-r--r--lang/gcc13-devel/Makefile5
-rw-r--r--lang/gcc13-devel/pkg-plist1
-rw-r--r--lang/gcc13/Makefile5
-rw-r--r--lang/gcc13/pkg-plist1
-rw-r--r--lang/gcc14-devel/Makefile5
-rw-r--r--lang/gcc14-devel/pkg-plist1
8 files changed, 24 insertions, 0 deletions
diff --git a/lang/gcc12-devel/Makefile b/lang/gcc12-devel/Makefile
index 0a6d834d134f..ea70987deadb 100644
--- a/lang/gcc12-devel/Makefile
+++ b/lang/gcc12-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gcc
PORTVERSION= 12.3.1.s20231201
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
@@ -163,6 +164,10 @@ full-regression-test: build
post-stage:
${RM} ${STAGEDIR}${PREFIX}/man/man7/*
${RM} -r ${STAGEDIR}${TARGLIB}/gcc/*/${GCC_VERSION}/include-fixed/
+ # Install ISO_Fortran_binding.h in an easily findable directory
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/gcc${SUFFIX}
+ ${INSTALL_DATA} ${STAGEDIR}${PREFIX}/lib/gcc${SUFFIX}/gcc/${CONFIGURE_TARGET}/${GCC_VERSION}/include/ISO_Fortran_binding.h \
+ ${STAGEDIR}${PREFIX}/include/gcc${SUFFIX}
# Add target libraries and include files to packaging list.
${RM} ${WRKDIR}/PLIST.lib
diff --git a/lang/gcc12-devel/pkg-plist b/lang/gcc12-devel/pkg-plist
index cada193c9907..4d10bbf6db56 100644
--- a/lang/gcc12-devel/pkg-plist
+++ b/lang/gcc12-devel/pkg-plist
@@ -18,6 +18,7 @@ bin/gcov-dump%%SUFFIX%%
bin/gcov-tool%%SUFFIX%%
bin/gfortran%%SUFFIX%%
bin/lto-dump%%SUFFIX%%
+include/gcc%%SUFFIX%%/ISO_Fortran_binding.h
include/libgccjit++.h
include/libgccjit.h
man/man1/cpp%%SUFFIX%%.1.gz
diff --git a/lang/gcc13-devel/Makefile b/lang/gcc13-devel/Makefile
index 8def32ef5f15..7c0045027683 100644
--- a/lang/gcc13-devel/Makefile
+++ b/lang/gcc13-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gcc
PORTVERSION= 13.2.1.s20231202
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
@@ -165,6 +166,10 @@ full-regression-test: build
post-stage:
${RM} ${STAGEDIR}${PREFIX}/man/man7/*
${RM} -r ${STAGEDIR}${TARGLIB}/gcc/*/${GCC_VERSION}/include-fixed/
+ # Install ISO_Fortran_binding.h in an easily findable directory
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/gcc${SUFFIX}
+ ${INSTALL_DATA} ${STAGEDIR}${PREFIX}/lib/gcc${SUFFIX}/gcc/${CONFIGURE_TARGET}/${GCC_VERSION}/include/ISO_Fortran_binding.h \
+ ${STAGEDIR}${PREFIX}/include/gcc${SUFFIX}
# Add target libraries and include files to packaging list.
${RM} ${WRKDIR}/PLIST.lib
diff --git a/lang/gcc13-devel/pkg-plist b/lang/gcc13-devel/pkg-plist
index cada193c9907..4d10bbf6db56 100644
--- a/lang/gcc13-devel/pkg-plist
+++ b/lang/gcc13-devel/pkg-plist
@@ -18,6 +18,7 @@ bin/gcov-dump%%SUFFIX%%
bin/gcov-tool%%SUFFIX%%
bin/gfortran%%SUFFIX%%
bin/lto-dump%%SUFFIX%%
+include/gcc%%SUFFIX%%/ISO_Fortran_binding.h
include/libgccjit++.h
include/libgccjit.h
man/man1/cpp%%SUFFIX%%.1.gz
diff --git a/lang/gcc13/Makefile b/lang/gcc13/Makefile
index 4118ae6ac87f..19f73a5a0396 100644
--- a/lang/gcc13/Makefile
+++ b/lang/gcc13/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gcc
PORTVERSION= 13.2.0
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= GCC
PKGNAMESUFFIX= ${SUFFIX}
@@ -152,6 +153,10 @@ full-regression-test: build
post-stage:
${RM} ${STAGEDIR}${PREFIX}/man/man7/*
${RM} -r ${STAGEDIR}${TARGLIB}/gcc/*/${GCC_VERSION}/include-fixed/
+ # Install ISO_Fortran_binding.h in an easily findable directory
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/gcc${SUFFIX}
+ ${INSTALL_DATA} ${STAGEDIR}${PREFIX}/lib/gcc${SUFFIX}/gcc/${CONFIGURE_TARGET}/${GCC_VERSION}/include/ISO_Fortran_binding.h \
+ ${STAGEDIR}${PREFIX}/include/gcc${SUFFIX}
# Add target libraries and include files to packaging list.
${RM} ${WRKDIR}/PLIST.lib
diff --git a/lang/gcc13/pkg-plist b/lang/gcc13/pkg-plist
index cada193c9907..4d10bbf6db56 100644
--- a/lang/gcc13/pkg-plist
+++ b/lang/gcc13/pkg-plist
@@ -18,6 +18,7 @@ bin/gcov-dump%%SUFFIX%%
bin/gcov-tool%%SUFFIX%%
bin/gfortran%%SUFFIX%%
bin/lto-dump%%SUFFIX%%
+include/gcc%%SUFFIX%%/ISO_Fortran_binding.h
include/libgccjit++.h
include/libgccjit.h
man/man1/cpp%%SUFFIX%%.1.gz
diff --git a/lang/gcc14-devel/Makefile b/lang/gcc14-devel/Makefile
index de78a0d373e2..64221853a1e3 100644
--- a/lang/gcc14-devel/Makefile
+++ b/lang/gcc14-devel/Makefile
@@ -1,5 +1,6 @@
PORTNAME= gcc
PORTVERSION= 14.0.0.s20231126
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= GCC/snapshots/${DIST_VERSION}
PKGNAMESUFFIX= ${SUFFIX}-devel
@@ -164,6 +165,10 @@ full-regression-test: build
post-stage:
${RM} ${STAGEDIR}${PREFIX}/man/man7/*
${RM} -r ${STAGEDIR}${TARGLIB}/gcc/*/${GCC_VERSION}/include-fixed/
+ # Install ISO_Fortran_binding.h in an easily findable directory
+ ${MKDIR} ${STAGEDIR}${PREFIX}/include/gcc${SUFFIX}
+ ${INSTALL_DATA} ${STAGEDIR}${PREFIX}/lib/gcc${SUFFIX}/gcc/${CONFIGURE_TARGET}/${GCC_VERSION}/include/ISO_Fortran_binding.h \
+ ${STAGEDIR}${PREFIX}/include/gcc${SUFFIX}
# Add target libraries and include files to packaging list.
${RM} ${WRKDIR}/PLIST.lib
diff --git a/lang/gcc14-devel/pkg-plist b/lang/gcc14-devel/pkg-plist
index cada193c9907..4d10bbf6db56 100644
--- a/lang/gcc14-devel/pkg-plist
+++ b/lang/gcc14-devel/pkg-plist
@@ -18,6 +18,7 @@ bin/gcov-dump%%SUFFIX%%
bin/gcov-tool%%SUFFIX%%
bin/gfortran%%SUFFIX%%
bin/lto-dump%%SUFFIX%%
+include/gcc%%SUFFIX%%/ISO_Fortran_binding.h
include/libgccjit++.h
include/libgccjit.h
man/man1/cpp%%SUFFIX%%.1.gz