aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Judge <tj@FreeBSD.org>2016-04-01 03:31:43 +0000
committerTom Judge <tj@FreeBSD.org>2016-04-01 03:31:43 +0000
commit514d265f6669392ab07db76131844693b591e8c5 (patch)
treef5519beedb871ab9f608f0164fcac4278af4e75d
parent47497c19f8717019d2c6776bcac463765e5e1ee1 (diff)
downloadports-514d265f6669392ab07db76131844693b591e8c5.tar.gz
ports-514d265f6669392ab07db76131844693b591e8c5.zip
New port www/py-django-configurations 1.0
django-configurations eases Django project configuration by relying on the composability of Python classes. It extends the notion of Django's module based settings loading with well established object oriented programming patterns. WWW: https://github.com/jazzband/django-configurations
Notes
Notes: svn path=/head/; revision=412312
-rw-r--r--www/Makefile1
-rw-r--r--www/py-django-configurations/Makefile22
-rw-r--r--www/py-django-configurations/distinfo2
-rw-r--r--www/py-django-configurations/pkg-descr5
4 files changed, 30 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 609fead1db6a..8426b92d7f2f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1531,6 +1531,7 @@
SUBDIR += py-django-caching-app-plugins
SUBDIR += py-django-classy-tags
SUBDIR += py-django-cms
+ SUBDIR += py-django-configurations
SUBDIR += py-django-contact-form
SUBDIR += py-django-contrib-comments
SUBDIR += py-django-countries
diff --git a/www/py-django-configurations/Makefile b/www/py-django-configurations/Makefile
new file mode 100644
index 000000000000..4f0d374c9ccc
--- /dev/null
+++ b/www/py-django-configurations/Makefile
@@ -0,0 +1,22 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= configurations
+PORTVERSION= 1.0
+CATEGORIES= www python
+MASTER_SITES= GH
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}django-
+
+MAINTAINER= tj@FreeBSD.org
+COMMENT= Django project configuration using the composability of Python classes
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django18>=0:${PORTSDIR}/www/py-django18
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+USE_GITHUB= yes
+GH_ACCOUNT= jazzband
+GH_PROJECT= django-configurations
+
+.include <bsd.port.mk>
diff --git a/www/py-django-configurations/distinfo b/www/py-django-configurations/distinfo
new file mode 100644
index 000000000000..4a54047a15d9
--- /dev/null
+++ b/www/py-django-configurations/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jazzband-django-configurations-1.0_GH0.tar.gz) = 345564cf1481a0101a59026a2ec0ec8fae51e8a25fe4083c1b2ca6beb911aed9
+SIZE (jazzband-django-configurations-1.0_GH0.tar.gz) = 39308
diff --git a/www/py-django-configurations/pkg-descr b/www/py-django-configurations/pkg-descr
new file mode 100644
index 000000000000..8aa6cf6f76ae
--- /dev/null
+++ b/www/py-django-configurations/pkg-descr
@@ -0,0 +1,5 @@
+django-configurations eases Django project configuration by relying on the
+composability of Python classes. It extends the notion of Django's module based
+settings loading with well established object oriented programming patterns.
+
+WWW: https://github.com/jazzband/django-configurations