aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2022-04-08 12:42:06 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2022-04-13 13:30:25 +0000
commit51638b90e3b459063940f3a7e33c77354f8cd232 (patch)
tree5c39f9f8a66e494a1255f87e26f868c6e183d513
parentf70859f0746ecf4a5dd63764560d8db752f0d2d5 (diff)
downloadports-51638b90e3b459063940f3a7e33c77354f8cd232.tar.gz
ports-51638b90e3b459063940f3a7e33c77354f8cd232.zip
devel/libtool, devel/libltdl: update to 2.4.7
comms/wsjtx: patch configure instead of configure.ac to avoid autotools. The build runs autoconf to regenerate configure but forgets to run libtoolize to update ltmain.sh. PR: 263151 Exp-run by: antoine
-rw-r--r--comms/wsjtx/Makefile5
-rw-r--r--comms/wsjtx/files/hamlib.patch32
-rw-r--r--devel/libltdl/pkg-plist2
-rw-r--r--devel/libtool/Makefile11
-rw-r--r--devel/libtool/Makefile.common5
-rw-r--r--devel/libtool/distinfo5
-rw-r--r--devel/libtool/files/patch-tests_testsuite20
7 files changed, 47 insertions, 33 deletions
diff --git a/comms/wsjtx/Makefile b/comms/wsjtx/Makefile
index e76b13b02844..b06981e2322f 100644
--- a/comms/wsjtx/Makefile
+++ b/comms/wsjtx/Makefile
@@ -9,11 +9,8 @@ COMMENT= Weak signal ham radio communication package
LICENSE= GPLv3
BUILD_DEPENDS= asciidoctor:textproc/rubygem-asciidoctor \
- autoconf>=2.69:devel/autoconf \
- automake>=1.16.1:devel/automake \
a2x:textproc/asciidoc \
git:devel/git \
- libtool:devel/libtool \
${LOCALBASE}/share/xsl/docbook:textproc/docbook-xsl
LIB_DEPENDS= libfftw3.so:math/fftw3 \
libfftw3f.so:math/fftw3-float \
@@ -42,7 +39,7 @@ _PATCHES= wsjtx.patch hamlib.patch
FFLAGS+= -fallow-argument-mismatch
.endif
-_HAMLIB_PATCHES= configure.ac hamlib.pc.in tests/rigtestlibusb.c
+_HAMLIB_PATCHES= configure hamlib.pc.in tests/rigtestlibusb.c
make-hamlib-patch:
${MV} ${FILESDIR}/hamlib.patch ${FILESDIR}/hamlib.patch.old
. for f in ${_HAMLIB_PATCHES}
diff --git a/comms/wsjtx/files/hamlib.patch b/comms/wsjtx/files/hamlib.patch
index c9cb55d808de..448098d51819 100644
--- a/comms/wsjtx/files/hamlib.patch
+++ b/comms/wsjtx/files/hamlib.patch
@@ -1,24 +1,24 @@
---- hamlib/configure.ac.orig 2021-11-03 20:39:16.000000000 -0400
-+++ hamlib/configure.ac 2021-12-28 12:12:44.629890000 -0500
-@@ -269,7 +269,7 @@
- dnl The host_os variable is set by the AC_CANONICAL_HOST macro above.
- AS_CASE(["$host_os"],
- [freebsd*], [
+--- hamlib/configure.orig 2022-01-02 11:10:19.000000000 +0100
++++ hamlib/configure 2022-04-13 12:51:01.174492000 +0200
+@@ -19135,7 +19135,7 @@
+ case "$host_os" in #(
+ freebsd*) :
+
- AM_CPPFLAGS="-I/usr/local/include ${AM_CPPFLAGS}"
+ AM_CPPFLAGS="${AM_CPPFLAGS} -I/usr/local/include"
AM_LDFLAGS="${AM_LDFLAGS} -L/usr/local/lib"
- AC_SUBST([AM_LDFLAGS])],
+ ;; #(
+ darwin* | rhapsody*) :
+@@ -19211,6 +19211,7 @@
+ fi
-@@ -317,6 +317,7 @@
- AC_MSG_RESULT([$cf_with_libusb])
- AM_CONDITIONAL([HAVE_LIBUSB], [test x"${cf_with_libusb}" = "xyes"])
+LIBUSB_LIBS="-lusb"
LIBUSB=""
- AC_ARG_VAR([LIBUSB_CFLAGS], [C compiler flags for libusb, overriding configure defaults])
- AC_ARG_VAR([LIBUSB_LIBS], [linker flags for libusb, overriding configure check (useful for specifying static libusb-1.0.a (see INSTALL))])
---- hamlib/hamlib.pc.in.orig 2021-11-03 20:39:16.000000000 -0400
-+++ hamlib/hamlib.pc.in 2021-12-28 12:19:09.120541000 -0500
+
+
+--- hamlib/hamlib.pc.in.orig 2022-01-02 11:10:11.000000000 +0100
++++ hamlib/hamlib.pc.in 2022-04-13 12:34:36.119285000 +0200
@@ -7,7 +7,6 @@
Description: Library to control radio and rotator equipment.
URL: @PACKAGE_URL@
@@ -29,8 +29,8 @@
-Libs.private: @MATH_LIBS@ @DL_LIBS@ @NET_LIBS@ @PTHREAD_LIBS@
+Libs: -L${libdir} ${libdir}/libhamlib.a
+Libs.private: @MATH_LIBS@ @DL_LIBS@ @NET_LIBS@ @PTHREAD_LIBS@ -lusb
---- hamlib/tests/rigtestlibusb.c.orig 2021-11-03 20:39:16.000000000 -0400
-+++ hamlib/tests/rigtestlibusb.c 2021-12-28 12:12:44.630778000 -0500
+--- hamlib/tests/rigtestlibusb.c.orig 2022-01-02 11:10:11.000000000 +0100
++++ hamlib/tests/rigtestlibusb.c 2022-04-13 12:34:36.119728000 +0200
@@ -115,7 +115,10 @@
printf(" wSpeedSupported: %u\n", ss_usb_cap->wSpeedSupported);
printf(" bFunctionalitySupport: %u\n", ss_usb_cap->bFunctionalitySupport);
diff --git a/devel/libltdl/pkg-plist b/devel/libltdl/pkg-plist
index 9758fd9ba16d..e16d56804daf 100644
--- a/devel/libltdl/pkg-plist
+++ b/devel/libltdl/pkg-plist
@@ -6,4 +6,4 @@ lib/libltdl.a
lib/libltdl.la
lib/libltdl.so
lib/libltdl.so.7
-lib/libltdl.so.7.3.1
+lib/libltdl.so.7.3.2
diff --git a/devel/libtool/Makefile b/devel/libtool/Makefile
index 262518d6520a..e740024c1cc5 100644
--- a/devel/libtool/Makefile
+++ b/devel/libtool/Makefile
@@ -1,7 +1,7 @@
# Created by: Motoyuki Kasahara <m-kasahr@sra.co.jp>
PORTNAME= libtool
-PORTREVISION= 1
+PORTREVISION= 0
COMMENT= Generic shared library support script
@@ -15,14 +15,9 @@ RUN_DEPENDS= gm4:devel/m4
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-ltdl-install
-MAKE_ARGS= MAKEINFOFLAGS=--no-split
-NO_ARCH= yes
-USES+= makeinfo
+TEST_TARGET= check
+NO_ARCH= yes
INFO= libtool
-post-patch:
- @${RM} ${WRKSRC}/doc/*.info*
- @${TOUCH} ${WRKSRC}/doc/libtool.1
-
.include <bsd.port.mk>
diff --git a/devel/libtool/Makefile.common b/devel/libtool/Makefile.common
index a9e1b03e57a4..e819193d5805 100644
--- a/devel/libtool/Makefile.common
+++ b/devel/libtool/Makefile.common
@@ -1,4 +1,4 @@
-PORTVERSION= 2.4.6
+PORTVERSION= 2.4.7
PORTREVISION?= 0 # Leave this zero. Set in Makefile instead.
CATEGORIES= devel
MASTER_SITES= GNU/libtool
@@ -6,8 +6,9 @@ DISTNAME= libtool-${PORTVERSION}
MAINTAINER= tijl@FreeBSD.org
-DISTINFO_FILE= ${.CURDIR}/../libtool/distinfo
USES= cpe gmake tar:xz
CPE_VENDOR= gnu
CPE_PRODUCT= libtool
+
+DISTINFO_FILE= ${.CURDIR}/../libtool/distinfo
diff --git a/devel/libtool/distinfo b/devel/libtool/distinfo
index ad91ca4e3da4..6a90e9d8d11c 100644
--- a/devel/libtool/distinfo
+++ b/devel/libtool/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libtool-2.4.6.tar.xz) = 7c87a8c2c8c0fc9cd5019e402bed4292462d00a718a7cd5f11218153bf28b26f
-SIZE (libtool-2.4.6.tar.xz) = 973080
+TIMESTAMP = 1649420958
+SHA256 (libtool-2.4.7.tar.xz) = 4f7f217f057ce655ff22559ad221a0fd8ef84ad1fc5fcb6990cecc333aa1635d
+SIZE (libtool-2.4.7.tar.xz) = 1016040
diff --git a/devel/libtool/files/patch-tests_testsuite b/devel/libtool/files/patch-tests_testsuite
new file mode 100644
index 000000000000..bd223f4dd39f
--- /dev/null
+++ b/devel/libtool/files/patch-tests_testsuite
@@ -0,0 +1,20 @@
+--- tests/testsuite.orig 2022-03-17 02:45:47 UTC
++++ tests/testsuite
+@@ -8737,7 +8737,7 @@ at_xfail=no
+
+ { set +x
+ $as_echo "$at_srcdir/demo.at:513: case \$host in
+-hppa*|x86_64*|s390*)
++hppa*|amd64*|x86_64*|s390*)
+ # These hosts cannot use non-PIC shared libs
+ exit 77 ;;
+ *-solaris*|*-sunos*)
+@@ -8762,7 +8762,7 @@ fi
+ "
+ at_fn_check_prepare_notrace 'a `...` command substitution' "demo.at:513"
+ ( $at_check_trace; case $host in
+-hppa*|x86_64*|s390*)
++hppa*|amd64*|x86_64*|s390*)
+ # These hosts cannot use non-PIC shared libs
+ exit 77 ;;
+ *-solaris*|*-sunos*)