aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2012-06-27 01:14:01 +0000
committerAlberto Villa <avilla@FreeBSD.org>2012-06-27 01:14:01 +0000
commit519877d020c7f93880bb55cf82465bf64d3c7ff1 (patch)
tree3146a2dddf1eeb6a80f91b73dddaa38e52aadcb1
parent82f44b69fb7fc5f4c2cc8063c48a72fea9e5ace4 (diff)
downloadports-519877d020c7f93880bb55cf82465bf64d3c7ff1.tar.gz
ports-519877d020c7f93880bb55cf82465bf64d3c7ff1.zip
- Detect eigen2 by checking for .pc file, not min. port version.
If a user had eigen3 installed, but not eigen2, the min. port version check would not differentiate between the two. Submitted by: Jason E. Hale <bsdkaffee at gmail.com> via area51
Notes
Notes: svn path=/head/; revision=300056
-rw-r--r--astro/kstars/Makefile2
-rw-r--r--cad/openscad/Makefile2
-rw-r--r--deskutils/kdeplasma-addons/Makefile2
-rw-r--r--editors/calligra/Makefile4
-rw-r--r--science/avogadro/Makefile2
-rw-r--r--science/kalzium/Makefile2
-rw-r--r--science/step/Makefile2
-rw-r--r--x11-themes/kdeartwork4/Makefile2
8 files changed, 9 insertions, 9 deletions
diff --git a/astro/kstars/Makefile b/astro/kstars/Makefile
index ec0d3699b75a..fb4d29351daf 100644
--- a/astro/kstars/Makefile
+++ b/astro/kstars/Makefile
@@ -17,7 +17,7 @@ COMMENT= KDE 4 desktop planetarium
LIB_DEPENDS= cfitsio.0:${PORTSDIR}/astro/cfitsio
-BUILD_DEPENDS= eigen>=2.0.b3:${PORTSDIR}/math/eigen2 \
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2 \
xplanet:${PORTSDIR}/astro/xplanet
RUN_DEPENDS= xplanet:${PORTSDIR}/astro/xplanet
diff --git a/cad/openscad/Makefile b/cad/openscad/Makefile
index 75372e52a0d8..8d816a896fde 100644
--- a/cad/openscad/Makefile
+++ b/cad/openscad/Makefile
@@ -17,7 +17,7 @@ COMMENT= The programmer's solid 3D CAD modeller
BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
flex:${PORTSDIR}/textproc/flex \
- eigen>=2.0.3:${PORTSDIR}/math/eigen2 \
+ ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2 \
${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boost-libs
#RUN_DEPENDS= ${LOCALBASE}/include/boost/tuple/tuple.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= GLU.1:${PORTSDIR}/graphics/libGLU \
diff --git a/deskutils/kdeplasma-addons/Makefile b/deskutils/kdeplasma-addons/Makefile
index 0987d784077a..864a1f90849d 100644
--- a/deskutils/kdeplasma-addons/Makefile
+++ b/deskutils/kdeplasma-addons/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= qalculate.5:${PORTSDIR}/math/libqalculate \
qwt.5:${PORTSDIR}/x11-toolkits/qwt5 \
qca.2:${PORTSDIR}/devel/qca
-BUILD_DEPENDS= eigen>=2.0.b3:${PORTSDIR}/math/eigen2
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2
CONFLICTS_INSTALL= plasma-applet-icontasks-0.[89].*
diff --git a/editors/calligra/Makefile b/editors/calligra/Makefile
index d9729d55a47c..e46485f42f38 100644
--- a/editors/calligra/Makefile
+++ b/editors/calligra/Makefile
@@ -33,7 +33,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
fftw3.6:${PORTSDIR}/math/fftw3 \
tiff.4:${PORTSDIR}/graphics/tiff \
gsl.16:${PORTSDIR}/math/gsl
-BUILD_DEPENDS= eigen>=2.0.b3:${PORTSDIR}/math/eigen2
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2
CONFLICTS= koffice-kde4-2.*
CONFLICTS_BUILD= qt-3.*
@@ -42,7 +42,7 @@ USE_GL= glew
USE_GNOME= glib20 libxml2 libxslt
USE_ICONV= yes
USE_KDE4= kdehier kdelibs kdeprefix libkdcraw okular pimlibs \
- automoc4 sharedmime soprano
+ automoc4 sharedmime soprano
USE_PERL5= yes
USE_QT4= dbus designer gui opengl phonon porting_build qt3support \
qtestlib_build script sql svg webkit xml xmlpatterns \
diff --git a/science/avogadro/Makefile b/science/avogadro/Makefile
index 66fb29a5c13c..c02ef9086ff1 100644
--- a/science/avogadro/Makefile
+++ b/science/avogadro/Makefile
@@ -14,7 +14,7 @@ MASTER_SITES= SF
MAINTAINER= tkjacobsen@gmail.com
COMMENT= An advanced molecular editor and viewer
-BUILD_DEPENDS= eigen>=2.0.3:${PORTSDIR}/math/eigen2
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2
LIB_DEPENDS= openbabel.3:${PORTSDIR}/science/openbabel
USE_LDCONFIG= yes
diff --git a/science/kalzium/Makefile b/science/kalzium/Makefile
index 47252e0a4041..26be80628373 100644
--- a/science/kalzium/Makefile
+++ b/science/kalzium/Makefile
@@ -18,7 +18,7 @@ COMMENT= Periodic table of elements for KDE 4
LIB_DEPENDS= openbabel.3:${PORTSDIR}/science/openbabel \
avogadro.1:${PORTSDIR}/science/avogadro
-BUILD_DEPENDS= eigen>=2.0.b3:${PORTSDIR}/math/eigen2 \
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2 \
${LOCALBASE}/lib/ocaml/facile/facile.a:${PORTSDIR}/math/facile
CONFLICTS= kdeedu-4.[0-6].*
diff --git a/science/step/Makefile b/science/step/Makefile
index 686df6d71f5f..6ae8a6c1f85c 100644
--- a/science/step/Makefile
+++ b/science/step/Makefile
@@ -18,7 +18,7 @@ COMMENT= KDE 4 interactive physics simulator
LIB_DEPENDS= qalculate.5:${PORTSDIR}/math/libqalculate \
gsl.16:${PORTSDIR}/math/gsl
-BUILD_DEPENDS= eigen>=2.0.b3:${PORTSDIR}/math/eigen2
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2
CONFLICTS= kdeedu-4.[0-6].*
diff --git a/x11-themes/kdeartwork4/Makefile b/x11-themes/kdeartwork4/Makefile
index 421ea832ac2f..3fe5a3db386c 100644
--- a/x11-themes/kdeartwork4/Makefile
+++ b/x11-themes/kdeartwork4/Makefile
@@ -14,7 +14,7 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE Artworks Themes
-BUILD_DEPENDS= eigen>=2.0.b1:${PORTSDIR}/math/eigen2
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/eigen2.pc:${PORTSDIR}/math/eigen2
CONFLICTS_INSTALL= kdeaccessibility-4.[0-6].* \
kdebase-workspace-4.5.[0-5] \