aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Bowling <kbowling@FreeBSD.org>2021-10-23 23:42:29 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2021-10-23 23:42:29 +0000
commit51a00e6b949724d82679085d672d3dc4df6b67bf (patch)
tree341ef52ea4ea1f069d04512831240c067f5d43ed
parent8a1517141686b1835374b2d350609ec74c1d11af (diff)
downloadports-51a00e6b949724d82679085d672d3dc4df6b67bf.tar.gz
ports-51a00e6b949724d82679085d672d3dc4df6b67bf.zip
Mk/bsd.default-versions.mk: Update to PostgreSQL 13
PR: 258792 Reviewed by: girgen (pgsql@) Exp-run by: antoine
-rw-r--r--Mk/bsd.default-versions.mk4
-rw-r--r--UPDATING56
2 files changed, 58 insertions, 2 deletions
diff --git a/Mk/bsd.default-versions.mk b/Mk/bsd.default-versions.mk
index cbb84537697f..1dff8bce1d94 100644
--- a/Mk/bsd.default-versions.mk
+++ b/Mk/bsd.default-versions.mk
@@ -105,8 +105,8 @@ _PERL5_FROM_BIN!= ${LOCALBASE}/bin/perl -e 'printf "%vd\n", $$^V;'
_EXPORTED_VARS+= _PERL5_FROM_BIN
PERL5_DEFAULT:= ${_PERL5_FROM_BIN:R}
.endif
-# Possible values: 9.6, 10, 11, 12, 13
-PGSQL_DEFAULT?= 12
+# Possible values: 9.6, 10, 11, 12, 13, 14
+PGSQL_DEFAULT?= 13
# Possible values: 7.3, 7.4, 8.0
PHP_DEFAULT?= 7.4
# Possible values: 2.7, 3.6, 3.7, 3.8, 3.9, 3.10
diff --git a/UPDATING b/UPDATING
index 540154150e82..f4c84f17bc8b 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,62 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20211024:
+ AFFECTS: users of databases/postgresql* and other software using PostgreSQL to run
+ AUTHOR: kbowling@FreeBSD.org
+
+ The default version of PostgreSQL has been switched from 12 to 13.
+ The upgrade procedure can use up twice the space the databases
+ currently needs. If you have a big amount of stored data take a
+ closer look at the manpage of pg_upgrade for avoidance and/or
+ speedup of the upgrade.
+
+ The upgrade instructions consider a basic usage and do not match
+ complex scenarios like replication, sharding, or similar.
+
+ Upgrade instructions:
+
+ First stop your PostgreSQL, create PostgreSQL-binaries and backup your data.
+ If you have another Version of PostgreSQL installed, for example 12.8, your
+ files are named according to this.
+
+ # service postgresql stop
+ # pkg create postgresql12-server postgresql12-contrib
+ # mkdir /tmp/pg-upgrade
+ # tar xf postgresql12-server-12.8.txz -C /tmp/pg-upgrade
+ # tar xf postgresql12-contrib-12.8.txz -C /tmp/pg-upgrade
+ # pkg delete -f databases/postgresql12-server databases/postgresql12-contrib databases/postgresql12-client
+
+ Now update PostgreSQL:
+
+ pkg user:
+ # pkg install databases/postgresql13-server databases/postgresql13-contrib
+ # pkg upgrade
+
+ Portmaster users:
+ # portmaster databases/postgresql13-server databases/postgresql13-contrib
+ # portmaster -a
+
+ Portupgrade users:
+ # portinstall databases/postgresql13-server databases/postgresql13-contrib
+ # portupgrade -a
+
+ After installing the new PostgreSQL version you need to convert
+ all your databases to new version:
+
+ # su -l postgres -c "/usr/local/bin/initdb --encoding=utf-8 --lc-collate=C -D /var/db/postgres/data13 -U postgres"
+ # su -l postgres -c "pg_upgrade -b /tmp/pg-upgrade/usr/local/bin/ -d /var/db/postgres/data12/ -B /usr/local/bin/ -D /var/db/postgres/data13/ -U postgres "
+
+ Now the migration is finished. You can start PostgreSQL again with:
+
+ # service postgresql start
+
+ ATTENTION:
+ 1) The default user changed from "pgsql" to "postgres" in 11. The migration steps above now assume
+ the "postgres" database user and FreeBSD user.
+ 2) See the updating entry 20190829 if you are updating from a release prior to 11.
+ 3) If you use non-default initdb options, you have to adjust the initdb-command accordingly
+
20211023:
AFFECTS: users of www/node
AUTHOR: bhughes@FreeBSD.org