aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2021-04-25 13:56:52 +0000
committerThierry Thomas <thierry@FreeBSD.org>2022-04-20 18:17:05 +0000
commit51d1ea8ed77c6d526c6913c399180a21bd5359d1 (patch)
tree7bdf2e26d93a5326a32f84a6bee4769291779fb3
parenta80e46e547fc776013cb45d592b20f9e65229d3a (diff)
downloadports-51d1ea8ed77c6d526c6913c399180a21bd5359d1.tar.gz
ports-51d1ea8ed77c6d526c6913c399180a21bd5359d1.zip
science/cgnslib: upgrade to v4.3.0
-rw-r--r--science/cgnslib/Makefile7
-rw-r--r--science/cgnslib/distinfo6
-rw-r--r--science/cgnslib/files/patch-src_cgnstools_cgnscalc_CMakeLists.txt18
-rw-r--r--science/cgnslib/files/patch-src_cgnstools_cgnscalc_Makefile.unix15
-rw-r--r--science/cgnslib/files/patch-src_cgnstools_cgnscalc_unitconv.desktop9
-rw-r--r--science/cgnslib/pkg-plist26
6 files changed, 50 insertions, 31 deletions
diff --git a/science/cgnslib/Makefile b/science/cgnslib/Makefile
index 233a534629bb..0611a1aff8d5 100644
--- a/science/cgnslib/Makefile
+++ b/science/cgnslib/Makefile
@@ -1,9 +1,8 @@
# Created by: thierry@pompo.net
PORTNAME= cgnslib
-PORTVERSION= 4.1.2
+PORTVERSION= 4.3.0
DISTVERSIONPREFIX= v
-PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= science
@@ -22,8 +21,10 @@ GH_PROJECT= CGNS
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
+#CMAKE_ARGS= -DOpenGL_GL_PREFERENCE:STRING="GLVND"
+CMAKE_ARGS= -DOpenGL_GL_PREFERENCE:STRING="LEGACY"
+FFLAGS+= -fPIC -std=legacy
TEST_TARGET= test
-FFLAGS+= -std=legacy
OPTIONS_DEFINE= FORTRAN HDF5 TESTS TOOLS
OPTIONS_DEFAULT= FORTRAN HDF5 TESTS TOOLS
diff --git a/science/cgnslib/distinfo b/science/cgnslib/distinfo
index 6d5bdbc70028..6df3776a3716 100644
--- a/science/cgnslib/distinfo
+++ b/science/cgnslib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1599987558
-SHA256 (CGNS-CGNS-v4.1.2_GH0.tar.gz) = 951653956f509b8a64040f1440c77f5ee0e6e2bf0a9eef1248d370f60a400050
-SIZE (CGNS-CGNS-v4.1.2_GH0.tar.gz) = 1416803
+TIMESTAMP = 1650459751
+SHA256 (CGNS-CGNS-v4.3.0_GH0.tar.gz) = 7709eb7d99731dea0dd1eff183f109eaef8d9556624e3fbc34dc5177afc0a032
+SIZE (CGNS-CGNS-v4.3.0_GH0.tar.gz) = 1472044
diff --git a/science/cgnslib/files/patch-src_cgnstools_cgnscalc_CMakeLists.txt b/science/cgnslib/files/patch-src_cgnstools_cgnscalc_CMakeLists.txt
index 49640d79f163..1449a3ba8ef1 100644
--- a/science/cgnslib/files/patch-src_cgnstools_cgnscalc_CMakeLists.txt
+++ b/science/cgnslib/files/patch-src_cgnstools_cgnscalc_CMakeLists.txt
@@ -1,15 +1,15 @@
---- src/cgnstools/cgnscalc/CMakeLists.txt.orig 2020-08-18 19:44:35 UTC
+--- src/cgnstools/cgnscalc/CMakeLists.txt.orig 2021-04-22 21:09:36 UTC
+++ src/cgnstools/cgnscalc/CMakeLists.txt
-@@ -77,10 +77,10 @@ else (WIN32)
- cgnscalc.sh
- DESTINATION bin
- RENAME cgnscalc)
-+ # Do not install as unitconv to avoid a conflicy with XCrySDen
+@@ -80,10 +80,10 @@ else (WIN32)
+ install(PROGRAMS
+ cgnscalc.desktop
+ DESTINATION bin)
++# Do not install as unitconv to avoid a conflict with XCrySDen
install(PROGRAMS
unitconv.sh
- DESTINATION bin
- RENAME unitconv)
+ DESTINATION bin)
- install(FILES
- cgnscalc.tcl
- unitconv.tcl
+ install(PROGRAMS
+ unitconv.desktop
+ DESTINATION bin)
diff --git a/science/cgnslib/files/patch-src_cgnstools_cgnscalc_Makefile.unix b/science/cgnslib/files/patch-src_cgnstools_cgnscalc_Makefile.unix
index b4b8eb9e1ba6..bdcc9d48aa26 100644
--- a/science/cgnslib/files/patch-src_cgnstools_cgnscalc_Makefile.unix
+++ b/science/cgnslib/files/patch-src_cgnstools_cgnscalc_Makefile.unix
@@ -1,14 +1,15 @@
---- src/cgnstools/cgnscalc/Makefile.unix.orig 2020-08-18 19:44:35 UTC
+--- src/cgnstools/cgnscalc/Makefile.unix.orig 2021-04-22 21:09:36 UTC
+++ src/cgnstools/cgnscalc/Makefile.unix
-@@ -45,8 +45,9 @@ install-prog :
- @echo "installing cgnscalc shell scripts to $(BIN_INSTALL_DIR)"
+@@ -46,9 +46,10 @@ install-prog :
@$(INSTALL_PROG) cgnscalc.sh $(BIN_INSTALL_DIR)/cgnscalc
- @chmod +x $(BIN_INSTALL_DIR)/cgnscalc
+ @$(INSTALL_PROG) cgnscalc.desktop $(BIN_INSTALL_DIR)/
+ @chmod +x $(BIN_INSTALL_DIR)/cgnscalc $(BIN_INSTALL_DIR)/cgnscalc.desktop
- @$(INSTALL_PROG) unitconv.sh $(BIN_INSTALL_DIR)/unitconv
-- @chmod +x $(BIN_INSTALL_DIR)/unitconv
-+ # Do not install as unitconv to avoid a conflicy with XCrySDen
++ # Do not install as unitconv to avoid a conflict with XCrySDen
+ @$(INSTALL_PROG) unitconv.sh $(BIN_INSTALL_DIR)/unitconv.sh
-+ @chmod +x $(BIN_INSTALL_DIR)/unitconv.sh
+ @$(INSTALL_PROG) unitconv.desktop $(BIN_INSTALL_DIR)/
+- @chmod +x $(BIN_INSTALL_DIR)/unitconv $(BIN_INSTALL_DIR)/unitconv.desktop
++ @chmod +x $(BIN_INSTALL_DIR)/unitconv.sh $(BIN_INSTALL_DIR)/unitconv.desktop
@if [ ! -f $(EXE_INSTALL_DIR)/cgconfig ] ; then \
echo "installing configuration file to $(EXE_INSTALL_DIR)"; \
$(INSTALL_DATA) ../cgconfig $(EXE_INSTALL_DIR)/cgconfig; \
diff --git a/science/cgnslib/files/patch-src_cgnstools_cgnscalc_unitconv.desktop b/science/cgnslib/files/patch-src_cgnstools_cgnscalc_unitconv.desktop
new file mode 100644
index 000000000000..44ad57c81167
--- /dev/null
+++ b/science/cgnslib/files/patch-src_cgnstools_cgnscalc_unitconv.desktop
@@ -0,0 +1,9 @@
+--- src/cgnstools/cgnscalc/unitconv.desktop.orig 2021-04-22 21:09:36 UTC
++++ src/cgnstools/cgnscalc/unitconv.desktop
+@@ -6,5 +6,5 @@ Name=CGNSunitconv
+ GenericName=Unit conversions tool
+ Terminal=false
+ Categories=Development;
+-Exec="./unitconv"
++Exec="./unitconv.sh"
+ Icon=../share/cgnstools/unitconv.png
diff --git a/science/cgnslib/pkg-plist b/science/cgnslib/pkg-plist
index 86ebc71c99af..e6a28741f291 100644
--- a/science/cgnslib/pkg-plist
+++ b/science/cgnslib/pkg-plist
@@ -1,12 +1,21 @@
%%HDF5%%bin/adf2hdf
-%%HDF5%%bin/hdf2adf
%%TOOLS%%bin/cgconfig
%%TOOLS%%bin/cgnscalc
+%%TOOLS%%bin/cgnscalc.desktop
+bin/cgnscheck
+bin/cgnscompress
+bin/cgnsconvert
+bin/cgnsdiff
+bin/cgnslist
+bin/cgnsnames
%%TOOLS%%bin/cgnsnodes
+%%TOOLS%%bin/cgnsnodes.desktop
%%TOOLS%%bin/cgnsplot
+%%TOOLS%%bin/cgnsplot.desktop
%%TOOLS%%bin/cgnstools/aflr3_to_cgns
%%TOOLS%%bin/cgnstools/calcwish
%%TOOLS%%bin/cgnstools/cgiowish
+%%TOOLS%%bin/cgnstools/cgns_info
%%TOOLS%%bin/cgnstools/cgns_to_aflr3
%%TOOLS%%bin/cgnstools/cgns_to_fast
%%TOOLS%%bin/cgnstools/cgns_to_plot3d
@@ -25,15 +34,12 @@
%%TOOLS%%bin/cgnstools/tetgen_to_cgns
%%TOOLS%%bin/cgnstools/update_ngon
%%TOOLS%%bin/cgnstools/vgrid_to_cgns
+bin/cgnsupdate
%%TOOLS%%bin/cgnsview
+%%TOOLS%%bin/cgnsview.desktop
+%%HDF5%%bin/hdf2adf
+%%TOOLS%%bin/unitconv.desktop
%%TOOLS%%bin/unitconv.sh
-bin/cgnscheck
-bin/cgnscompress
-bin/cgnsconvert
-bin/cgnsdiff
-bin/cgnslist
-bin/cgnsnames
-bin/cgnsupdate
%%FORTRAN%%include/cgns.mod
include/cgnsBuild.defs
include/cgns_io.h
@@ -43,10 +49,12 @@ include/cgnstypes.h
include/cgnstypes_f.h
include/cgnstypes_f03.h
include/cgnswin_f.h
+lib/cmake/cgns/cgns-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/cgns/cgns-targets.cmake
lib/libcgns.a
lib/libcgns.so
lib/libcgns.so.4
-lib/libcgns.so.4.1
+lib/libcgns.so.4.3
%%TOOLS%%share/cgnstools/aflr3.tcl
%%TOOLS%%share/cgnstools/balloon.tcl
%%TOOLS%%share/cgnstools/cgns-icon.xbm