aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-09-30 19:58:20 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-09-30 19:58:20 +0000
commit51ff0091fe4415fbce42958d322e233cee30dd44 (patch)
tree66c0fb3a67a629edacc1fa1eaf67011239045779
parent1932b7bf5efce9b8adca08225feb6c18f3397833 (diff)
downloadports-51ff0091fe4415fbce42958d322e233cee30dd44.tar.gz
ports-51ff0091fe4415fbce42958d322e233cee30dd44.zip
Fix using iconv at ports:
. shells/fish; . games/instead; . www/xapian-omega; . devel/xdg-user-dirs. Submitted by: marino (via e-mail) Approved by: portmgr (bapt, implicit)
Notes
Notes: svn path=/head/; revision=328855
-rw-r--r--devel/xdg-user-dirs/Makefile2
-rw-r--r--games/instead/Makefile1
-rw-r--r--shells/fish/Makefile2
-rw-r--r--www/xapian-omega/Makefile1
4 files changed, 4 insertions, 2 deletions
diff --git a/devel/xdg-user-dirs/Makefile b/devel/xdg-user-dirs/Makefile
index cae724bf9bf1..8b733e17d5fd 100644
--- a/devel/xdg-user-dirs/Makefile
+++ b/devel/xdg-user-dirs/Makefile
@@ -15,7 +15,7 @@ GNU_CONFIGURE= yes
USES= gettext iconv
USE_GMAKE= yes
USE_GNOME= libxslt:build
-LDFLAGS+= -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CFLAGS+= -I${LOCALBASE}/include
MAN1= xdg-user-dir.1 xdg-user-dirs-update.1
diff --git a/games/instead/Makefile b/games/instead/Makefile
index b29e7c805a05..603f05830614 100644
--- a/games/instead/Makefile
+++ b/games/instead/Makefile
@@ -17,6 +17,7 @@ USE_GNOME= gtk20
USE_LUA= 5.1
USE_SDL= sdl image ttf mixer
USES= pkgconfig iconv
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
CONFIGURE_SCRIPT= configure.sh
CONFIGURE_ENV= PREFIX="${PREFIX}"
diff --git a/shells/fish/Makefile b/shells/fish/Makefile
index 6098f7b7d709..8052e80f32ca 100644
--- a/shells/fish/Makefile
+++ b/shells/fish/Makefile
@@ -20,7 +20,7 @@ USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS= --docdir=${WRKDIR}/tmproot
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -pthread
+LDFLAGS+= -L${LOCALBASE}/lib -pthread ${ICONV_LIB}
MAN1= fish.1 fish_indent.1 fish_pager.1 fishd.1 mimedb.1
diff --git a/www/xapian-omega/Makefile b/www/xapian-omega/Makefile
index bff629f02a00..6bf86b86f4ca 100644
--- a/www/xapian-omega/Makefile
+++ b/www/xapian-omega/Makefile
@@ -41,6 +41,7 @@ NO_STAGE= yes
.if ${PORT_OPTIONS:MICONV}
USES+= iconv
+LDFLAGS+= ${ICONV_LIB}
CONFIGURE_ARGS+=--with-iconv
.else
CONFIGURE_ARGS+=--without-iconv