aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2022-05-31 20:01:30 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2022-05-31 20:02:18 +0000
commit522ac45a6940a2ca9717e78280d165df056b20fb (patch)
treeeaf7bf289ff22dde749edf128c2ae9a24d3abff9
parent0e341b87dbfb1ce481520e3f90578248ae6b3ad4 (diff)
downloadports-522ac45a6940a2ca9717e78280d165df056b20fb.tar.gz
ports-522ac45a6940a2ca9717e78280d165df056b20fb.zip
science/quantum-jet: New port: Cross-platform header-only library for simulating quantum circuits
-rw-r--r--science/Makefile1
-rw-r--r--science/quantum-jet/Makefile35
-rw-r--r--science/quantum-jet/distinfo3
-rw-r--r--science/quantum-jet/pkg-descr4
-rw-r--r--science/quantum-jet/pkg-plist18
5 files changed, 61 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index 6433804ff343..cc41e4b7e355 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -355,6 +355,7 @@
SUBDIR += qmcpack
SUBDIR += quantum-espresso
SUBDIR += quantum-espresso-pseudopotentials
+ SUBDIR += quantum-jet
SUBDIR += qwalk
SUBDIR += rdkit
SUBDIR += rmf
diff --git a/science/quantum-jet/Makefile b/science/quantum-jet/Makefile
new file mode 100644
index 000000000000..7c94e153935e
--- /dev/null
+++ b/science/quantum-jet/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= quantum-jet
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.2-2
+DISTVERSIONSUFFIX= -g99c55ce
+CATEGORIES= science # quantum-computing
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Cross-platform header-only library for simulating quantum circuits
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= openblas>0:math/openblas
+RUN_DEPENDS= taskflow>0:devel/taskflow \
+ openblas>0:math/openblas
+TEST_DEPENDS= git:devel/git
+
+USES= cmake:testing compiler:c++17-lang
+
+USE_GITHUB= yes
+GH_ACCOUNT= XanaduAI
+GH_PROJECT= jet
+
+CMAKE_TESTING_ON= BUILD_TESTS
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+do-configure: # no configure because it clones the taskflow repository
+ @${NADA}
+
+do-install: # tests fail to compile, see https://github.com/XanaduAI/jet/issues/77
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} include ${STAGEDIR}${PREFIX}
+
+.include <bsd.port.mk>
diff --git a/science/quantum-jet/distinfo b/science/quantum-jet/distinfo
new file mode 100644
index 000000000000..9655c4c98915
--- /dev/null
+++ b/science/quantum-jet/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1653980414
+SHA256 (XanaduAI-jet-v0.2.2-2-g99c55ce_GH0.tar.gz) = 5b2c40504828c1c89183d9d4fc46ee18e35e6ecc2b27aba43b3683fd49fbf252
+SIZE (XanaduAI-jet-v0.2.2-2-g99c55ce_GH0.tar.gz) = 2428873
diff --git a/science/quantum-jet/pkg-descr b/science/quantum-jet/pkg-descr
new file mode 100644
index 000000000000..d2837c52e1a1
--- /dev/null
+++ b/science/quantum-jet/pkg-descr
@@ -0,0 +1,4 @@
+Jet is a cross-platform library for simulating quantum circuits
+using tensor network contractions.
+
+WWW: https://github.com/XanaduAI/jet
diff --git a/science/quantum-jet/pkg-plist b/science/quantum-jet/pkg-plist
new file mode 100644
index 000000000000..754c416f9521
--- /dev/null
+++ b/science/quantum-jet/pkg-plist
@@ -0,0 +1,18 @@
+include/Jet.hpp
+include/jet/Abort.hpp
+include/jet/CudaTensor.hpp
+include/jet/CudaTensorHelpers.hpp
+include/jet/PathInfo.hpp
+include/jet/TaskBasedContractor.hpp
+include/jet/Tensor.hpp
+include/jet/TensorHelpers.hpp
+include/jet/TensorNetwork.hpp
+include/jet/TensorNetworkIO.hpp
+include/jet/Utilities.hpp
+include/jet/Version.hpp
+include/jet/external/nlohmann/json.hpp
+include/jet/permute/Default.hpp
+include/jet/permute/Hptt.hpp
+include/jet/permute/Permuter.hpp
+include/jet/permute/PermuterIncludes.hpp
+include/jet/permute/QFlex.hpp