aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-12-26 18:08:49 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2021-12-26 18:23:22 +0000
commit529117f533a514559415cae1128f90c4c8f131c4 (patch)
tree58b60ea615aa245a7247119719bdddd5ab22106b
parent04a920dd64070719d8c36f35563d403afa060b61 (diff)
downloadports-529117f533a514559415cae1128f90c4c8f131c4.tar.gz
ports-529117f533a514559415cae1128f90c4c8f131c4.zip
Fix fetch for php*
- Primary hosting provider of php has introduced some sort of checking which is blocking fetch although curl/wget works perfectly. fetch with other --user-agent is also not working at the moment. An issue has been opened with the upstream which can be found at: https://github.com/php/web-php/issues/483 - Untill this is fixed add php Github distributions URL to MASTER_SITES - Modify MASTER_SITES for php[73|74|80] and remove SUBDIR as it affects DIST_SUBDIR - Add DIST_SUBDIR as Github is IPv4 only which affects IPv6 only builders. In case someone is running IPv6 only builders distcache will pickup and serve. - Although distinfo has been updated as we have added DIST_SUBDIR but SHA256 and SIZE are unchanged. In case someone needs to verify those are available from https://www.php.net/downloads - We might have done some drastic changes but we are on the brink of quarterly build and we do not want to start a new year and a new quarter with BROKEN php and thousands of other ports. PR: 260699 Reported by: chris@cretaforce.gr Approved by: portmgr (blanket infrastructure) Sponsored by: Bounce Experts
-rw-r--r--Mk/bsd.sites.mk5
-rw-r--r--lang/php73/Makefile3
-rw-r--r--lang/php73/distinfo6
-rw-r--r--lang/php74/Makefile3
-rw-r--r--lang/php74/distinfo6
-rw-r--r--lang/php80/Makefile3
-rw-r--r--lang/php80/distinfo6
7 files changed, 19 insertions, 13 deletions
diff --git a/Mk/bsd.sites.mk b/Mk/bsd.sites.mk
index ac66be4d02e8..f77e304b71c7 100644
--- a/Mk/bsd.sites.mk
+++ b/Mk/bsd.sites.mk
@@ -970,9 +970,12 @@ MASTER_SITE_PGSQL+= \
https://ftp.postgresql.org/pub/%SUBDIR%/
.endif
+# Currently MyraCloud is blocking fetch. Hence add php Github distributions
+# untill it is fixed.
.if !defined(IGNORE_MASTER_SITE_PHP)
MASTER_SITE_PHP+= \
- https://www.php.net/%SUBDIR%/
+ https://www.php.net/distributions/ \
+ https://raw.githubusercontent.com/php/web-php-distributions/master/
.endif
.if !defined(IGNORE_MASTER_SITE_PYTHON)
diff --git a/lang/php73/Makefile b/lang/php73/Makefile
index 283e36d84053..7e4d414f12cb 100644
--- a/lang/php73/Makefile
+++ b/lang/php73/Makefile
@@ -2,8 +2,9 @@ PORTNAME= php73
DISTVERSION= 7.3.33
PORTREVISION?= 0
CATEGORIES?= lang devel www
-MASTER_SITES= PHP/distributions
+MASTER_SITES= PHP
DISTNAME= php-${DISTVERSION}
+DIST_SUBDIR= php
MAINTAINER= tz@FreeBSD.org
COMMENT= PHP Scripting Language
diff --git a/lang/php73/distinfo b/lang/php73/distinfo
index ef5674b888d5..4bc3efd9082a 100644
--- a/lang/php73/distinfo
+++ b/lang/php73/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1637348769
-SHA256 (php-7.3.33.tar.xz) = 166eaccde933381da9516a2b70ad0f447d7cec4b603d07b9a916032b215b90cc
-SIZE (php-7.3.33.tar.xz) = 12143820
+TIMESTAMP = 1640541366
+SHA256 (php/php-7.3.33.tar.xz) = 166eaccde933381da9516a2b70ad0f447d7cec4b603d07b9a916032b215b90cc
+SIZE (php/php-7.3.33.tar.xz) = 12143820
diff --git a/lang/php74/Makefile b/lang/php74/Makefile
index 6ea41959830e..998034541d9c 100644
--- a/lang/php74/Makefile
+++ b/lang/php74/Makefile
@@ -2,8 +2,9 @@ PORTNAME= php74
DISTVERSION= 7.4.27
PORTREVISION?= 0
CATEGORIES?= lang devel www
-MASTER_SITES= PHP/distributions
+MASTER_SITES= PHP
DISTNAME= php-${DISTVERSION}
+DIST_SUBDIR= php
MAINTAINER= tz@FreeBSD.org
COMMENT= PHP Scripting Language
diff --git a/lang/php74/distinfo b/lang/php74/distinfo
index be3754334520..4d66194d8b5c 100644
--- a/lang/php74/distinfo
+++ b/lang/php74/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1640242507
-SHA256 (php-7.4.27.tar.xz) = 3f8b937310f155822752229c2c2feb8cc2621e25a728e7b94d0d74c128c43d0c
-SIZE (php-7.4.27.tar.xz) = 10419380
+TIMESTAMP = 1640541720
+SHA256 (php/php-7.4.27.tar.xz) = 3f8b937310f155822752229c2c2feb8cc2621e25a728e7b94d0d74c128c43d0c
+SIZE (php/php-7.4.27.tar.xz) = 10419380
diff --git a/lang/php80/Makefile b/lang/php80/Makefile
index 00088f9682c7..5991c9b1339d 100644
--- a/lang/php80/Makefile
+++ b/lang/php80/Makefile
@@ -2,8 +2,9 @@ PORTNAME= php80
DISTVERSION= 8.0.13
PORTREVISION?= 0
CATEGORIES?= lang devel www
-MASTER_SITES= PHP/distributions
+MASTER_SITES= PHP
DISTNAME= php-${DISTVERSION}
+DIST_SUBDIR= php
MAINTAINER= tz@FreeBSD.org
COMMENT= PHP Scripting Language
diff --git a/lang/php80/distinfo b/lang/php80/distinfo
index 8754c07f4489..82e50ea21c8f 100644
--- a/lang/php80/distinfo
+++ b/lang/php80/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1637349092
-SHA256 (php-8.0.13.tar.xz) = cd976805ec2e9198417651027dfe16854ba2c2c388151ab9d4d268513d52ed52
-SIZE (php-8.0.13.tar.xz) = 10854284
+TIMESTAMP = 1640541762
+SHA256 (php/php-8.0.13.tar.xz) = cd976805ec2e9198417651027dfe16854ba2c2c388151ab9d4d268513d52ed52
+SIZE (php/php-8.0.13.tar.xz) = 10854284