aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-12-01 15:12:48 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-12-01 15:47:14 +0000
commit52bbede93d769c17286ece1c0e66285bbb070dae (patch)
treefc13ab4c647b3170b088d181e20be7d004cf3fe4
parentbfee83e3a0be489b8e54d647ca4d1add4cf5c9be (diff)
downloadports-52bbede93d769c17286ece1c0e66285bbb070dae.tar.gz
ports-52bbede93d769c17286ece1c0e66285bbb070dae.zip
x11-wm/wayfire: update to 0.7.5
-rw-r--r--x11-wm/wayfire-plugins-extra/Makefile7
-rw-r--r--x11-wm/wayfire-plugins-extra/distinfo8
-rw-r--r--x11-wm/wayfire-plugins-extra/files/patch-wlroots-0.1624
-rw-r--r--x11-wm/wayfire/Makefile6
-rw-r--r--x11-wm/wayfire/distinfo6
-rw-r--r--x11/wcm/Makefile1
-rw-r--r--x11/wf-shell/Makefile1
7 files changed, 33 insertions, 20 deletions
diff --git a/x11-wm/wayfire-plugins-extra/Makefile b/x11-wm/wayfire-plugins-extra/Makefile
index 7dcd133c0626..70ca5507e2d5 100644
--- a/x11-wm/wayfire-plugins-extra/Makefile
+++ b/x11-wm/wayfire-plugins-extra/Makefile
@@ -1,12 +1,8 @@
PORTNAME= wayfire-plugins-extra
DISTVERSIONPREFIX= v
-DISTVERSION= 0.7.0
-PORTREVISION= 6
+DISTVERSION= 0.7.5
CATEGORIES= x11-wm wayland
-PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
-PATCHFILES+= cf95ac721fb1.patch:-p1 # https://github.com/WayfireWM/wayfire-plugins-extra/pull/127
-
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Additional plugins for Wayfire
WWW= https://wayfire.org/
@@ -50,5 +46,4 @@ post-patch:
@${REINPLACE_CMD} 's,/usr/share,${DATADIR:H},' \
${WRKSRC}/subprojects/windecor/deco-theme.cpp
-.include "${.CURDIR:H:H}/x11-toolkits/wlroots015/override.mk"
.include <bsd.port.mk>
diff --git a/x11-wm/wayfire-plugins-extra/distinfo b/x11-wm/wayfire-plugins-extra/distinfo
index 555c783185a8..140f566cfb82 100644
--- a/x11-wm/wayfire-plugins-extra/distinfo
+++ b/x11-wm/wayfire-plugins-extra/distinfo
@@ -1,9 +1,7 @@
-TIMESTAMP = 1611938557
-SHA256 (WayfireWM-wayfire-plugins-extra-v0.7.0_GH0.tar.gz) = e6377e7f2cd6b0a19fe0a256c819f801ee1d963524ed4e4930b702474bc04287
-SIZE (WayfireWM-wayfire-plugins-extra-v0.7.0_GH0.tar.gz) = 50385
+TIMESTAMP = 1669908612
+SHA256 (WayfireWM-wayfire-plugins-extra-v0.7.5_GH0.tar.gz) = 70418f29ecf9e3cb9c5313302ded125048d1493d57e4e5146f30363c5c954840
+SIZE (WayfireWM-wayfire-plugins-extra-v0.7.5_GH0.tar.gz) = 50246
SHA256 (damianatorrpm-wayfire-plugin_dbus_interface-c705bf1_GH0.tar.gz) = 1eef146ea1077b69aa2ec1afdf51dc1a7831d7661c43b9b10ea68a39b7c50ac3
SIZE (damianatorrpm-wayfire-plugin_dbus_interface-c705bf1_GH0.tar.gz) = 30095
SHA256 (wayfireplugins-windecor-6ad31bfc10c5d39c0da7c68fa435064effad6381_GL0.tar.gz) = d3c739481faad2abc4391f165ebcd52a8fde1b062038bdbefcc1540a2dbbeed2
SIZE (wayfireplugins-windecor-6ad31bfc10c5d39c0da7c68fa435064effad6381_GL0.tar.gz) = 16547
-SHA256 (cf95ac721fb1.patch) = 8f059e60e438c3ff9f0b62071b69f567895f399ab8b44f386189a1571e4e1616
-SIZE (cf95ac721fb1.patch) = 6562
diff --git a/x11-wm/wayfire-plugins-extra/files/patch-wlroots-0.16 b/x11-wm/wayfire-plugins-extra/files/patch-wlroots-0.16
new file mode 100644
index 000000000000..4eef4852c0ef
--- /dev/null
+++ b/x11-wm/wayfire-plugins-extra/files/patch-wlroots-0.16
@@ -0,0 +1,24 @@
+https://github.com/damianatorrpm/wayfire-plugin_dbus_interface/issues/50
+
+--- subprojects/dbus/dbus_interface.cpp.orig 2020-12-25 14:04:08 UTC
++++ subprojects/dbus/dbus_interface.cpp
+@@ -198,15 +198,15 @@ class dbus_interface_t
+ #endif
+ wf::pointf_t cursor_position;
+ GVariant* signal_data;
+- wf::input_event_signal<wlr_event_pointer_button>* wf_ev;
+- wlr_event_pointer_button* wlr_signal;
++ wf::input_event_signal<wlr_pointer_button_event>* wf_ev;
++ wlr_pointer_button_event* wlr_signal;
+ wlr_button_state button_state;
+ bool button_released;
+ uint32_t button;
+
+ cursor_position = core.get_cursor_position();
+- wf_ev = static_cast<wf::input_event_signal<wlr_event_pointer_button>*> (data);
+- wlr_signal = static_cast<wlr_event_pointer_button*> (wf_ev->event);
++ wf_ev = static_cast<wf::input_event_signal<wlr_pointer_button_event>*> (data);
++ wlr_signal = static_cast<wlr_pointer_button_event*> (wf_ev->event);
+ button_state = wlr_signal->state;
+ button = wlr_signal->button;
+ button_released = (button_state == WLR_BUTTON_RELEASED);
diff --git a/x11-wm/wayfire/Makefile b/x11-wm/wayfire/Makefile
index 663cac4e582d..4e0a77f4377b 100644
--- a/x11-wm/wayfire/Makefile
+++ b/x11-wm/wayfire/Makefile
@@ -1,7 +1,6 @@
PORTNAME= wayfire
DISTVERSIONPREFIX= v
-DISTVERSION= 0.7.4
-PORTREVISION= 1
+DISTVERSION= 0.7.5
CATEGORIES= x11-wm wayland
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -19,7 +18,7 @@ BUILD_DEPENDS= evdev-proto>0:devel/evdev-proto \
${LOCALBASE}/include/xf86drmMode.h:graphics/libdrm \
wayland-protocols>=1.12:graphics/wayland-protocols \
glm>=0.9.8:math/glm \
- wlroots>=0.15.0<0.16.0:x11-toolkits/wlroots
+ wlroots>=0.16.0<0.17.0:x11-toolkits/wlroots
LIB_DEPENDS= libinotify.so:devel/libinotify \
libwf-config.so:devel/wf-config \
libpng.so:graphics/png \
@@ -54,5 +53,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.ini ${STAGEDIR}${EXAMPLESDIR}
# Keep override.mk in sync with x11/wcm + x11/wf-shell
-.include "${.CURDIR:H:H}/x11-toolkits/wlroots015/override.mk"
.include <bsd.port.mk>
diff --git a/x11-wm/wayfire/distinfo b/x11-wm/wayfire/distinfo
index 8c112e8b2d12..54486fb52bc6 100644
--- a/x11-wm/wayfire/distinfo
+++ b/x11-wm/wayfire/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1659273682
-SHA256 (WayfireWM-wayfire-v0.7.4_GH0.tar.gz) = 343093e3b062383d2a6965ca09eb26d0f68cb897d8efeb69f4967679bb128c8e
-SIZE (WayfireWM-wayfire-v0.7.4_GH0.tar.gz) = 364792
+TIMESTAMP = 1669907568
+SHA256 (WayfireWM-wayfire-v0.7.5_GH0.tar.gz) = ae9a44d3ddcdf97b2dbe2baeeaf880f24f95bfb18e11e1dd5ad7443c26c5e19e
+SIZE (WayfireWM-wayfire-v0.7.5_GH0.tar.gz) = 365235
SHA256 (WayfireWM-wf-touch-8974eb0_GH0.tar.gz) = 3d66a67b35452741135420caf43ba349d35fc64643b8e223e6cdf74dbcef33aa
SIZE (WayfireWM-wf-touch-8974eb0_GH0.tar.gz) = 9881
SHA256 (WayfireWM-wf-utils-889fdaf_GH0.tar.gz) = 8848592f4a04dec60c3e09a996f15d1f86e79f544eda4519f2b3d9dc91997db3
diff --git a/x11/wcm/Makefile b/x11/wcm/Makefile
index b088dd3be163..e110dd76ab45 100644
--- a/x11/wcm/Makefile
+++ b/x11/wcm/Makefile
@@ -35,5 +35,4 @@ WFSHELL_DESC= Build with wf-shell support
WFSHELL_BUILD_DEPENDS= wf-shell>0:x11/wf-shell
WFSHELL_MESON_ENABLED= wf_shell
-.include "${.CURDIR:H:H}/x11-toolkits/wlroots015/override.mk"
.include <bsd.port.mk>
diff --git a/x11/wf-shell/Makefile b/x11/wf-shell/Makefile
index 71c04aa613ab..c572a5c88c48 100644
--- a/x11/wf-shell/Makefile
+++ b/x11/wf-shell/Makefile
@@ -47,5 +47,4 @@ post-patch:
${WRKSRC}/src/dock/toplevel-icon.cpp \
${WRKSRC}/src/panel/widgets/window-list/toplevel.cpp
-.include "${.CURDIR:H:H}/x11-toolkits/wlroots015/override.mk"
.include <bsd.port.mk>