aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-12-11 12:33:58 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-12-11 12:33:58 +0000
commit5302808264fe518af161d5376b4a46a205979369 (patch)
tree3ae131089da64fbe3dd149961bf243e7ba16bd91
parent8ddec8c585a281d969bc31243b351d35d33093c6 (diff)
downloadports-5302808264fe518af161d5376b4a46a205979369.tar.gz
ports-5302808264fe518af161d5376b4a46a205979369.zip
- Add patches to fix build with clang and recent gcc [1]
- Trim Makefile header PR: ports/172213 [1] Submitted by: mbsd <mbsd at isgroup.com.ua>
Notes
Notes: svn path=/head/; revision=308683
-rw-r--r--textproc/stardict3/Makefile6
-rw-r--r--textproc/stardict3/files/patch-dict__tests__t_lookupdata.cpp13
-rw-r--r--textproc/stardict3/files/patch-lib__src__libcommon.cpp11
-rw-r--r--textproc/stardict3/files/patch-lib__src__libcommon.h11
4 files changed, 36 insertions, 5 deletions
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index 9e7fb184a3d0..06eaf3e3f666 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: stardict3
-# Date created: 23 July 2008
-# Whom: eric
-#
+# Created by: eric
# $FreeBSD$
-#
PORTNAME= stardict
PORTVERSION= 3.0.3
diff --git a/textproc/stardict3/files/patch-dict__tests__t_lookupdata.cpp b/textproc/stardict3/files/patch-dict__tests__t_lookupdata.cpp
new file mode 100644
index 000000000000..d14875b7b060
--- /dev/null
+++ b/textproc/stardict3/files/patch-dict__tests__t_lookupdata.cpp
@@ -0,0 +1,13 @@
+--- ./dict/tests/t_lookupdata.cpp.orig 2012-12-11 08:15:24.000000000 +0000
++++ ./dict/tests/t_lookupdata.cpp 2012-12-11 08:29:56.172016591 +0000
+@@ -38,8 +38,8 @@
+ List dict_list;
+ libs.load(dict_list);
+ std::vector<InstantDictIndex> dictmask;
+- std::vector<gchar *> reslist[dictmask.size()];
+- if (libs.LookupData("letter", reslist, NULL, NULL, NULL, dictmask))
++ std::vector< std::vector<gchar *> > reslist(dictmask.size());
++ if (libs.LookupData("letter", &reslist[0], NULL, NULL, NULL, dictmask))
+ return EXIT_SUCCESS;
+ else
+ return EXIT_FAILURE;
diff --git a/textproc/stardict3/files/patch-lib__src__libcommon.cpp b/textproc/stardict3/files/patch-lib__src__libcommon.cpp
new file mode 100644
index 000000000000..18cc56dcbcd3
--- /dev/null
+++ b/textproc/stardict3/files/patch-lib__src__libcommon.cpp
@@ -0,0 +1,11 @@
+--- ./lib/src/libcommon.cpp.orig 2011-07-08 12:35:48.000000000 +0000
++++ ./lib/src/libcommon.cpp 2012-12-11 07:48:00.601016758 +0000
+@@ -599,7 +599,7 @@
+
+ int unpack_zlib(const char* arch_file_name, const char* out_file_name)
+ {
+- zip::gzFile in(gzopen(arch_file_name, "rb"));
++ zip::gzFileWrapper in(gzopen(arch_file_name, "rb"));
+ if(!in) {
+ g_critical("Unable to open archive file: %s.", arch_file_name);
+ return EXIT_FAILURE;
diff --git a/textproc/stardict3/files/patch-lib__src__libcommon.h b/textproc/stardict3/files/patch-lib__src__libcommon.h
new file mode 100644
index 000000000000..44667b4e0c4f
--- /dev/null
+++ b/textproc/stardict3/files/patch-lib__src__libcommon.h
@@ -0,0 +1,11 @@
+--- ./lib/src/libcommon.h.orig 2011-07-08 12:32:09.000000000 +0000
++++ ./lib/src/libcommon.h 2012-12-11 07:48:00.604014902 +0000
+@@ -188,7 +188,7 @@
+ }
+
+ namespace zip {
+-typedef ResourceWrapper<void, void*, int, gzclose> gzFile;
++typedef ResourceWrapper<struct gzFile_s, struct gzFile_s *, int, gzclose> gzFileWrapper;
+ }
+
+ /* Create a new temporary file. Return file name in file name encoding.