aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-15 12:20:47 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-15 12:55:45 +0000
commit530f87719f8e57f1dd875fa3f226067423a20952 (patch)
tree2aa25dc3d3f51076ed533c349870f0502a96e845
parente841c23b1f29f5a798de620438f74371f3462a87 (diff)
downloadports-530f87719f8e57f1dd875fa3f226067423a20952.tar.gz
ports-530f87719f8e57f1dd875fa3f226067423a20952.zip
science/libtensorflow1: Mark DEPRECATED
- Broken for more than a year - Set EXPIRATION_DATE to 2024-01-01 - Pet portclippy Approved by: portmgr (blanket)
-rw-r--r--science/libtensorflow1/Makefile30
1 files changed, 13 insertions, 17 deletions
diff --git a/science/libtensorflow1/Makefile b/science/libtensorflow1/Makefile
index 8a152146a8e3..cd0ac8b10120 100644
--- a/science/libtensorflow1/Makefile
+++ b/science/libtensorflow1/Makefile
@@ -17,6 +17,8 @@ LICENSE_FILE_THIRD_PARTY_TF_C_LICENSES= ${WRKDIR}/THIRD_PARTY_TF_C_LICENSES
LICENSE_PERMS_THIRD_PARTY_TF_C_LICENSES= dist-mirror dist-sell \
pkg-mirror pkg-sell auto-accept
+DEPRECATED= Broken for more than a year
+EXPIRATION_DATE= 2024-01-15
BROKEN= does not build: tries to fetch during the build
ONLY_FOR_ARCHS= amd64
@@ -26,13 +28,11 @@ BUILD_DEPENDS= bash:shells/bash \
FLAVORS= default noavx
FLAVOR?= ${FLAVORS:[1]}
+default_CONFLICTS_INSTALL= libtensorflow1-noavx
noavx_PKGNAMESUFFIX= -noavx
noavx_CONFLICTS_INSTALL= libtensorflow1
-default_CONFLICTS_INSTALL= libtensorflow1-noavx
-CONFLICTS_INSTALL= science/libtensorflow2
USES= gmake python:3.8-3.9,build
-
USE_GITHUB= yes
GH_ACCOUNT= tensorflow
GH_PROJECT= tensorflow
@@ -76,9 +76,10 @@ GH_TUPLE= bazelbuild:rules_closure:308b05b2:bazelbuild_rules_closure \
NervanaSystems:ngraph-tf:v0.9.0:NervanaSystems_ngraph_tf \
pybind:pybind11:v2.3.0:pybind_pybind11 \
GrahamDumpleton:wrapt:1.11.1:GrahamDumpleton_wrapt
-
USE_LDCONFIG= yes
+CONFLICTS_INSTALL= science/libtensorflow2
+
CC?= clang
BINARY_ALIAS= python3=${PYTHON_CMD} python=${PYTHON_CMD}
@@ -95,29 +96,24 @@ OPTIONS_SINGLE_CPUFEATURE= AVX AVX2 NOAVX
OPTIONS_EXCLUDE:= ${OPTIONS_SINGLE_CPUFEATURE}
.endif
+AVX2_DESC= Enable Advanced Vector Extensions v2 (AVX2)
+AVX_DESC= Enable Advanced Vector Extensions (AVX)
CPUFEATURE_DESC=Vector Processing Extensions
-
+CUDA_DESC= Enable Compute Unified Device Architecture (CUDA) for Nvidia GPUs
NOAVX_DESC= Disable Advanced Vector Extensions
-AVX_DESC= Enable Advanced Vector Extensions (AVX)
-AVX2_DESC= Enable Advanced Vector Extensions v2 (AVX2)
+OPENCL_SYCL_DESC= Enable OpenCL Sycl
+ROCM_DESC= Enable Radeon Open Computer (ROCm) for AMD GPUs
+XLA_DESC= Enable Accelerated Linear Algebra (XLA)
-NOAVX_VARS= BAZEL_ARGS=""
-AVX_VARS= BAZEL_ARGS="--copt=-march=core-avx-i --host_copt=-march=core-avx-i"
AVX2_VARS= BAZEL_ARGS="--copt=-march=core-avx2 --host_copt=-march=core-avx2"
-
-CUDA_DESC= Enable Compute Unified Device Architecture (CUDA) for Nvidia GPUs
+AVX_VARS= BAZEL_ARGS="--copt=-march=core-avx-i --host_copt=-march=core-avx-i"
CUDA_VARS= TF_ENABLE_CUDA=1
CUDA_VARS_OFF= TF_ENABLE_CUDA=0
-
-OPENCL_SYCL_DESC= Enable OpenCL Sycl
+NOAVX_VARS= BAZEL_ARGS=""
OPENCL_SYCL_VARS= TF_NEED_OPENCL_SYCL=1
OPENCL_SYCL_VARS_OFF= TF_NEED_OPENCL_SYCL=0
-
-ROCM_DESC= Enable Radeon Open Computer (ROCm) for AMD GPUs
ROCM_VARS= TF_ENABLE_ROCM=1
ROCM_VARS_OFF= TF_ENABLE_ROCM=0
-
-XLA_DESC= Enable Accelerated Linear Algebra (XLA)
XLA_VARS= TF_ENABLE_XLA=1
XLA_VARS_OFF= TF_ENABLE_XLA=0