aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2022-04-08 14:31:53 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2022-12-25 22:12:15 +0000
commit5325ea5ae199c461c0dce63075d2d90c095b80fd (patch)
treeeabd8d4f90c4a78fc34f15f9e6bc08d946aea59d
parent4a51f972d1a9db6aa1bb93873b74674e4323049d (diff)
downloadports-5325ea5ae199c461c0dce63075d2d90c095b80fd.tar.gz
ports-5325ea5ae199c461c0dce63075d2d90c095b80fd.zip
devel/libtool: Fix cross compiled packages
The libtool script is generated for a given compiler so Poudriere cannot use a cross compiler. lang/python* ports have a similar problem. PR: 230018
-rw-r--r--devel/libtool/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/devel/libtool/Makefile b/devel/libtool/Makefile
index 5121661dc23c..338a975d2990 100644
--- a/devel/libtool/Makefile
+++ b/devel/libtool/Makefile
@@ -19,4 +19,11 @@ TEST_TARGET= check
NO_ARCH= yes
INFO= libtool
+.if "${CC}" == "/nxb-bin/usr/bin/cc"
+# Generate libtool script for the native compiler, not the cross compiler.
+CC= cc
+CXX= c++
+LD= ld
+.endif
+
.include <bsd.port.mk>