aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-06-06 13:36:39 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-06-06 13:36:39 +0000
commit539331c4d9e500b1772f05cbaf01d83bcbe60db6 (patch)
tree4b7f4a6c26b9876a1173be958fa24ea5720a0ada
parenta15cbc06b0bcda4b360e7ee70bb837a7513b9dc0 (diff)
downloadports-539331c4d9e500b1772f05cbaf01d83bcbe60db6.tar.gz
ports-539331c4d9e500b1772f05cbaf01d83bcbe60db6.zip
Initial import of ubench - yet another *nix benchmarking utility.
PR: 19049 Submitted by: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
Notes
Notes: svn path=/head/; revision=29261
-rw-r--r--benchmarks/ubench/Makefile20
-rw-r--r--benchmarks/ubench/distinfo1
-rw-r--r--benchmarks/ubench/files/patch-aa38
-rw-r--r--benchmarks/ubench/files/patch-ab11
-rw-r--r--benchmarks/ubench/files/patch-ac11
-rw-r--r--benchmarks/ubench/files/patch-ad11
-rw-r--r--benchmarks/ubench/pkg-comment1
-rw-r--r--benchmarks/ubench/pkg-descr23
-rw-r--r--benchmarks/ubench/pkg-plist1
9 files changed, 117 insertions, 0 deletions
diff --git a/benchmarks/ubench/Makefile b/benchmarks/ubench/Makefile
new file mode 100644
index 000000000000..5f6e23db4c06
--- /dev/null
+++ b/benchmarks/ubench/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: ubench
+# Date created: 6 June 2000
+# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ubench
+PORTVERSION= 0.31
+CATEGORIES= benchmarks
+MASTER_SITES= ftp://metalab.unc.edu/pub/Linux/system/benchmark/ \
+ http://linuxberg.concepts.nl/files/console/system/
+
+MAINTAINER= leeym@cae.ce.ntu.edu.tw
+
+HAS_CONFIGURE= yes
+
+MAN8= ubench.8
+
+.include <bsd.port.mk>
diff --git a/benchmarks/ubench/distinfo b/benchmarks/ubench/distinfo
new file mode 100644
index 000000000000..6064dff4212e
--- /dev/null
+++ b/benchmarks/ubench/distinfo
@@ -0,0 +1 @@
+MD5 (ubench-0.31.tar.gz) = 1a6c5fec5922dda91dae38833e3caedd
diff --git a/benchmarks/ubench/files/patch-aa b/benchmarks/ubench/files/patch-aa
new file mode 100644
index 000000000000..3c31523047fd
--- /dev/null
+++ b/benchmarks/ubench/files/patch-aa
@@ -0,0 +1,38 @@
+--- configure.orig Mon May 29 04:46:09 2000
++++ configure Tue Jun 6 16:21:42 2000
+@@ -12,7 +12,8 @@
+ ###############################################################################
+
+ #DEFINES=-DDEBUG
+-INSTALLDIR= /usr/local/bin
++INSTALLDIR= \$(PREFIX)/bin
++MANDIR= \$(PREFIX)/man/man8
+
+ !
+
+@@ -113,8 +114,8 @@
+ ;;
+ *)
+ cat <<! >> Makefile
+-CC = cc
+-CFLAGS =
++CC ?= cc
++CFLAGS += -D${SYSTEM}
+ LDFLAGS = -lm
+ INCLUDES = -I.
+
+@@ -134,11 +135,11 @@
+ %.o: %.c
+ \$(CC) \$(CFLAGS) \$(INCLUDES) -c \$<
+
+-default: ubench
++all: ubench
+
+ install: ubench
+- mv -f \$(INSTALLDIR)/ubench \$(INSTALLDIR)/ubench.old
+- install -c -m 0555 ubench \$(INSTALLDIR)
++ \$(BSD_INSTALL_MAN) ubench.8 \$(MANDIR)
++ \$(BSD_INSTALL_PROGRAM) ubench \$(INSTALLDIR)
+
+ utime: \$(utimeobjects)
+ \$(CC) \$(CFLAGS) \$(LDFLAGS) -o \$@ \$^
diff --git a/benchmarks/ubench/files/patch-ab b/benchmarks/ubench/files/patch-ab
new file mode 100644
index 000000000000..2a7a03629b51
--- /dev/null
+++ b/benchmarks/ubench/files/patch-ab
@@ -0,0 +1,11 @@
+--- cpubench.c.orig Tue Jun 6 14:33:33 2000
++++ cpubench.c Tue Jun 6 14:34:40 2000
+@@ -41,7 +41,7 @@
+ #define sys_errlist _sys_errlist
+ #endif
+
+-#ifdef SunOS
++#if defined SunOS || defined FreeBSD
+ extern sigjmp_buf env;
+ #else
+ extern jmp_buf env;
diff --git a/benchmarks/ubench/files/patch-ac b/benchmarks/ubench/files/patch-ac
new file mode 100644
index 000000000000..f625642fe9cf
--- /dev/null
+++ b/benchmarks/ubench/files/patch-ac
@@ -0,0 +1,11 @@
+--- membench.c.orig Tue Jun 6 14:33:33 2000
++++ membench.c Tue Jun 6 14:34:29 2000
+@@ -41,7 +41,7 @@
+ #define sys_errlist _sys_errlist
+ #endif
+
+-#ifdef SunOS
++#if defined SunOS || defined FreeBSD
+ extern sigjmp_buf env;
+ #else
+ extern jmp_buf env;
diff --git a/benchmarks/ubench/files/patch-ad b/benchmarks/ubench/files/patch-ad
new file mode 100644
index 000000000000..bc6ef63c360b
--- /dev/null
+++ b/benchmarks/ubench/files/patch-ad
@@ -0,0 +1,11 @@
+--- signals.c.orig Tue Jun 6 14:33:33 2000
++++ signals.c Tue Jun 6 14:35:08 2000
+@@ -22,7 +22,7 @@
+ #include <signal.h>
+ #include <setjmp.h>
+
+-#ifdef SunOS
++#if defined SunOS || defined FreeBSD
+ sigjmp_buf env;
+ #else
+ jmp_buf env;
diff --git a/benchmarks/ubench/pkg-comment b/benchmarks/ubench/pkg-comment
new file mode 100644
index 000000000000..876323db95fb
--- /dev/null
+++ b/benchmarks/ubench/pkg-comment
@@ -0,0 +1 @@
+Unix Benchmark Utility for CPU(s) and memory
diff --git a/benchmarks/ubench/pkg-descr b/benchmarks/ubench/pkg-descr
new file mode 100644
index 000000000000..f31e4dbdf753
--- /dev/null
+++ b/benchmarks/ubench/pkg-descr
@@ -0,0 +1,23 @@
+The Unix Benchmark Utility "ubench" is an attempt to introduce a single measure
+of perfomance among computer systems running various flavors of Unix operation
+system.
+
+The current development release tests only CPU(s) and memory. In the future
+releases there will be tests added for disk and TCP/IP. Ubench is taking
+advantage of multiple CPUs on an SMP system and the results will reflect that.
+
+o Ubench is executing rather senseless mathematical integer and floating-point
+ calculations for 3 mins concurrently using several processes, and the result
+ Ubench CPU benchmark.
+
+o Ubench will spawn about 2 concurrent processes for each CPU available on the
+ system. This ensures all available raw CPU horsepower is used.
+
+o Ubench is executing rather senseless memory allocation and memory to memory
+ copying operations for another 3 mins concurrently using several processes,
+ and the result Ubench MEM benchmark.
+
+WWW: http://www.phystech.com/download/ubench.html
+
+--
+Sergei Viznyuk <sv@phystech.com>
diff --git a/benchmarks/ubench/pkg-plist b/benchmarks/ubench/pkg-plist
new file mode 100644
index 000000000000..06feb3e79c9d
--- /dev/null
+++ b/benchmarks/ubench/pkg-plist
@@ -0,0 +1 @@
+bin/ubench