aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2011-05-23 23:08:32 +0000
committerBeech Rintoul <beech@FreeBSD.org>2011-05-23 23:08:32 +0000
commit5418439c4ccb0f600901243bf2218aa6cd36ffb3 (patch)
tree550306798159792aee300125b17ba86319bfd932
parentd8b17fbfab2e9480974a3bc92d6d83150e03e0af (diff)
downloadports-5418439c4ccb0f600901243bf2218aa6cd36ffb3.tar.gz
ports-5418439c4ccb0f600901243bf2218aa6cd36ffb3.zip
-New port horde4-content-1.0.0
-Horde content. This application provides tagging support for the other Horde applications. Approved by: itetcu (mentor)(implicit)
Notes
Notes: svn path=/head/; revision=274548
-rw-r--r--devel/Makefile1
-rw-r--r--devel/horde4-content/Makefile44
-rw-r--r--devel/horde4-content/distinfo2
-rw-r--r--devel/horde4-content/files/pkg-message.in7
-rw-r--r--devel/horde4-content/pkg-descr4
-rw-r--r--devel/horde4-content/pkg-plist36
6 files changed, 94 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 511dc948d732..bfbafe87037a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -552,6 +552,7 @@
SUBDIR += highlighterkit
SUBDIR += horde-chora
SUBDIR += horde-whups
+ SUBDIR += horde4-content
SUBDIR += hp48cc
SUBDIR += hp48xgcc
SUBDIR += hs-Boolean
diff --git a/devel/horde4-content/Makefile b/devel/horde4-content/Makefile
new file mode 100644
index 000000000000..ae6f2275e58b
--- /dev/null
+++ b/devel/horde4-content/Makefile
@@ -0,0 +1,44 @@
+# Ports collection makefile for: horde4-content
+# Date created: Mon May 23, 2011
+# Whom: Beech Rintoul (<beech@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= content
+PORTVERSION= 1.0.0
+DISTVERSIONPREFIX=
+DISTVERSIONSUFFIX=
+CATEGORIES= devel www
+MASTER_SITES= http://pear.horde.org/get/ \
+ LOCAL/beech
+PKGNAMEPREFIX= horde4-
+DISTNAME= content-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= Horde tagging application
+
+USE_HORDE= base
+USE_GETTEXT= yes
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/config && ${TOUCH} ${WRKSRC}/config/placeholder.dist
+
+do-install:
+ @${INSTALL} -d ${HORDIR}/
+# @${CP} ${WRKSRC}/lib/Horde/content.php ${HORBAS}/
+ @${CP} -Rp ${WRKSRC}/app/ ${HORDIR}/
+ @${CP} -Rp ${WRKSRC}/config/ ${HORDIR}/
+ @${CP} -Rp ${WRKSRC}/lib/ ${HORDIR}/
+ @${CP} -Rp ${WRKSRC}/migration/ ${HORDIR}/
+ @${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ @${ECHO_CMD} @exec ${CHMOD} -R o-rwx %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${TOUCH} ${HORLOG};${CHOWN} ${WWWOWN}:${WWWGRP} ${HORLOG}" >> ${TMPPLIST}
+
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include "${.CURDIR}/../../www/horde4-base/bsd.horde4.mk"
+.include <bsd.port.mk>
diff --git a/devel/horde4-content/distinfo b/devel/horde4-content/distinfo
new file mode 100644
index 000000000000..c7b63dbf4995
--- /dev/null
+++ b/devel/horde4-content/distinfo
@@ -0,0 +1,2 @@
+SHA256 (content-1.0.0.tgz) = b4ec6c971118a3274b85d8b6407576e3f7bba70b3fbbf3f823854839b61049d8
+SIZE (content-1.0.0.tgz) = 18025
diff --git a/devel/horde4-content/files/pkg-message.in b/devel/horde4-content/files/pkg-message.in
new file mode 100644
index 000000000000..f014ccc943f7
--- /dev/null
+++ b/devel/horde4-content/files/pkg-message.in
@@ -0,0 +1,7 @@
+************************************************************************
+content has been installed in %%HORDIR%%/.
+
+Horde must be configured and the tables created; if not, see
+`pkg_info -Dx horde-base'.
+
+************************************************************************
diff --git a/devel/horde4-content/pkg-descr b/devel/horde4-content/pkg-descr
new file mode 100644
index 000000000000..f7535d9eb037
--- /dev/null
+++ b/devel/horde4-content/pkg-descr
@@ -0,0 +1,4 @@
+Horde content. This application provides tagging support for the other Horde
+applications.
+
+WWW: http://www.horde.org
diff --git a/devel/horde4-content/pkg-plist b/devel/horde4-content/pkg-plist
new file mode 100644
index 000000000000..5a6c1a9a137e
--- /dev/null
+++ b/devel/horde4-content/pkg-plist
@@ -0,0 +1,36 @@
+%%HORDIR%%/1_rampage_base_tables.php
+%%HORDIR%%/2_rampage_tag_tables.php
+%%HORDIR%%/Application.php
+%%HORDIR%%/Exception.php
+%%HORDIR%%/Index/Index.php
+%%HORDIR%%/Index/IndexMapper.php
+%%HORDIR%%/Linkbacks/Linkback.php
+%%HORDIR%%/Linkbacks/LinkbackMapper.php
+%%HORDIR%%/Objects/Manager.php
+%%HORDIR%%/Objects/Object.php
+%%HORDIR%%/Objects/ObjectMapper.php
+%%HORDIR%%/Relationships/Relationship.php
+%%HORDIR%%/Relationships/RelationshipMapper.php
+%%HORDIR%%/Tagger.php
+%%HORDIR%%/Tags/Tag.php
+%%HORDIR%%/Tags/TagMapper.php
+%%HORDIR%%/Types/Manager.php
+%%HORDIR%%/Users/Manager.php
+%%HORDIR%%/controllers/ApplicationController.php
+%%HORDIR%%/controllers/TagController.php
+%%HORDIR%%/placeholder.dist
+%%HORDIR%%/routes.php
+%%HORDIR%%/views/Tag/recentTags.html.php
+%%HORDIR%%/views/Tag/searchTags.html.php
+@dirrm %%HORDIR%%/views/Tag
+@dirrm %%HORDIR%%/views
+@dirrm %%HORDIR%%/controllers
+@dirrm %%HORDIR%%/Users
+@dirrm %%HORDIR%%/Types
+@dirrm %%HORDIR%%/Tags
+@dirrm %%HORDIR%%/Relationships
+@dirrm %%HORDIR%%/Objects
+@dirrm %%HORDIR%%/Linkbacks
+@dirrm %%HORDIR%%/Index
+@dirrmtry %%HORDIR%%
+@dirrmtry %%HORBAS%%