aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 01:25:18 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 01:25:18 +0000
commit5555d89b50c7710cb97fb22ca6af251e6404e404 (patch)
tree700b4c9a8ec0af3f2f98ea0c4dc852268cc67aaf
parent42b9878de05e3fd31b1537c7fb21ea8d4260e335 (diff)
downloadports-5555d89b50c7710cb97fb22ca6af251e6404e404.tar.gz
ports-5555d89b50c7710cb97fb22ca6af251e6404e404.zip
Remove always-false/true conditions based on OSVERSION 500000
Notes
Notes: svn path=/head/; revision=200774
-rw-r--r--lang/cmucl/Makefile11
-rw-r--r--lang/gambas/Makefile4
-rw-r--r--lang/gcc34/Makefile3
-rw-r--r--lang/ghc/Makefile10
-rw-r--r--lang/gnat/Makefile2
-rw-r--r--lang/io/Makefile7
-rw-r--r--lang/mdk/Makefile8
-rw-r--r--lang/ocaml-camlidl/Makefile6
-rw-r--r--lang/p5-JavaScript/Makefile8
-rw-r--r--lang/phc/Makefile8
-rw-r--r--lang/pike72/Makefile8
-rw-r--r--lang/pike76/Makefile8
-rw-r--r--lang/qscheme/Makefile13
-rw-r--r--lang/see-devel/Makefile4
-rw-r--r--lang/spidermonkey/Makefile8
15 files changed, 19 insertions, 89 deletions
diff --git a/lang/cmucl/Makefile b/lang/cmucl/Makefile
index be331c898d4f..f2ea9fb76766 100644
--- a/lang/cmucl/Makefile
+++ b/lang/cmucl/Makefile
@@ -19,6 +19,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-x86-FreeBSD
MAINTAINER= cracauer@cons.org
COMMENT= The CMU implementation of Common Lisp
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+
# To make available on other archs, has to be cross-compiled (there is a
# script for this, but a configuration file has to be written).
IA32_BINARY_PORT= yes
@@ -29,13 +31,6 @@ MAN1= lisp.1 cmucl.1
PLIST_SUB= VER=${PORTVERSION}
-.include <bsd.port.pre.mk>
-
-# portlint wants this earlier but this doesn't work because weneed OSVERSION
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKDIR}/bin/lisp ${PREFIX}/bin
cd ${WRKDIR} && ${FIND} lib | \
@@ -47,4 +42,4 @@ do-install:
${INSTALL_DATA} ${WRKDIR}/doc/cmucl/* ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/gambas/Makefile b/lang/gambas/Makefile
index be3f8a443cd3..ad995cb0a013 100644
--- a/lang/gambas/Makefile
+++ b/lang/gambas/Makefile
@@ -82,10 +82,6 @@ PLIST_SUB+= XML="@comment "
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile with gcc-2.95
-.endif
-
.if ${ARCH} == "sparc64" || ${ARCH} == "ia64"
BROKEN= Segfault during build on ${ARCH}
.endif
diff --git a/lang/gcc34/Makefile b/lang/gcc34/Makefile
index 12adbeda5c5e..2567ec9048a6 100644
--- a/lang/gcc34/Makefile
+++ b/lang/gcc34/Makefile
@@ -61,9 +61,6 @@ CONFIGURE_ENV= RANLIB=:
MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
ALL_TARGET= bootstrap-lean
USE_LDCONFIG= ${TARGLIB}
-.if ${OSVERSION} < 500000 && ${ARCH} == alpha
-CXXFLAGS+= -fPIC
-.endif
PLIST_SUB= GCC_VER=${PORTVERSION} GNU_HOST=${CONFIGURE_TARGET} \
SUFFIX=${SUFFIX}
MAN1= cpp${SUFFIX}.1 \
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index 8dc0584006f0..fda97792bf8e 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -36,20 +36,14 @@ OPTIONS= PROFILE "Compile for profiling as well" on
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-#DISTFILES+= ${BOOT_DIST4}
+.if ${OSVERSION} >= 700000
IGNORE= unsupported at the moment
-.else
-.if ${OSVERSION} >= 600000
+.elif ${OSVERSION} >= 600000
DISTFILES+= ${BOOT_DIST}
.else
IGNORE= unsupported at the moment
#DISTFILES+= ${BOOT_DIST5}
.endif
-.endif
-.if ${OSVERSION} >= 700000
-IGNORE= unsupported at the moment
-.endif
PLIST_SUB+= GHC_VERSION=${PORTVERSION}
.if defined(WITHOUT_PROFILE)
diff --git a/lang/gnat/Makefile b/lang/gnat/Makefile
index 6e37a7d84791..fc885956b66b 100644
--- a/lang/gnat/Makefile
+++ b/lang/gnat/Makefile
@@ -97,9 +97,7 @@ have_boot=
.if empty(have_boot)
ONLY_FOR_ARCHS= i386
DISTFILES+= gnat-3.15p-boot.tar.gz:boot
-.if ${OSVERSION} >= 500000
BUILD_DEPENDS+= ${LOCALBASE}/lib/compat/libc.so.4:${PORTSDIR}/misc/compat4x
-.endif
# Warning! You need the trailing slash on GCC_EXEC_PREFIX.
COMPILEDATA= GCC_EXEC_PREFIX=${WRKDIR}/adaboot/lib/gcc-lib/ \
ADA_INCLUDE_PATH=${WRKDIR}/adaboot/lib/gcc-lib/adainclude \
diff --git a/lang/io/Makefile b/lang/io/Makefile
index dde8e0e7630b..1e7318eb3dc0 100644
--- a/lang/io/Makefile
+++ b/lang/io/Makefile
@@ -31,10 +31,6 @@ BINDINGS_DEACTIVATE= Font Image ObjcBridge OpenGL SGML SQLite SQLite3
BROKEN= Does not compile on ia64 or sparc64
.endif
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4+
-.endif
-
pre-patch:
${FIND} ${WRKSRC} -name '.DS_Store*' -delete
@@ -63,9 +59,6 @@ pre-patch:
post-patch:
${FIND} ${WRKSRC} -name '*.orig' -delete
-.if ${OSVERSION} < 500000
- @cd ${WRKSRC} && ${REINPLACE_CMD} -e 's/<stdint.h>/<inttypes.h>/' vm/base/_new/Array/Array.h vm/base/_new/Data.h vm/base/Common.h vm/base/NEW_stdint.h
-.endif
do-install:
.for fname in vm/io2c vm/io binaries/ioDesktop binaries/ioServer
diff --git a/lang/mdk/Makefile b/lang/mdk/Makefile
index c0587487bb5b..a0342cdcef21 100644
--- a/lang/mdk/Makefile
+++ b/lang/mdk/Makefile
@@ -32,10 +32,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
INFO= mdk
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/ocaml-camlidl/Makefile b/lang/ocaml-camlidl/Makefile
index 249c7cf3dd4c..2daf24592706 100644
--- a/lang/ocaml-camlidl/Makefile
+++ b/lang/ocaml-camlidl/Makefile
@@ -26,10 +26,6 @@ DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-USE_GMAKE= yes
-.endif
-
post-extract:
@${REINPLACE_CMD} -e "s,^\(OCAMLLIB=\).*,\1${PREFIX}/lib/ocaml,g" \
-e "s,^\(BINDIR=\).*,\1${PREFIX}/bin,g" \
@@ -67,4 +63,4 @@ test:
${WRKSRC}/tests/Makefile
cd ${WRKSRC}/tests && ${SETENV} ${MAKE_ENV} ${MAKE} all
-.include <bsd.port.post.mk>
+.include <bsd.port.port.mk>
diff --git a/lang/p5-JavaScript/Makefile b/lang/p5-JavaScript/Makefile
index d0f37c9f7e50..c4612fdc05b0 100644
--- a/lang/p5-JavaScript/Makefile
+++ b/lang/p5-JavaScript/Makefile
@@ -26,10 +26,4 @@ CONFIGURE_ARGS= INC=-I${LOCALBASE}/include
post-patch:
${REINPLACE_CMD} -e 's/<malloc.h>/<stdlib.h>/' ${WRKSRC}/JavaScript.xs
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= a dependency does not compile on FreeBSD 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/phc/Makefile b/lang/phc/Makefile
index cf0c16cebfd5..80fe0ee6b3ec 100644
--- a/lang/phc/Makefile
+++ b/lang/phc/Makefile
@@ -18,10 +18,4 @@ USE_GCC= 3.4+
USE_GMAKE= yes
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-IGNORE= doesn't build on FreeBSD 4.x
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/lang/pike72/Makefile b/lang/pike72/Makefile
index 66b196ac91be..238963effffd 100644
--- a/lang/pike72/Makefile
+++ b/lang/pike72/Makefile
@@ -19,7 +19,8 @@ COMMENT= A dynamic programming language with a syntax similar to C++
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
gdbm.3:${PORTSDIR}/databases/gdbm \
- mird.1:${PORTSDIR}/databases/mird
+ mird.1:${PORTSDIR}/databases/mird \
+ gmp.7:${PORTSDIR}/math/libgmp4
WRKSRC= ${WRKDIR}/${DISTNAME}/src/
@@ -63,11 +64,6 @@ CONFIGURE_ARGS+= --with-long-double-precision
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-# FreeBSD 5.0 Needs to have libgmp port to support gmp.
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
-.endif
-
.if exists(${LOCALBASE}/lib/libttf.so.4)
WITH_TTF= yes
.endif
diff --git a/lang/pike76/Makefile b/lang/pike76/Makefile
index 8b2c95350e20..4cd55fd2d436 100644
--- a/lang/pike76/Makefile
+++ b/lang/pike76/Makefile
@@ -24,7 +24,8 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
gdbm.3:${PORTSDIR}/databases/gdbm \
pcre.0:${PORTSDIR}/devel/pcre \
nettle.2:${PORTSDIR}/security/nettle \
- mird.1:${PORTSDIR}/databases/mird
+ mird.1:${PORTSDIR}/databases/mird \
+ gmp.7:${PORTSDIR}/math/libgmp4
OPTIONS= TTF "Add FreeType 1 support" on \
FREETYPE "Add FreeType 2 support" on \
@@ -89,11 +90,6 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION}
BROKEN= Does not compile
.endif
-# FreeBSD 5.0 Needs to have libgmp port to support gmp.
-.if ${OSVERSION} >= 500000
-LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
-.endif
-
# Allow building Embedded Perl
CONFIGURE_ARGS+= --with-perl
USE_PERL5= YES
diff --git a/lang/qscheme/Makefile b/lang/qscheme/Makefile
index 11ca47e582ec..c536a8eb8da9 100644
--- a/lang/qscheme/Makefile
+++ b/lang/qscheme/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= erik@smluc.org
COMMENT= A small and fast Scheme interpreter
BUILD_DEPENDS= ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall\
- ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre
+ ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre \
+ ${LOCALBASE}/include/gmp.h:${PORTSDIR}/math/libgmp4
LIB_DEPENDS= getline:${PORTSDIR}/devel/libgetline
GNU_CONFIGURE= yes
@@ -25,7 +26,9 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
CONFIGURE_ARGS= --with-pcre-dir=${LOCALBASE}/lib \
--with-pcre-inc=${LOCALBASE}/include \
--with-avcall-dir=${LOCALBASE}/lib \
- --with-avcall-inc=${LOCALBASE}/include
+ --with-avcall-inc=${LOCALBASE}/include \
+ --with-gmp-dir=${LOCALBASE}/lib \
+ --with-gmp-inc=${LOCALBASE}/include
post-patch:
${REINPLACE_CMD} \
@@ -41,10 +44,4 @@ post-patch:
BROKEN= "Does not build on amd64 or ia64"
.endif
-.if ${OSVERSION} >= 500000
-BUILD_DEPENDS+= ${LOCALBASE}/include/gmp.h:${PORTSDIR}/math/libgmp4
-CONFIGURE_ARGS+= --with-gmp-dir=${LOCALBASE}/lib \
- --with-gmp-inc=${LOCALBASE}/include
-.endif
-
.include <bsd.port.post.mk>
diff --git a/lang/see-devel/Makefile b/lang/see-devel/Makefile
index e44eb8455f78..3ada5115cc34 100644
--- a/lang/see-devel/Makefile
+++ b/lang/see-devel/Makefile
@@ -35,10 +35,6 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-BROKEN= does not build on 4.x
-.endif
-
.if !defined(WITH_SEE_DEBUG)
CFLAGS+= -DNDEBUG
.endif
diff --git a/lang/spidermonkey/Makefile b/lang/spidermonkey/Makefile
index 501646ce463c..8edb5780a954 100644
--- a/lang/spidermonkey/Makefile
+++ b/lang/spidermonkey/Makefile
@@ -70,12 +70,6 @@ test:
--shellpath ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/js \
--engine smdebug --confail --trace --list ecma* js1_*
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on FreeBSD 4.x
-.endif
-
do-configure:
${CP} ${WRKSRC}/config/Linux_All.mk \
${WRKSRC}/config/${OPSYS}`${UNAME} -r`.mk && \
@@ -89,4 +83,4 @@ do-install:
${CP} ${WRKSRC}/${OPSYS}`${UNAME} -r`_DBG.OBJ/jsautocfg.h ${WRKSRC}
@${INSTALL_DATA} ${JSH:S,^,${WRKSRC}/,} ${PREFIX}/include/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>