aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2022-11-04 15:27:04 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2022-11-04 15:27:04 +0000
commit55c01f69543c6336bb583857019f5278d4bf90ef (patch)
treef7fb507e6807a789063fa15d773217f478e3fc30
parentefe501e4d54986b53bfc8bcb7d8dcb9bb027a921 (diff)
downloadports-55c01f69543c6336bb583857019f5278d4bf90ef.tar.gz
ports-55c01f69543c6336bb583857019f5278d4bf90ef.zip
net-mgmt/smokeping: fix bug in FPingContinuous.pm
Add patch accepted upstream with bug #341. https://github.com/oetiker/SmokePing/issues/341 PR: 267015 Approved by: rodrigo (maintainer timeout, 3 weeks)
-rw-r--r--net-mgmt/smokeping/Makefile2
-rw-r--r--net-mgmt/smokeping/files/patch-lib_Smokeping_probes_FPingContinuous.pm13
2 files changed, 14 insertions, 1 deletions
diff --git a/net-mgmt/smokeping/Makefile b/net-mgmt/smokeping/Makefile
index 619e42e43091..a67fa425f303 100644
--- a/net-mgmt/smokeping/Makefile
+++ b/net-mgmt/smokeping/Makefile
@@ -1,6 +1,6 @@
PORTNAME= smokeping
PORTVERSION= 2.8.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-mgmt www
MAINTAINER= rodrigo@FreeBSD.org
diff --git a/net-mgmt/smokeping/files/patch-lib_Smokeping_probes_FPingContinuous.pm b/net-mgmt/smokeping/files/patch-lib_Smokeping_probes_FPingContinuous.pm
new file mode 100644
index 000000000000..04aa39c2fab9
--- /dev/null
+++ b/net-mgmt/smokeping/files/patch-lib_Smokeping_probes_FPingContinuous.pm
@@ -0,0 +1,13 @@
+--- lib/Smokeping/probes/FPingContinuous.pm.orig 2021-08-13 06:20:13 UTC
++++ lib/Smokeping/probes/FPingContinuous.pm
+@@ -72,8 +72,8 @@ sub new($$$)
+ my $binary = join(" ", $self->binary);
+ my $testhost = $self->testhost;
+ my $return = `$binary -C 1 $testhost 2>&1`;
+- $self->{enable}{S} = (`$binary -h 2>&1` =~ /\s-S\s/);
+- $self->{enable}{O} = (`$binary -h 2>&1` =~ /\s-O\s/);
++ $self->{enable}{S} = (`$binary -h 2>&1` =~ /\s-S[,\s]/);
++ $self->{enable}{O} = (`$binary -h 2>&1` =~ /\s-O[,\s]/);
+ croak "ERROR: fping ('$binary -C 1 $testhost') could not be run: $return"
+ if $return =~ m/not found/;
+ croak "ERROR: FPing must be installed setuid root or it will not work\n"