aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-02 22:37:19 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2023-04-02 22:37:19 +0000
commit560c6d1bdf4d7b4eff1bdfed0506443b3444e597 (patch)
tree3b8089abe277e693a416159635641aa1526a814a
parent582d4d27786ea1ec6e19f2ee2317f63c5c16a02d (diff)
downloadports-560c6d1bdf4d7b4eff1bdfed0506443b3444e597.tar.gz
ports-560c6d1bdf4d7b4eff1bdfed0506443b3444e597.zip
security/py-python-gvm: Update to 23.2.0
-rw-r--r--security/py-python-gvm/Makefile17
-rw-r--r--security/py-python-gvm/distinfo6
-rw-r--r--security/py-python-gvm/files/patch-setup.py79
3 files changed, 18 insertions, 84 deletions
diff --git a/security/py-python-gvm/Makefile b/security/py-python-gvm/Makefile
index c4af3b0d3079..e1c7ecc92868 100644
--- a/security/py-python-gvm/Makefile
+++ b/security/py-python-gvm/Makefile
@@ -1,7 +1,7 @@
PORTNAME= python-gvm
-DISTVERSION= 22.9.1
+DISTVERSION= 23.2.0
+DISTVERSIONPREFIX= v
CATEGORIES= security python
-MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= acm@FreeBSD.org
@@ -10,13 +10,26 @@ WWW= https://github.com/greenbone/python-gvm
LICENSE= GPLv3+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry2setup>0:devel/py-poetry2setup@${PY_FLAVOR}
+
+USE_GITHUB= yes
+GH_ACCOUNT= greenbone
+GH_PROJECT= ${PORTNAME}
+
USES= python:3.7+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
+post-extract:
+ ${MV} ${WRKSRC}/tests ${WRKSRC}/gvm/
+
post-patch:
${REINPLACE_CMD} -i "" -e 's|/run/gvmd/|/var/run/gvmd/|g' \
${WRKSRC}/gvm/connections.py
+ ${REINPLACE_CMD} '31d' ${WRKSRC}/pyproject.toml
+
+pre-configure:
+ @cd ${WRKSRC} && poetry2setup > ${WRKSRC}/setup.py
.include <bsd.port.mk>
diff --git a/security/py-python-gvm/distinfo b/security/py-python-gvm/distinfo
index 9d1bfd4973f2..cdec2ae59ff2 100644
--- a/security/py-python-gvm/distinfo
+++ b/security/py-python-gvm/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1668634790
-SHA256 (python-gvm-22.9.1.tar.gz) = 1dc2c788a322c56fe28b7339cb54ac24def35b13a9ffc8754b35368038d76eec
-SIZE (python-gvm-22.9.1.tar.gz) = 175034
+TIMESTAMP = 1680419775
+SHA256 (greenbone-python-gvm-v23.2.0_GH0.tar.gz) = 97d5a9dffb599a788cd81e90fdfdedf19376616ec35efa3c4c1e4d9d17608237
+SIZE (greenbone-python-gvm-v23.2.0_GH0.tar.gz) = 286131
diff --git a/security/py-python-gvm/files/patch-setup.py b/security/py-python-gvm/files/patch-setup.py
deleted file mode 100644
index c8f04f01f6ea..000000000000
--- a/security/py-python-gvm/files/patch-setup.py
+++ /dev/null
@@ -1,79 +0,0 @@
---- setup.py 2022-07-29 05:48:30.961574300 -0500
-+++ setup.py 2022-08-01 00:25:33.168450000 -0500
-@@ -12,75 +12,7 @@
- 'gvm.protocols.gmpv214.system',
- 'gvm.protocols.gmpv224',
- 'gvm.protocols.gmpv224.entities',
-- 'gvm.protocols.gmpv224.system',
-- 'tests',
-- 'tests.connections',
-- 'tests.protocols',
-- 'tests.protocols.gmp',
-- 'tests.protocols.gmpv208',
-- 'tests.protocols.gmpv208.entities',
-- 'tests.protocols.gmpv208.entities.alerts',
-- 'tests.protocols.gmpv208.entities.audits',
-- 'tests.protocols.gmpv208.entities.credentials',
-- 'tests.protocols.gmpv208.entities.filters',
-- 'tests.protocols.gmpv208.entities.groups',
-- 'tests.protocols.gmpv208.entities.hosts',
-- 'tests.protocols.gmpv208.entities.notes',
-- 'tests.protocols.gmpv208.entities.operating_systems',
-- 'tests.protocols.gmpv208.entities.overrides',
-- 'tests.protocols.gmpv208.entities.permissions',
-- 'tests.protocols.gmpv208.entities.policies',
-- 'tests.protocols.gmpv208.entities.port_lists',
-- 'tests.protocols.gmpv208.entities.report_formats',
-- 'tests.protocols.gmpv208.entities.reports',
-- 'tests.protocols.gmpv208.entities.results',
-- 'tests.protocols.gmpv208.entities.roles',
-- 'tests.protocols.gmpv208.entities.scan_configs',
-- 'tests.protocols.gmpv208.entities.scanners',
-- 'tests.protocols.gmpv208.entities.schedules',
-- 'tests.protocols.gmpv208.entities.secinfo',
-- 'tests.protocols.gmpv208.entities.tags',
-- 'tests.protocols.gmpv208.entities.targets',
-- 'tests.protocols.gmpv208.entities.tasks',
-- 'tests.protocols.gmpv208.entities.tickets',
-- 'tests.protocols.gmpv208.entities.tls_certificates',
-- 'tests.protocols.gmpv208.entities.users',
-- 'tests.protocols.gmpv208.entities.vulnerabilities',
-- 'tests.protocols.gmpv208.enums',
-- 'tests.protocols.gmpv208.system',
-- 'tests.protocols.gmpv208.system.aggregates',
-- 'tests.protocols.gmpv208.system.authentication',
-- 'tests.protocols.gmpv208.system.feed',
-- 'tests.protocols.gmpv208.system.help',
-- 'tests.protocols.gmpv208.system.system_reports',
-- 'tests.protocols.gmpv208.system.trashcan',
-- 'tests.protocols.gmpv208.system.user_settings',
-- 'tests.protocols.gmpv208.system.versions',
-- 'tests.protocols.gmpv214',
-- 'tests.protocols.gmpv214.entities',
-- 'tests.protocols.gmpv214.entities.notes',
-- 'tests.protocols.gmpv214.entities.overrides',
-- 'tests.protocols.gmpv214.entities.scanners',
-- 'tests.protocols.gmpv214.entities.targets',
-- 'tests.protocols.gmpv214.entities.users',
-- 'tests.protocols.gmpv214.enums',
-- 'tests.protocols.gmpv214.system',
-- 'tests.protocols.gmpv214.system.versions',
-- 'tests.protocols.gmpv224',
-- 'tests.protocols.gmpv224.entities',
-- 'tests.protocols.gmpv224.entities.notes',
-- 'tests.protocols.gmpv224.entities.overrides',
-- 'tests.protocols.gmpv224.entities.scan_configs',
-- 'tests.protocols.gmpv224.entities.scanners',
-- 'tests.protocols.gmpv224.entities.targets',
-- 'tests.protocols.gmpv224.entities.users',
-- 'tests.protocols.gmpv224.enums',
-- 'tests.protocols.gmpv224.system',
-- 'tests.protocols.gmpv224.system.versions',
-- 'tests.protocols.osp',
-- 'tests.transforms',
-- 'tests.utils',
-- 'tests.xml']
-+ 'gvm.protocols.gmpv224.system']
-
- package_data = \
- {'': ['*']}