aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYasuhiro Kimura <yasu@freebsd.org>2023-04-18 12:31:07 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-04-18 12:31:07 +0000
commit560e5d91cd95734cea19013b2e4857432c545e94 (patch)
tree03fa97a34d683081bf048c2856b58c3f0cfbc5b6
parentf7d92a2af6b147d1ed8c01c89cb7fd63dbd9e684 (diff)
downloadports-560e5d91cd95734cea19013b2e4857432c545e94.tar.gz
ports-560e5d91cd95734cea19013b2e4857432c545e94.zip
lang/ruby31: Update to 3.1.4
Changes: https://www.ruby-lang.org/en/news/2023/03/30/ruby-3-1-4-released/ PR: 270557 Exp-run by: antoine Security: 9b60bba1-cf18-11ed-bd44-080027f5fec9 Security: 6bd2773c-cf1a-11ed-bd44-080027f5fec9
-rw-r--r--Mk/Uses/ruby.mk4
-rw-r--r--lang/ruby31/distinfo6
-rw-r--r--lang/ruby31/files/patch-mkmf-pkg-config25
-rw-r--r--lang/ruby31/files/patch-tool_rbinstall.rb11
-rw-r--r--lang/ruby31/pkg-plist6
5 files changed, 18 insertions, 34 deletions
diff --git a/Mk/Uses/ruby.mk b/Mk/Uses/ruby.mk
index c1518b4cbcef..42385c5b021f 100644
--- a/Mk/Uses/ruby.mk
+++ b/Mk/Uses/ruby.mk
@@ -154,8 +154,8 @@ RUBY_PORTREVISION= 0
#
# Ruby 3.1
#
-RUBY_DISTVERSION= 3.1.3
-RUBY_PORTREVISION= 2
+RUBY_DISTVERSION= 3.1.4
+RUBY_PORTREVISION= 0
. elif ${RUBY_VER} == 3.2
#
diff --git a/lang/ruby31/distinfo b/lang/ruby31/distinfo
index 9e8eb012b397..41be02864cf8 100644
--- a/lang/ruby31/distinfo
+++ b/lang/ruby31/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1669322575
-SHA256 (ruby/ruby-3.1.3.tar.xz) = 4ee161939826bcdfdafa757cf8e293a7f14e357f62be7144f040335cc8c7371a
-SIZE (ruby/ruby-3.1.3.tar.xz) = 15300224
+TIMESTAMP = 1680203228
+SHA256 (ruby/ruby-3.1.4.tar.xz) = 1b6d6010e76036c937b9671f4752f065aeca800a6c664f71f6c9a699453af94f
+SIZE (ruby/ruby-3.1.4.tar.xz) = 15316604
diff --git a/lang/ruby31/files/patch-mkmf-pkg-config b/lang/ruby31/files/patch-mkmf-pkg-config
deleted file mode 100644
index f966b82eadb1..000000000000
--- a/lang/ruby31/files/patch-mkmf-pkg-config
+++ /dev/null
@@ -1,25 +0,0 @@
-From 613fca01486e47dee9364a2fd86b5f5e77fe23c8 Mon Sep 17 00:00:00 2001
-From: Nobuyoshi Nakada <nobu@ruby-lang.org>
-Date: Wed, 7 Dec 2022 22:14:44 +0900
-Subject: [PATCH] [Bug #19189] Fallback to the default "pkg-config"
-
----
- lib/mkmf.rb | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git lib/mkmf.rb lib/mkmf.rb
-index e94733c635..0fbc1cc2e5 100644
---- lib/mkmf.rb
-+++ lib/mkmf.rb
-@@ -1866,7 +1866,7 @@ def pkg_config(pkg, *options)
- if pkgconfig = with_config("#{pkg}-config") and find_executable0(pkgconfig)
- # if and only if package specific config command is given
- elsif ($PKGCONFIG ||=
-- (pkgconfig = with_config("pkg-config", RbConfig::CONFIG["PKG_CONFIG"])) &&
-+ (pkgconfig = with_config("pkg-config") {config_string("PKG_CONFIG") || "pkg-config"}) &&
- find_executable0(pkgconfig) && pkgconfig) and
- xsystem([*envs, $PKGCONFIG, "--exists", pkg])
- # default to pkg-config command
---
-2.39.1
-
diff --git a/lang/ruby31/files/patch-tool_rbinstall.rb b/lang/ruby31/files/patch-tool_rbinstall.rb
index 6be5e4ad0fc0..5d25f0ff501e 100644
--- a/lang/ruby31/files/patch-tool_rbinstall.rb
+++ b/lang/ruby31/files/patch-tool_rbinstall.rb
@@ -1,6 +1,6 @@
---- tool/rbinstall.rb.orig 2022-11-24 10:20:31 UTC
+--- tool/rbinstall.rb.orig 2023-03-30 10:53:51 UTC
+++ tool/rbinstall.rb
-@@ -930,170 +930,6 @@ end
+@@ -930,173 +930,6 @@ end
# :startdoc:
@@ -119,9 +119,12 @@
- next if /^\s*(?:#|$)/ =~ name
- next unless /^(\S+)\s+(\S+).*/ =~ name
- gem_name = "#$1-#$2"
-- path = "#{srcdir}/.bundle/specifications/#{gem_name}.gemspec"
+- # Try to find the gemspec file for C ext gems
+- # ex .bundle/gems/debug-1.7.1/debug-1.7.1.gemspec
+- # This gemspec keep the original dependencies
+- path = "#{srcdir}/.bundle/gems/#{gem_name}/#{gem_name}.gemspec"
- unless File.exist?(path)
-- path = "#{srcdir}/.bundle/gems/#{gem_name}/#{gem_name}.gemspec"
+- path = "#{srcdir}/.bundle/specifications/#{gem_name}.gemspec"
- next unless File.exist?(path)
- end
- spec = load_gemspec(path, "#{srcdir}/.bundle/gems/#{gem_name}")
diff --git a/lang/ruby31/pkg-plist b/lang/ruby31/pkg-plist
index 3cd32542975b..3f34529365dd 100644
--- a/lang/ruby31/pkg-plist
+++ b/lang/ruby31/pkg-plist
@@ -12453,6 +12453,8 @@ man/man1/ruby%%RUBY_SUFFIX%%.1.gz
%%RDOC%%%%RUBY_RIDIR%%/URI/Generic/component-c.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/Generic/component-i.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/Generic/component_ary-i.ri
+%%RDOC%%%%RUBY_RIDIR%%/URI/Generic/decoded_password-i.ri
+%%RDOC%%%%RUBY_RIDIR%%/URI/Generic/decoded_user-i.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/Generic/default_port-c.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/Generic/default_port-i.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/Generic/eql%3f-i.ri
@@ -12590,9 +12592,13 @@ man/man1/ruby%%RUBY_SUFFIX%%.1.gz
%%RDOC%%%%RUBY_RIDIR%%/URI/WS/cdesc-WS.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/WS/request_uri-i.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/WSS/cdesc-WSS.ri
+%%RDOC%%%%RUBY_RIDIR%%/URI/_decode_uri_component-c.ri
+%%RDOC%%%%RUBY_RIDIR%%/URI/_encode_uri_component-c.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/cdesc-URI.ri
+%%RDOC%%%%RUBY_RIDIR%%/URI/decode_uri_component-c.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/decode_www_form-c.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/decode_www_form_component-c.ri
+%%RDOC%%%%RUBY_RIDIR%%/URI/encode_uri_component-c.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/encode_www_form-c.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/encode_www_form_component-c.ri
%%RDOC%%%%RUBY_RIDIR%%/URI/extract-c.ri