aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2021-02-27 00:06:36 +0000
committerSteve Wills <swills@FreeBSD.org>2021-02-27 00:06:36 +0000
commit571f0acd386e7fb546c4423ac52735cec751e53a (patch)
tree0eeee2091506b8a00b09f11820830ba24d432d53
parentdac56b71d7ddb78d350055b9df24583c32ba8662 (diff)
downloadports-571f0acd386e7fb546c4423ac52735cec751e53a.tar.gz
ports-571f0acd386e7fb546c4423ac52735cec751e53a.zip
net/p5-Net-Connection-ncnetstat: create port
Provides a enhances colorized netstat like tool that is capable of doing searches. The search criteria can be any of the following. * CIDR * port * host * PTR * pctcpu * pctmem * Regex PTR * state * UID * username * wait channel Among other unique features it can also display the full command, PctMem, and PctCPU of the process with the connection. WWW: https://metacpan.org/release/Net-Connection-ncnetstat PR: 253410 Submitted by: Zane C. Bowers-Hadley <vvelox@vvelox.net>
Notes
Notes: svn path=/head/; revision=566648
-rw-r--r--net/p5-Net-Connection-ncnetstat/Makefile30
-rw-r--r--net/p5-Net-Connection-ncnetstat/distinfo3
-rw-r--r--net/p5-Net-Connection-ncnetstat/pkg-descr21
-rw-r--r--net/p5-Net-Connection-ncnetstat/pkg-plist3
4 files changed, 57 insertions, 0 deletions
diff --git a/net/p5-Net-Connection-ncnetstat/Makefile b/net/p5-Net-Connection-ncnetstat/Makefile
new file mode 100644
index 000000000000..36c669c90c55
--- /dev/null
+++ b/net/p5-Net-Connection-ncnetstat/Makefile
@@ -0,0 +1,30 @@
+# Created by: Zane C. Bowers-Hadley <vvelox@vvelox.net>
+# $FreeBSD$
+
+PORTNAME= Net-Connection-ncnetstat
+PORTVERSION= 0.7.1
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:VVELOX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= vvelox@vvelox.net
+COMMENT= Netstat like utility that supports color and searching
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= p5-Net-Connection>=0.2.0:net/p5-Net-Connection \
+ p5-Net-Connection-Match>=0.5.0:net/p5-Net-Connection-Match \
+ p5-Net-Connection-Sort>=0.0.1:net/p5-Net-Connection-Sort \
+ p5-Term-ANSIColor>=4.06:devel/p5-Term-ANSIColor \
+ p5-Text-ANSITable>=0.601:textproc/p5-Text-ANSITable \
+ p5-Getopt-Long>=2.52:devel/p5-Getopt-Long \
+ p5-Data-Unixish>=1.570:devel/p5-Data-Unixish \
+ p5-Net-Connection-lsof>=0.2.0:net/p5-Net-Connection-lsof
+
+USES= perl5 shebangfix
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Connection-ncnetstat/distinfo b/net/p5-Net-Connection-ncnetstat/distinfo
new file mode 100644
index 000000000000..f914024c16f3
--- /dev/null
+++ b/net/p5-Net-Connection-ncnetstat/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1613752616
+SHA256 (Net-Connection-ncnetstat-0.7.1.tar.gz) = 72bd22a4abe88a9a75a65ce9311451931a4a23995733157ef19edbbc30993a66
+SIZE (Net-Connection-ncnetstat-0.7.1.tar.gz) = 11171
diff --git a/net/p5-Net-Connection-ncnetstat/pkg-descr b/net/p5-Net-Connection-ncnetstat/pkg-descr
new file mode 100644
index 000000000000..9dbdb6a09f84
--- /dev/null
+++ b/net/p5-Net-Connection-ncnetstat/pkg-descr
@@ -0,0 +1,21 @@
+Provides a enhances colorized netstat like tool that is
+capable of doing searches.
+
+The search criteria can be any of the following.
+
+ * CIDR
+ * port
+ * host
+ * PTR
+ * pctcpu
+ * pctmem
+ * Regex PTR
+ * state
+ * UID
+ * username
+ * wait channel
+
+Among other unique features it can also display the full
+command, PctMem, and PctCPU of the process with the connection.
+
+WWW: https://metacpan.org/release/Net-Connection-ncnetstat
diff --git a/net/p5-Net-Connection-ncnetstat/pkg-plist b/net/p5-Net-Connection-ncnetstat/pkg-plist
new file mode 100644
index 000000000000..ddc3835ee55c
--- /dev/null
+++ b/net/p5-Net-Connection-ncnetstat/pkg-plist
@@ -0,0 +1,3 @@
+bin/ncnetstat
+%%SITE_PERL%%/Net/Connection/ncnetstat.pm
+%%PERL5_MAN3%%/Net::Connection::ncnetstat.3.gz