aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Palmen <felix@palmen-it.de>2022-06-28 18:47:46 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2022-06-28 18:49:53 +0000
commit5774e493c4cbd700f0f850b3efeb8ca49302bf97 (patch)
treecc37f73fd907b40c9591b1a367cb3346593f2d60
parentad5fa8f8bdeff724e69e5d7250785cd22216ce13 (diff)
downloadports-5774e493c4cbd700f0f850b3efeb8ca49302bf97.tar.gz
ports-5774e493c4cbd700f0f850b3efeb8ca49302bf97.zip
security/unix-selfauth-helper: Add new port
This little helper enables self-authentication against the local passwd database using pam_exec. Differential Revision: https://reviews.freebsd.org/D35347
-rw-r--r--security/Makefile1
-rw-r--r--security/unix-selfauth-helper/Makefile21
-rw-r--r--security/unix-selfauth-helper/distinfo3
-rw-r--r--security/unix-selfauth-helper/pkg-descr5
4 files changed, 30 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 9b35072627f6..e31dd17fcb71 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1247,6 +1247,7 @@
SUBDIR += uacme
SUBDIR += ubuntu-keyring
SUBDIR += unhide
+ SUBDIR += unix-selfauth-helper
SUBDIR += vanguards-tor
SUBDIR += vault
SUBDIR += vaultwarden
diff --git a/security/unix-selfauth-helper/Makefile b/security/unix-selfauth-helper/Makefile
new file mode 100644
index 000000000000..2d4909ced787
--- /dev/null
+++ b/security/unix-selfauth-helper/Makefile
@@ -0,0 +1,21 @@
+# Created by: Felix Palmen <felix@palmen-it.de>
+
+PORTNAME= unix-selfauth-helper
+PORTVERSION= 1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+
+MAINTAINER= felix@palmen-it.de
+COMMENT= Local self-authentication for pam_exec
+
+LICENSE= BSD2CLAUSE
+
+USES= uidfix
+
+USE_GITHUB= yes
+GH_ACCOUNT= Zirias
+
+PLIST_FILES= libexec/unix-selfauth-helper \
+ man/man8/unix-selfauth-helper.8.gz
+
+.include <bsd.port.mk>
diff --git a/security/unix-selfauth-helper/distinfo b/security/unix-selfauth-helper/distinfo
new file mode 100644
index 000000000000..b544eeb0fea9
--- /dev/null
+++ b/security/unix-selfauth-helper/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1655634372
+SHA256 (Zirias-unix-selfauth-helper-v1.0_GH0.tar.gz) = 5a1aff046fb9e76555d7289afbe9c54d73269b5903a2f77f40b456840149a6ef
+SIZE (Zirias-unix-selfauth-helper-v1.0_GH0.tar.gz) = 3924
diff --git a/security/unix-selfauth-helper/pkg-descr b/security/unix-selfauth-helper/pkg-descr
new file mode 100644
index 000000000000..0648dbd5da24
--- /dev/null
+++ b/security/unix-selfauth-helper/pkg-descr
@@ -0,0 +1,5 @@
+This is a little suid-root helper allowing self-authentication against the
+local unix passwd database using pam_exec on a FreeBSD system. As a result,
+the behavior of LinuxPAM is mimicked without changes to the pam_unix module.
+
+WWW: https://github.com/Zirias/unix-selfauth-helper