aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2023-10-31 13:45:14 +0000
committerRenato Botelho <garga@FreeBSD.org>2023-11-06 18:13:54 +0000
commit577cb7aaf28306abca03274ec38d295700b5bc9b (patch)
tree456ffe3a34740300e54d8bef52cb8ecce4c203fe
parent1d96c7ebef903ee680ecd9232013c03826a658cc (diff)
downloadports-577cb7aaf28306abca03274ec38d295700b5bc9b.tar.gz
ports-577cb7aaf28306abca03274ec38d295700b5bc9b.zip
security/sudo: Update to 1.9.15
While here: - Prevent combination of SSSD and GSSAPI_HEIMDAL because sssd port requires MIT kerberos and it will conflict with heimdal - Removed SSSD_DEVEL option because sssd-devel port requires sudo and it creates a circular dependency - Fix OPIE on FreeBSD versions after it was removed from base Sponsored by: Rubicon Communications, LLC ("Netgate") (cherry picked from commit dd773c1540388b14692001643e323a556ed2d445)
-rw-r--r--security/sudo/Makefile26
-rw-r--r--security/sudo/distinfo6
-rw-r--r--security/sudo/pkg-plist1
3 files changed, 18 insertions, 15 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index c3267fce9a29..c8b0c63da991 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -1,6 +1,5 @@
PORTNAME= sudo
-PORTVERSION= 1.9.14p3
-PORTREVISION= 1
+PORTVERSION= 1.9.15
CATEGORIES= security
MASTER_SITES= SUDO
@@ -30,11 +29,10 @@ LDFLAGS+= -lgcc
PORTSCOUT= ignore:1
OPTIONS_DEFINE= AUDIT DISABLE_AUTH DISABLE_ROOT_SUDO DOCS EXAMPLES \
- INSULTS LDAP NLS NOARGS_SHELL OPIE PAM PYTHON SSL
+ INSULTS LDAP NLS NOARGS_SHELL OPIE PAM PYTHON SSL SSSD
OPTIONS_DEFAULT= AUDIT PAM SSL
-OPTIONS_RADIO= KERBEROS SSSD
+OPTIONS_RADIO= KERBEROS
OPTIONS_RADIO_KERBEROS= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
-OPTIONS_RADIO_SSSD= SSSD SSSD_DEVEL
OPTIONS_SUB= yes
AUDIT_DESC= Enable BSM audit support
@@ -46,8 +44,7 @@ NOARGS_SHELL_DESC= Run a shell if no arguments are given
OPIE_DESC= Enable one-time passwords (no PAM support)
PYTHON_DESC= Enable python plugin support
SSL_DESC= Use OpenSSL TLS and SHA2 functions
-SSSD_DESC= Enable SSSD backend support.
-SSSD_DEVEL_DESC= Enable SSSD-devel backend support.
+SSSD_DESC= Enable SSSD backend support
AUDIT_CONFIGURE_WITH= bsm-audit
@@ -86,12 +83,11 @@ PYTHON_CONFIGURE_ENABLE=python
SSL_USES= ssl
SSL_CONFIGURE_ON= --enable-openssl=${OPENSSLBASE}
+SSSD_PREVENTS= GSSAPI_HEIMDAL
+SSSD_PREVENTS_MSG= sssd requires MIT kerberos and it conflicts with heimdal
SSSD_RUN_DEPENDS= sssd:security/sssd
SSSD_CONFIGURE_ON= --with-sssd
-SSSD_DEVEL_RUN_DEPENDS= sssd:security/sssd-devel
-SSSD_DEVEL_CONFIGURE_ON= --with-sssd
-
LOGFAC?= authpriv
SUDO_LDAP_CONF?= ldap.conf
@@ -112,6 +108,13 @@ CONFIGURE_ARGS+= --enable-kerb5-instance="${SUDO_KERB5_INSTANCE}"
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400072
+. if ${PORT_OPTIONS:MOPIE}
+BUILD_DEPENDS+= opie>0:security/opie
+RUN_DEPENDS+= opie>0:security/opie
+. endif
+.endif
+
.if ${ARCH} == "arm"
CONFIGURE_ARGS+= --disable-pie
.endif
@@ -120,8 +123,6 @@ post-patch:
@${REINPLACE_CMD} -E '/install-(binaries|noexec):/,/^$$/ \
s/\$$\(INSTALL\)/& ${STRIP}/;s/-b\~/-b ~/' \
${WRKSRC}/src/Makefile.in
- @${REINPLACE_CMD} -e 's,$$(srcdir)/sudoers2ldif $$(DESTDIR)$$(docdir),$$(srcdir)/sudoers2ldif $$(DESTDIR)$$(bindir),' \
- ${WRKSRC}/plugins/sudoers/Makefile.in
post-install:
${INSTALL_DATA} ${FILESDIR}/pam.conf ${STAGEDIR}${PREFIX}/etc/pam.d/sudo.default
@@ -130,6 +131,7 @@ post-install:
${RM} ${STAGEDIR}${PREFIX}/etc/sudoers
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/cvtsudoers
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/sudoreplay
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/libexec/sudo/sudo_intercept.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/sudo_logsrvd
${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/sudo_sendlog
${STRIP_CMD} ${STAGEDIR}${PREFIX}/sbin/visudo
diff --git a/security/sudo/distinfo b/security/sudo/distinfo
index 823b7ed41411..ff270902c6f5 100644
--- a/security/sudo/distinfo
+++ b/security/sudo/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1690249679
-SHA256 (sudo-1.9.14p3.tar.gz) = a08318b1c4bc8582c004d4cd9ae2903abc549e7e46ba815e41fe81d1c0782b62
-SIZE (sudo-1.9.14p3.tar.gz) = 5232320
+TIMESTAMP = 1699294299
+SHA256 (sudo-1.9.15.tar.gz) = fd0e254870e92e873b508ba16382f5ac3af81a5a38d1ea9cf973606db4262589
+SIZE (sudo-1.9.15.tar.gz) = 5301915
diff --git a/security/sudo/pkg-plist b/security/sudo/pkg-plist
index 682fedc57f46..96573715a41b 100644
--- a/security/sudo/pkg-plist
+++ b/security/sudo/pkg-plist
@@ -92,6 +92,7 @@ sbin/sudo_sendlog
%%NLS%%share/locale/hr/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/hu/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/hu/LC_MESSAGES/sudoers.mo
+%%NLS%%share/locale/id/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/it/LC_MESSAGES/sudo.mo
%%NLS%%share/locale/it/LC_MESSAGES/sudoers.mo
%%NLS%%share/locale/ja/LC_MESSAGES/sudo.mo