aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2023-12-04 14:43:08 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2023-12-04 14:45:42 +0000
commit57a11a93dad3b2f74f2f77ea4226d43476298d85 (patch)
treefceff20bfcd067fdcc4bb1f8845a3d8077400c7c
parentacdf54f7daabd4a08f61d823f22d576596c97b99 (diff)
downloadports-57a11a93dad3b2f74f2f77ea4226d43476298d85.tar.gz
ports-57a11a93dad3b2f74f2f77ea4226d43476298d85.zip
security/py-python-cas: New port
Add SAML support to your Python software using this library. Forget those complicated libraries and use the open source library provided and supported by OneLogin Inc.
-rw-r--r--security/Makefile1
-rw-r--r--security/py-python-cas/Makefile23
-rw-r--r--security/py-python-cas/distinfo3
-rw-r--r--security/py-python-cas/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c940d52d8671..d2572882601f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1005,6 +1005,7 @@
SUBDIR += py-pyspnego
SUBDIR += py-python-axolotl
SUBDIR += py-python-axolotl-curve25519
+ SUBDIR += py-python-cas
SUBDIR += py-python-gnupg
SUBDIR += py-python-gvm
SUBDIR += py-python-jose
diff --git a/security/py-python-cas/Makefile b/security/py-python-cas/Makefile
new file mode 100644
index 000000000000..dae872ff0a53
--- /dev/null
+++ b/security/py-python-cas/Makefile
@@ -0,0 +1,23 @@
+PORTNAME= python-cas
+PORTVERSION= 1.6.0
+CATEGORIES= security python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ultima@FreeBSD.org
+COMMENT= Python CAS client library
+WWW= https://github.com/python-cas/python-cas
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.11.1:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=3.4:devel/py-lxml@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-python-cas/distinfo b/security/py-python-cas/distinfo
new file mode 100644
index 000000000000..71f2b4984db3
--- /dev/null
+++ b/security/py-python-cas/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1701158450
+SHA256 (python-cas-1.6.0.tar.gz) = b8f1dcb1b6c56b3ff4f86bbef47bcdfcf932061ccd4812ae35e3f63954dfdb28
+SIZE (python-cas-1.6.0.tar.gz) = 10476
diff --git a/security/py-python-cas/pkg-descr b/security/py-python-cas/pkg-descr
new file mode 100644
index 000000000000..37e1b7d79722
--- /dev/null
+++ b/security/py-python-cas/pkg-descr
@@ -0,0 +1,3 @@
+Add SAML support to your Python software using this library. Forget those
+complicated libraries and use the open source library provided and supported by
+OneLogin Inc.