aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-12-06 14:47:01 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-12-06 14:47:01 +0000
commit58432186eab43b6c01173b529312e00d59efc877 (patch)
tree2bcefc01e8e0759b1fce8d088c3134e4c25322bc
parent8bba7341bdd744f0f58720298759192ce764dc97 (diff)
downloadports-58432186eab43b6c01173b529312e00d59efc877.tar.gz
ports-58432186eab43b6c01173b529312e00d59efc877.zip
uchardet is a C language binding of the original C++ implementation
of the universal charset detection library by Mozilla. WWW: https://code.google.com/p/uchardet/ PR: 195083 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Notes
Notes: svn path=/head/; revision=374113
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/uchardet/Makefile20
-rw-r--r--textproc/uchardet/distinfo2
-rw-r--r--textproc/uchardet/files/patch-CMakeLists.txt19
-rw-r--r--textproc/uchardet/pkg-descr4
-rw-r--r--textproc/uchardet/pkg-plist8
6 files changed, 54 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6f9e9e11333a..e3960f9a3d4e 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1501,6 +1501,7 @@
SUBDIR += txt2html
SUBDIR += txt2man
SUBDIR += txt2tags
+ SUBDIR += uchardet
SUBDIR += uim
SUBDIR += uim-el
SUBDIR += uim-gtk
diff --git a/textproc/uchardet/Makefile b/textproc/uchardet/Makefile
new file mode 100644
index 000000000000..d5ef33fd9b41
--- /dev/null
+++ b/textproc/uchardet/Makefile
@@ -0,0 +1,20 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= uchardet
+PORTVERSION= 0.0.1
+CATEGORIES= textproc
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Universal charset detection library by Mozilla
+
+LICENSE= MPL
+
+USES= cmake
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} 's|_SHARE|_PREFIX|' ${WRKSRC}/doc/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/textproc/uchardet/distinfo b/textproc/uchardet/distinfo
new file mode 100644
index 000000000000..1f1222704348
--- /dev/null
+++ b/textproc/uchardet/distinfo
@@ -0,0 +1,2 @@
+SHA256 (uchardet-0.0.1.tar.gz) = e238c212350e07ebbe1961f8f128faaa40f71b70d37b63ffa2fe12c664269ee6
+SIZE (uchardet-0.0.1.tar.gz) = 179207
diff --git a/textproc/uchardet/files/patch-CMakeLists.txt b/textproc/uchardet/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..59c47a8baf19
--- /dev/null
+++ b/textproc/uchardet/files/patch-CMakeLists.txt
@@ -0,0 +1,19 @@
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -31,6 +31,7 @@
+
+ set (DIR_PREFIX ${CMAKE_INSTALL_PREFIX})
+ set (DIR_LIBRARY ${DIR_PREFIX}/${CMAKE_SHARED_LIBRARY_PREFIX})
++set (DIR_LIBDATA ${DIR_PREFIX}/libdata)
+ set (DIR_LIBRARY_STATIC ${DIR_PREFIX}/${CMAKE_STATIC_LIBRARY_PREFIX})
+ set (DIR_INCLUDE ${DIR_PREFIX}/include)
+ set (DIR_SHARE ${DIR_PREFIX}/share)
+@@ -69,7 +70,7 @@
+ FILES
+ ${CMAKE_BINARY_DIR}/uchardet.pc
+ DESTINATION
+- ${DIR_LIBRARY}/pkgconfig
++ ${DIR_LIBDATA}/pkgconfig
+ )
+
+ ######## Subdirectories
diff --git a/textproc/uchardet/pkg-descr b/textproc/uchardet/pkg-descr
new file mode 100644
index 000000000000..76b76205f82c
--- /dev/null
+++ b/textproc/uchardet/pkg-descr
@@ -0,0 +1,4 @@
+uchardet is a C language binding of the original C++ implementation
+of the universal charset detection library by Mozilla.
+
+WWW: https://code.google.com/p/uchardet/
diff --git a/textproc/uchardet/pkg-plist b/textproc/uchardet/pkg-plist
new file mode 100644
index 000000000000..b383794b84c5
--- /dev/null
+++ b/textproc/uchardet/pkg-plist
@@ -0,0 +1,8 @@
+bin/uchardet
+include/uchardet/uchardet.h
+lib/libuchardet.a
+lib/libuchardet.so
+lib/libuchardet.so.0
+lib/libuchardet.so.0.0.0
+libdata/pkgconfig/uchardet.pc
+man/man1/uchardet.1.gz