aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-07-19 09:00:31 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-07-19 09:00:31 +0000
commit5883931cd5f55e8ce7611c1a148b4b79b928c04b (patch)
treec74c88bebbdd55ca0afb5892abd05f8a90e6813d
parent2fe082806ee6fc0dd95793a92ea753c3ebadbd26 (diff)
downloadports-5883931cd5f55e8ce7611c1a148b4b79b928c04b.tar.gz
ports-5883931cd5f55e8ce7611c1a148b4b79b928c04b.zip
- Add LICENSE
- Switch to options helpers - Cosmetic fixes
Notes
Notes: svn path=/head/; revision=418763
-rw-r--r--graphics/deegree-igeoportal/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/graphics/deegree-igeoportal/Makefile b/graphics/deegree-igeoportal/Makefile
index a1563fbe0c05..db06bd23b28b 100644
--- a/graphics/deegree-igeoportal/Makefile
+++ b/graphics/deegree-igeoportal/Makefile
@@ -12,6 +12,8 @@ DISTNAME= ${PORTNAME}-std_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Browser based client handling WMS, WFS, and proxy service
+LICENSE= LGPL21+
+
USES= zip
USE_JAVA= 1.6+
@@ -34,14 +36,14 @@ OPTIONS_DEFINE= DOCS
.if ${PORT_OPTIONS:MTOMCAT6}
TOMCATVER= apache-tomcat-6.0
-TCPORT= 8180
+TCPORT= 8180
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat6
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat6
.endif
.if ${PORT_OPTIONS:MTOMCAT7}
TOMCATVER= apache-tomcat-7.0
-TCPORT= 8080
+TCPORT= 8080
BUILD_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat7
RUN_DEPENDS+= ${APPHOME}/bin/bootstrap.jar:www/tomcat7
.endif
@@ -51,10 +53,11 @@ post-extract:
@${TAR} xf ${WRKDIR}/igeoportal-std.war -C ${WRKDIR}/${PORTDIRNAME}
do-install:
- ${INSTALL} -d ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
+ @${MKDIR} ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
@cd ${WRKDIR}/${PORTDIRNAME} && ${COPYTREE_SHARE} \* ${STAGEDIR}${WEBAPPDIR}/${PORTDIRNAME}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKDIR}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>