aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-11-23 13:55:08 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-11-23 13:55:08 +0000
commit58ce8baa9d0915ddbb1f0303d845007327fbd1cf (patch)
treeccb2d6f94d51fdad956de0e5e8cfb2251877d2c7
parente050de4b9c320dffc668db53b6c65657d33884cc (diff)
downloadports-58ce8baa9d0915ddbb1f0303d845007327fbd1cf.tar.gz
ports-58ce8baa9d0915ddbb1f0303d845007327fbd1cf.zip
games/r1q2: unbreak the build on recent -CURRENT
Something had been changed in our toolchain which broke linking of this port because `SV_FixPlayerSkin' symbol became undefined. This function was annotated as `__inline', change it to `static' to unbreak the build as it is defined and called within a single file only. While here, remove unsupported optimization flag from the CFLAGS. Reported by: pkg-fallout
-rw-r--r--games/r1q2/Makefile2
-rw-r--r--games/r1q2/files/patch-binaries__make.inc2
2 files changed, 3 insertions, 1 deletions
diff --git a/games/r1q2/Makefile b/games/r1q2/Makefile
index b1f795e7e2d4..a452fe8547f2 100644
--- a/games/r1q2/Makefile
+++ b/games/r1q2/Makefile
@@ -71,6 +71,8 @@ PLIST_SUB+= REF_GL="@comment "
post-patch:
@${REINPLACE_CMD} -e 's|game$$(ARCH)|game|g' \
${BUILD_WRKSRC}/game/Makefile
+ @${REINPLACE_CMD} -e '/SV_FixPlayerSkin/s,__inline,static,' \
+ ${WRKSRC}/server/sv_game.c
pre-build:
@${FIND} ${BUILD_WRKSRC} -type d -depth 1 -exec ${MKDIR} {}/.depends \;
diff --git a/games/r1q2/files/patch-binaries__make.inc b/games/r1q2/files/patch-binaries__make.inc
index 7d0b61a4074c..5deef51b12fe 100644
--- a/games/r1q2/files/patch-binaries__make.inc
+++ b/games/r1q2/files/patch-binaries__make.inc
@@ -2,7 +2,7 @@
+++ binaries/make.inc Fri Sep 28 21:37:31 2007
@@ -1,5 +1,6 @@
-CFLAGS+=-DNDEBUG -DLINUX -O2 -fno-strict-aliasing -Wall -ffloat-store -pipe -g -MF .depends/$*.d -MMD
-+CFLAGS+=-I$(LOCALBASE)/include -DNDEBUG -DLINUX -DDATADIR='"$(Q2DIR)"' -DLIBDIR='"$(LIBDIR)"' -O2 -fno-strict-aliasing -Wall -ffloat-store -pipe -g -MF .depends/$*.d -MMD
++CFLAGS+=-I$(LOCALBASE)/include -DNDEBUG -DLINUX -DDATADIR='"$(Q2DIR)"' -DLIBDIR='"$(LIBDIR)"' -O2 -fno-strict-aliasing -Wall -pipe -g -MF .depends/$*.d -MMD
ALLOBJ:=$(ALLSRC:.c=.o)
+LDFLAGS+=-L$(LOCALBASE)/lib