aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-07-02 17:49:22 +0000
committerRene Ladan <rene@FreeBSD.org>2023-08-01 11:27:28 +0000
commit5981a247406772defbc64bf993e23580aaa0d4dd (patch)
tree046d67df6c0d0bdd8afcfd16603d5a0175b7d45d
parent6983bfc505340b4dc63a79134536fd1dcd4249bb (diff)
downloadports-5981a247406772defbc64bf993e23580aaa0d4dd.tar.gz
ports-5981a247406772defbc64bf993e23580aaa0d4dd.zip
all: remove support for expired FreeBSD 13.1
Approved by: portmgr (implicit), salvadore (gcc ports) Reviewed by: jbeich Differential Revision: https://reviews.freebsd.org/D40845
-rw-r--r--Mk/bsd.port.mk2
-rw-r--r--comms/ebusd/files/patch-src_lib_ebus_datatype.cpp10
-rw-r--r--devel/bbparse/Makefile7
-rw-r--r--editors/libreoffice/Makefile2
-rw-r--r--editors/openoffice-4/Makefile1
-rw-r--r--editors/openoffice-devel/Makefile1
-rw-r--r--emulators/virtualbox-ose/Makefile3
-rw-r--r--lang/gcc11-devel/files/patch-libphobos_libdruntime_core_sys_freebsd_config.d2
-rw-r--r--lang/gcc11/files/patch-libphobos_libdruntime_core_sys_freebsd_config.d2
-rw-r--r--net/samba416/Makefile6
-rw-r--r--net/tcplog_dumper/Makefile7
-rw-r--r--net/tcprtt/Makefile7
-rw-r--r--sysutils/nfs-over-tls/Makefile12
13 files changed, 13 insertions, 49 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 9f6dfb0452c1..b11c99fc0476 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1186,7 +1186,7 @@ OSVERSION!= ${AWK} '/^\#define[[:blank:]]__FreeBSD_version/ {print $$3}' < ${SRC
. endif
_EXPORTED_VARS+= OSVERSION
-. if ${OPSYS} == FreeBSD && (${OSVERSION} < 1204000 || (${OSVERSION} >= 1300000 && ${OSVERSION} < 1301000))
+. if ${OPSYS} == FreeBSD && (${OSVERSION} < 1204000 || (${OSVERSION} >= 1300000 && ${OSVERSION} < 1302000))
_UNSUPPORTED_SYSTEM_MESSAGE= Ports Collection support for your ${OPSYS} version has ended, and no ports\
are guaranteed to build on this system. Please upgrade to a supported release.
. if defined(ALLOW_UNSUPPORTED_SYSTEM)
diff --git a/comms/ebusd/files/patch-src_lib_ebus_datatype.cpp b/comms/ebusd/files/patch-src_lib_ebus_datatype.cpp
deleted file mode 100644
index 610c4f93e84a..000000000000
--- a/comms/ebusd/files/patch-src_lib_ebus_datatype.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/lib/ebus/datatype.cpp.orig 2023-06-07 06:49:34 UTC
-+++ src/lib/ebus/datatype.cpp
-@@ -22,6 +22,7 @@
-
- #include "lib/ebus/datatype.h"
- #include <math.h>
-+#include <cmath> // Only required for FreeBSD 13.1, later versions seems to be fine without that
- #include <iostream>
- #include <sstream>
- #include <iomanip>
diff --git a/devel/bbparse/Makefile b/devel/bbparse/Makefile
index 522e61cbe843..d762ebf20f68 100644
--- a/devel/bbparse/Makefile
+++ b/devel/bbparse/Makefile
@@ -10,6 +10,7 @@ WWW= https://github.com/Netflix/bbparse
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+IGNORE_FreeBSD_12=does not build
ONLY_FOR_ARCHS= amd64 powerpc64 powerpc64le
USE_GITHUB= yes
@@ -27,12 +28,6 @@ MANPAGE_LINKS= bbr_get_next bbr_get_stackname bbr_get_tlh bbr_init_fd bbr_init_f
PLIST_FILES+= man/man3/${l}.3.gz
.endfor
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300076
-IGNORE= builds only on FreeBSD 13-head with minimum revision 356414
-.endif
-
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/lib
${MKDIR} ${STAGEDIR}${PREFIX}/include
diff --git a/editors/libreoffice/Makefile b/editors/libreoffice/Makefile
index 34a299ff109c..1cc3830afcf6 100644
--- a/editors/libreoffice/Makefile
+++ b/editors/libreoffice/Makefile
@@ -333,8 +333,6 @@ BINARY_ALIAS= sed=gsed
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ( \
- (${OSVERSION} >= 1300525 && ${OSVERSION} < 1301000) || \
- (${OSVERSION} >= 1301500 && ${OSVERSION} < 1301502) || \
(${OSVERSION} >= 1400051 && ${OSVERSION} < 1400057))
BROKEN= please update FreeBSD base system first to fix an ABI incompatibility
.endif
diff --git a/editors/openoffice-4/Makefile b/editors/openoffice-4/Makefile
index bfc6ad41b8ef..64ae0fd63d5b 100644
--- a/editors/openoffice-4/Makefile
+++ b/editors/openoffice-4/Makefile
@@ -203,7 +203,6 @@ WITH= SDK
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ( \
- (${OSVERSION} >= 1301500 && ${OSVERSION} < 1301502) || \
(${OSVERSION} >= 1400051 && ${OSVERSION} < 1400057))
BROKEN= please update FreeBSD base system first to fix an ABI incompatibility
.endif
diff --git a/editors/openoffice-devel/Makefile b/editors/openoffice-devel/Makefile
index f9be22fabd47..63e6ffbc2f6a 100644
--- a/editors/openoffice-devel/Makefile
+++ b/editors/openoffice-devel/Makefile
@@ -233,7 +233,6 @@ WITH= SDK
.include <bsd.port.pre.mk>
.if ${OPSYS} == FreeBSD && ( \
- (${OSVERSION} >= 1301500 && ${OSVERSION} < 1301502) || \
(${OSVERSION} >= 1400051 && ${OSVERSION} < 1400057))
BROKEN= please update FreeBSD base system first to fix an ABI incompatibility
.endif
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 4e9b75177b16..8c341e4e0a66 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -202,8 +202,7 @@ EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-src_VBox_Devices_PC_DevFwCommon.cpp
# 2) llvm15 in FreeBSD miscompiles virtualbox 6.1 causing errors: PR#270189.
# Force llvm from ports.
.if ${OPSYS} == FreeBSD && \
- (${OSVERSION} < 1203502 || ${OSVERSION} >= 1300000 && ${OSVERSION} < 1300109 || \
- ${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 || ${OSVERSION} >= 1400079)
+ (${OSVERSION} >= 1302505 && ${OSVERSION} < 1400000 || ${OSVERSION} >= 1400079)
# USES must be before .include <bsd.port.pre.mk>, but CHOSEN_COMPILER_TYPE must be after.
# This is a workaround with possibility to define different llvm via VBOX_LLVM_VER in make.conf.
#USES+= llvm:min=11,max=14
diff --git a/lang/gcc11-devel/files/patch-libphobos_libdruntime_core_sys_freebsd_config.d b/lang/gcc11-devel/files/patch-libphobos_libdruntime_core_sys_freebsd_config.d
index 1cd22441936d..99288f341271 100644
--- a/lang/gcc11-devel/files/patch-libphobos_libdruntime_core_sys_freebsd_config.d
+++ b/lang/gcc11-devel/files/patch-libphobos_libdruntime_core_sys_freebsd_config.d
@@ -7,7 +7,7 @@
- version (FreeBSD_13) enum __FreeBSD_version = 1300000;
-else version (FreeBSD_12) enum __FreeBSD_version = 1202000;
+ version (FreeBSD_14) enum __FreeBSD_version = 1400000;
-+else version (FreeBSD_13) enum __FreeBSD_version = 1301000;
++else version (FreeBSD_13) enum __FreeBSD_version = 1302000;
+else version (FreeBSD_12) enum __FreeBSD_version = 1204000;
else version (FreeBSD_11) enum __FreeBSD_version = 1104000;
else version (FreeBSD_10) enum __FreeBSD_version = 1004000;
diff --git a/lang/gcc11/files/patch-libphobos_libdruntime_core_sys_freebsd_config.d b/lang/gcc11/files/patch-libphobos_libdruntime_core_sys_freebsd_config.d
index 1cd22441936d..99288f341271 100644
--- a/lang/gcc11/files/patch-libphobos_libdruntime_core_sys_freebsd_config.d
+++ b/lang/gcc11/files/patch-libphobos_libdruntime_core_sys_freebsd_config.d
@@ -7,7 +7,7 @@
- version (FreeBSD_13) enum __FreeBSD_version = 1300000;
-else version (FreeBSD_12) enum __FreeBSD_version = 1202000;
+ version (FreeBSD_14) enum __FreeBSD_version = 1400000;
-+else version (FreeBSD_13) enum __FreeBSD_version = 1301000;
++else version (FreeBSD_13) enum __FreeBSD_version = 1302000;
+else version (FreeBSD_12) enum __FreeBSD_version = 1204000;
else version (FreeBSD_11) enum __FreeBSD_version = 1104000;
else version (FreeBSD_10) enum __FreeBSD_version = 1004000;
diff --git a/net/samba416/Makefile b/net/samba416/Makefile
index f63b9c9a16f5..95ed3b12cc65 100644
--- a/net/samba416/Makefile
+++ b/net/samba416/Makefile
@@ -12,6 +12,8 @@ WWW= https://gitlab.com/samba-freebsd/
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
+IGNORE_FreeBSD_12= only runs on FreeBSD 13.1 and above due use of O_EMPTY_PATH
+
USES= cpe
CONFLICTS_INSTALL?= samba4*
@@ -409,10 +411,6 @@ UTMP_CONFIGURE_WITH= utmp
##############################################################################
.include <bsd.port.options.mk>
##############################################################################
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300076
-IGNORE=runs only on FreeBSD 13.1 and above due use of O_EMPTY_PATH
-.endif
-
.if !defined(WANT_EXP_MODULES) || empty(WANT_EXP_MODULES)
WANT_EXP_MODULES= vfs_cacheprime
.endif
diff --git a/net/tcplog_dumper/Makefile b/net/tcplog_dumper/Makefile
index 261db29afb77..951664199b63 100644
--- a/net/tcplog_dumper/Makefile
+++ b/net/tcplog_dumper/Makefile
@@ -13,6 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
ONLY_FOR_ARCHS= aarch64 amd64 mips64 mips64el mips64elhf mips64hf powerpc64 powerpc64le riscv64 riscv64sf
ONLY_FOR_ARCHS_REASON= only 64-bit platforms are supported
+IGNORE_FreeBSD_12=does not build
USE_GITHUB= yes
GH_ACCOUNT= Netflix
@@ -22,12 +23,6 @@ USE_RC_SUBR= tcplog_dumper
PLIST_FILES= sbin/tcplog_dumper \
man/man1/tcplog_dumper.1.gz
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300076
-IGNORE= builds only on FreeBSD 13-head with minimum revision 356414
-.endif
-
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/tcplog_dumper ${STAGEDIR}${PREFIX}/sbin
diff --git a/net/tcprtt/Makefile b/net/tcprtt/Makefile
index bec637b1dfb3..6d44084d6fda 100644
--- a/net/tcprtt/Makefile
+++ b/net/tcprtt/Makefile
@@ -7,18 +7,13 @@ COMMENT= Measures the TCP handshake RTT using the stats(9) statistics framework
LICENSE= BSD2CLAUSE
+IGNORE_FreeBSD_12=requires kernel OSVERSION 1300062 or above
USE_GITHUB= yes
GH_ACCOUNT= KlaraSystems
GH_TAGNAME= 1c857b8bd6e071290d118c96c051fbdf7db40129
PLIST_FILES= bin/tcprtt man/man8/${PORTNAME}.8.gz
-.include <bsd.port.options.mk>
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1300062
-IGNORE= requires kernel OSVERSION 1300062 or above
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tcprtt ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/tcprtt.8 ${STAGEDIR}${PREFIX}/man/man8
diff --git a/sysutils/nfs-over-tls/Makefile b/sysutils/nfs-over-tls/Makefile
index a74849b5ea1c..38b0d7f3d072 100644
--- a/sysutils/nfs-over-tls/Makefile
+++ b/sysutils/nfs-over-tls/Makefile
@@ -9,19 +9,15 @@ WWW= https://people.freebsd.org/~rmacklem/nfs-over-tls-setup.txt
LICENSE= BSD2CLAUSE
+IGNORE_FreeBSD_12=requires FreeBSD 13 or later with in-kernel TLS support \
+ and OpenSSL with KTLS enabled
+
LIB_DEPENDS= libssl.so:security/openssl
USES= kmod ssl
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 1300133
-IGNORE= requires FreeBSD 13 or later with in-kernel TLS support \
- and OpenSSL with KTLS enabled
-.endif
-
.if exists(/usr/sbin/rpc.tlsclntd)
IGNORE= already included in the base system
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>