aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2022-01-14 08:09:07 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2022-01-14 08:10:34 +0000
commit598b7625b04e0c0107c99dec5f66129c975916c1 (patch)
tree79bf4e991d226694fb6ff2689c38322a1033ab83
parent7c6b3a0d74c67f4c726b1abd05df2415d8fbc7dd (diff)
downloadports-598b7625b04e0c0107c99dec5f66129c975916c1.tar.gz
ports-598b7625b04e0c0107c99dec5f66129c975916c1.zip
net/haproxy: fix build with static pcre.
Pointed out by: Kirill Varnakov <kirill@varnakov.com>
-rw-r--r--net/haproxy/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 205da80f720e..60bfb36e3e9b 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -47,9 +47,9 @@ DPCRE_LIB_DEPENDS= libpcre.so:devel/pcre
DPCRE_MAKE_ARGS= USE_PCRE=1 USE_PCRE_JIT=1
DPCRE2_LIB_DEPENDS= libpcre2-8.so:devel/pcre2
DPCRE2_MAKE_ARGS= USE_PCRE2=1 USE_PCRE2_JIT=1
-SPCRE_LIB_DEPENDS= libpcre.a:devel/pcre
+SPCRE_BUILD_DEPENDS= ${LOCALBASE}/lib/libpcre.a:devel/pcre
SPCRE_MAKE_ARGS= USE_PCRE=1 USE_STATIC_PCRE=1 USE_PCRE_JIT=1
-SPCRE2_LIB_DEPENDS= libpcre2-8.a:devel/pcre2
+SPCRE2_BUILD_DEPENDS= ${LOCALBASE}/lib/libpcre2-8.a:devel/pcre2
SPCRE2_MAKE_ARGS= USE_PCRE2=1 USE_STATIC_PCRE2=1 USE_PCRE2_JIT=1
DEVICEATLAS_LIB_DEPENDS= libda.so:net/deviceatlas-enterprise-c
DEVICEATLAS_MAKE_ARGS= USE_DEVICEATLAS=1 DEVICEATLAS_LIB=${LOCALBASE}/lib DEVICEATLAS_INC=${LOCALBASE}/include