aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 17:06:34 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 17:54:16 +0000
commit5999040fd6b4228391390d0e08e8a161950d24ad (patch)
treed76931293b87ca41bdedcb74ce829f45d1b02a69
parent2dd993004188e2b97dc3904a76f2b5d1ae8cb800 (diff)
downloadports-5999040fd6b4228391390d0e08e8a161950d24ad.tar.gz
ports-5999040fd6b4228391390d0e08e8a161950d24ad.zip
devel/love5: Fix build with llvm16
- Add LICENSE BSD3CLAUSE - Utiize USES=localbase - Pet port{clippy|fmt} Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
-rw-r--r--devel/love5/Makefile31
1 files changed, 19 insertions, 12 deletions
diff --git a/devel/love5/Makefile b/devel/love5/Makefile
index f550a800ec61..301c34a48131 100644
--- a/devel/love5/Makefile
+++ b/devel/love5/Makefile
@@ -9,26 +9,33 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Open-source 2D game engine
WWW= https://www.love2d.org/
-LIB_DEPENDS= libIL.so:graphics/devil \
- libphysfs.so:devel/physfs \
- libfreetype.so:print/freetype2
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/license.txt
+
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+LIB_DEPENDS= libfreetype.so:print/freetype2 \
+ libIL.so:graphics/devil \
+ libphysfs.so:devel/physfs
-USES= tar:bzip2 gmake gl dos2unix lua:51 sdl
-USE_SDL= sdl mixer
+USES= dos2unix gl gmake localbase:ldflags lua:51 sdl tar:bzip2
+DOS2UNIX_FILES= src/system/love_system.cpp
+USE_CXXSTD= c++14
USE_GL= gl glu
+USE_SDL= mixer sdl
+
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
- -I${LUA_INCDIR} `${SDL_CONFIG} --cflags`
-CXXFLAGS+= -fsigned-char
-LDFLAGS+= -L${LOCALBASE}/lib -L${LUA_LIBDIR}
-CONFIGURE_ARGS= --bindir=${PREFIX}/bin --libdir=${PREFIX}/lib \
+CONFIGURE_ARGS= --bindir=${PREFIX}/bin \
+ --libdir=${PREFIX}/lib \
--program-suffix=5
-DOS2UNIX_FILES= src/system/love_system.cpp
-PLIST_FILES= bin/love5
+CPPFLAGS+= -I${LOCALBASE}/include/freetype2 \
+ -I${LUA_INCDIR} `${SDL_CONFIG} --cflags`
+CXXFLAGS+= -fsigned-char
+LDFLAGS+= -L${LUA_LIBDIR}
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX}
+
+PLIST_FILES= bin/love5
PORTDOCS= *
OPTIONS_DEFINE= DOCS