aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-10-10 08:59:05 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-10-10 20:08:58 +0000
commit59a4b7dc1d751774dc44af736f1b5ced8baa1aef (patch)
tree66ed64d35921e43e92df3828445b9fdc31c5804f
parente76a7c5d9e17c8b6ddf2cf661ba846cb6e92c166 (diff)
downloadports-59a4b7dc1d751774dc44af736f1b5ced8baa1aef.tar.gz
ports-59a4b7dc1d751774dc44af736f1b5ced8baa1aef.zip
misc/{,py-}fastscapelib: update 0.1.3-53 → 0.2.0
Reported by: portscout
-rw-r--r--misc/fastscapelib/Makefile5
-rw-r--r--misc/fastscapelib/distinfo6
-rw-r--r--misc/fastscapelib/pkg-plist6
-rw-r--r--misc/py-fastscapelib/Makefile16
-rw-r--r--misc/py-fastscapelib/distinfo6
-rw-r--r--misc/py-fastscapelib/files/patch-pyproject.toml11
6 files changed, 29 insertions, 21 deletions
diff --git a/misc/fastscapelib/Makefile b/misc/fastscapelib/Makefile
index 6df1bc0ea60f..af6b76014462 100644
--- a/misc/fastscapelib/Makefile
+++ b/misc/fastscapelib/Makefile
@@ -1,7 +1,6 @@
PORTNAME= fastscapelib
DISTVERSIONPREFIX= v
-DISTVERSION= 0.1.3-53
-DISTVERSIONSUFFIX= -g5698347
+DISTVERSION= 0.2.0
CATEGORIES= misc
MAINTAINER= yuri@FreeBSD.org
@@ -19,7 +18,7 @@ USES= cmake:testing
USE_GITHUB= yes
GH_ACCOUNT= fastscape-lem
-CMAKE_TESTING_ON= BUILD_TESTS
+CMAKE_TESTING_ON= FS_BUILD_TESTS
NO_ARCH= yes
diff --git a/misc/fastscapelib/distinfo b/misc/fastscapelib/distinfo
index cfde1fb9f4f9..45241831fe53 100644
--- a/misc/fastscapelib/distinfo
+++ b/misc/fastscapelib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1673219854
-SHA256 (fastscape-lem-fastscapelib-v0.1.3-53-g5698347_GH0.tar.gz) = 57c3e83041ba7b2e7e8bc789711d20fefc68b223c5e689e5801b23d18bc89c3c
-SIZE (fastscape-lem-fastscapelib-v0.1.3-53-g5698347_GH0.tar.gz) = 107177
+TIMESTAMP = 1696927095
+SHA256 (fastscape-lem-fastscapelib-v0.2.0_GH0.tar.gz) = 4029657425908b3fc4ef41339bd9db564b0308a4874316c2fdb4c67696db26d9
+SIZE (fastscape-lem-fastscapelib-v0.2.0_GH0.tar.gz) = 537682
diff --git a/misc/fastscapelib/pkg-plist b/misc/fastscapelib/pkg-plist
index 80ba359ae5e0..b550d3d4b3ae 100644
--- a/misc/fastscapelib/pkg-plist
+++ b/misc/fastscapelib/pkg-plist
@@ -4,8 +4,9 @@ include/fastscapelib/consts.hpp
include/fastscapelib/diffusion_adi.hpp
include/fastscapelib/flow_graph.hpp
include/fastscapelib/flow_graph_impl.hpp
+include/fastscapelib/flow_operator.hpp
include/fastscapelib/flow_router.hpp
-include/fastscapelib/flow_routing.hpp
+include/fastscapelib/flow_snapshot.hpp
include/fastscapelib/iterators.hpp
include/fastscapelib/pflood.hpp
include/fastscapelib/profile_grid.hpp
@@ -13,12 +14,11 @@ include/fastscapelib/raster_grid.hpp
include/fastscapelib/sink_resolver.hpp
include/fastscapelib/spl.hpp
include/fastscapelib/structured_grid.hpp
+include/fastscapelib/trimesh.hpp
include/fastscapelib/union_find.hpp
-include/fastscapelib/unstructured_mesh.hpp
include/fastscapelib/utils.hpp
include/fastscapelib/version.hpp
include/fastscapelib/xtensor_utils.hpp
lib/cmake/fastscapelib/fastscapelibConfig.cmake
lib/cmake/fastscapelib/fastscapelibConfigVersion.cmake
lib/cmake/fastscapelib/fastscapelibTargets.cmake
-libdata/pkgconfig/fastscapelib.pc
diff --git a/misc/py-fastscapelib/Makefile b/misc/py-fastscapelib/Makefile
index ca4efc083585..4adce043a483 100644
--- a/misc/py-fastscapelib/Makefile
+++ b/misc/py-fastscapelib/Makefile
@@ -1,8 +1,6 @@
PORTNAME= fastscapelib
DISTVERSIONPREFIX= v
-DISTVERSION= 0.1.3-53
-PORTREVISION= 1
-DISTVERSIONSUFFIX= -g5698347
+DISTVERSION= 0.2.0
CATEGORIES= misc
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,23 +9,23 @@ COMMENT= Library of efficient algorithms for topographic data
WWW= https://fastscapelib.readthedocs.io/en/latest/
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/../LICENSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= cmake:devel/cmake-core \
- pybind11>0:devel/pybind11 \
xtensor>0:math/xtensor \
xtensor-python>0:math/xtensor-python \
- ${PYNUMPY}
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}pybind11>0:devel/py-pybind11@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-build>0:devel/py-scikit-build@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-build-core>0:devel/py-scikit-build-core@${PY_FLAVOR}
RUN_DEPENDS= ${PYNUMPY}
USES= python
-USE_PYTHON= distutils autoplist pytest
+USE_PYTHON= pep517 autoplist pytest
USE_GITHUB= yes
GH_ACCOUNT= fastscape-lem
-WRKSRC_SUBDIR= python
-
TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
.include <bsd.port.mk>
diff --git a/misc/py-fastscapelib/distinfo b/misc/py-fastscapelib/distinfo
index cfde1fb9f4f9..ed532a98eb9b 100644
--- a/misc/py-fastscapelib/distinfo
+++ b/misc/py-fastscapelib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1673219854
-SHA256 (fastscape-lem-fastscapelib-v0.1.3-53-g5698347_GH0.tar.gz) = 57c3e83041ba7b2e7e8bc789711d20fefc68b223c5e689e5801b23d18bc89c3c
-SIZE (fastscape-lem-fastscapelib-v0.1.3-53-g5698347_GH0.tar.gz) = 107177
+TIMESTAMP = 1696926495
+SHA256 (fastscape-lem-fastscapelib-v0.2.0_GH0.tar.gz) = 4029657425908b3fc4ef41339bd9db564b0308a4874316c2fdb4c67696db26d9
+SIZE (fastscape-lem-fastscapelib-v0.2.0_GH0.tar.gz) = 537682
diff --git a/misc/py-fastscapelib/files/patch-pyproject.toml b/misc/py-fastscapelib/files/patch-pyproject.toml
new file mode 100644
index 000000000000..703b73ab414a
--- /dev/null
+++ b/misc/py-fastscapelib/files/patch-pyproject.toml
@@ -0,0 +1,11 @@
+--- pyproject.toml.orig 2023-10-10 18:00:46 UTC
++++ pyproject.toml
+@@ -4,7 +4,7 @@ requires = [
+ "pybind11",
+ # TODO: replace by "numpy>=1.25.0,<2" when dropping py3.8 support.
+ # https://github.com/scipy/oldest-supported-numpy/issues/76
+- "oldest-supported-numpy",
++ "numpy",
+ ]
+ build-backend = "scikit_build_core.build"
+