aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2022-08-20 07:26:39 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2022-08-20 07:32:11 +0000
commit5a2f556ccbd7685fb8149f1e63a6f692d057aa4c (patch)
tree6aa8977b535a103f94fc8a457ffa062fcdada1fc
parentab22566cfdf3becc9a5569e519a3ecab1449a755 (diff)
downloadports-5a2f556ccbd7685fb8149f1e63a6f692d057aa4c.tar.gz
ports-5a2f556ccbd7685fb8149f1e63a6f692d057aa4c.zip
archivers/zstd: Add LTO option
Add LTO option, this increases performance between 5-15% on my test systems (arm64 and amd64) with optimized cflags (-03) enabled. LTO is also enabled by default on Alpine Linux and OpenMandriva PR: 265605 Approved by: sunpoet (maintainer timeout, 2+ weeks)
-rw-r--r--archivers/zstd/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/archivers/zstd/Makefile b/archivers/zstd/Makefile
index ec45710de745..49255dbd1187 100644
--- a/archivers/zstd/Makefile
+++ b/archivers/zstd/Makefile
@@ -23,9 +23,10 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
SHEBANG_FILES= *.py
-OPTIONS_DEFINE= LZ4 OPTIMIZED_CFLAGS TEST
+OPTIONS_DEFINE= LTO LZ4 OPTIMIZED_CFLAGS TEST
OPTIONS_DEFAULT=LZ4
+LTO_MESON_TRUE= b_lto
LZ4_LIB_DEPENDS= liblz4.so:archivers/liblz4
LZ4_MESON_ENABLED= lz4
LZ4_USES= localbase:ldflags