aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Fechner <mfechner@FreeBSD.org>2024-02-09 10:29:45 +0000
committerMatthias Fechner <mfechner@FreeBSD.org>2024-02-18 04:53:32 +0000
commit5a638f64132ce3edc3991a2672ac524d95b06030 (patch)
tree00da80033e8234c2547c412762c6589309b9571e
parent8e2a489ff22f0c1c3daf5b0183efddb0e6793d3a (diff)
downloadports-5a638f64132ce3edc3991a2672ac524d95b06030.tar.gz
ports-5a638f64132ce3edc3991a2672ac524d95b06030.zip
www/gitlab-ce: use sidekiq from ports
The vendored sidekiq version does pollute the build environment, as it does not respect the STAGEDIR. As the vendored gem is maybe only a temporary solution: https://gitlab.com/gitlab-org/gitlab/-/merge_requests/142986 till these changes are fixed upstream, I will switch back to the sidekiq 7.1.6 version provided via ports.
-rw-r--r--www/gitlab-ce/Makefile1
-rw-r--r--www/gitlab-ce/files/patch-Gemfile13
2 files changed, 12 insertions, 2 deletions
diff --git a/www/gitlab-ce/Makefile b/www/gitlab-ce/Makefile
index 791e2fa3fb90..e83aaff711b7 100644
--- a/www/gitlab-ce/Makefile
+++ b/www/gitlab-ce/Makefile
@@ -155,6 +155,7 @@ MY_DEPENDS= git>=2.41.0:devel/git \
rubygem-sd_notify>=0.1.1<0.2:devel/rubygem-sd_notify \
rubygem-state_machines-activerecord08>=0.8.0<0.9.0:databases/rubygem-state_machines-activerecord08 \
rubygem-acts-as-taggable-on>=10.0<11:www/rubygem-acts-as-taggable-on \
+ rubygem-sidekiq71>=7.1.6<7.2:devel/rubygem-sidekiq71 \
rubygem-sidekiq-cron-rails70>=1.12.0<1.13:devel/rubygem-sidekiq-cron-rails70 \
rubygem-fugit18>=1.8.1<1.9:devel/rubygem-fugit18 \
rubygem-httparty>=0.21.0<0.22:www/rubygem-httparty \
diff --git a/www/gitlab-ce/files/patch-Gemfile b/www/gitlab-ce/files/patch-Gemfile
index db38faea6542..3e6bc6165173 100644
--- a/www/gitlab-ce/files/patch-Gemfile
+++ b/www/gitlab-ce/files/patch-Gemfile
@@ -1,4 +1,4 @@
---- Gemfile.orig 2024-01-24 16:26:54 UTC
+--- Gemfile.orig 2024-02-07 07:58:11 UTC
+++ Gemfile
@@ -58,7 +58,7 @@ gem 'neighbor', '~> 0.2.3' # rubocop:todo Gemfile/Miss
@@ -41,7 +41,16 @@
gem 'faraday_middleware-aws-sigv4', '~>0.3.0' # rubocop:todo Gemfile/MissingFeatureCategory
gem 'typhoeus', '~> 1.4.0' # Used with Elasticsearch to support http keep-alive connections # rubocop:todo Gemfile/MissingFeatureCategory
-@@ -392,134 +392,15 @@ gem 'prometheus-client-mmap', '~> 1.1', require: 'prom
+@@ -252,7 +252,7 @@ gem 'state_machines-activerecord', '~> 0.8.0' # ruboco
+ gem 'acts-as-taggable-on', '~> 10.0' # rubocop:todo Gemfile/MissingFeatureCategory
+
+ # Background jobs
+-gem 'sidekiq', path: 'vendor/gems/sidekiq-7.1.6', require: 'sidekiq' # rubocop:todo Gemfile/MissingFeatureCategory
++gem 'sidekiq', '~> 7.1.6', require: 'sidekiq' # rubocop:todo Gemfile/MissingFeatureCategory
+ gem 'sidekiq-cron', '~> 1.12.0', feature_category: :shared
+ gem 'gitlab-sidekiq-fetcher', path: 'vendor/gems/sidekiq-reliable-fetch', require: 'sidekiq-reliable-fetch' # rubocop:todo Gemfile/MissingFeatureCategory
+
+@@ -392,134 +392,15 @@ gem 'prometheus-client-mmap', '~> 1.1', '>= 1.1.1', re
gem 'warning', '~> 1.3.0' # rubocop:todo Gemfile/MissingFeatureCategory