aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-04-08 22:27:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-04-08 22:45:45 +0000
commit5a6beeaed0fa11c007feba49c027e8424f05de7e (patch)
treecbe402b9921b7a40b0393675a2754c26feed19e3
parent4395c84bf891613c3c76551b96a797e58bdde0e9 (diff)
downloadports-5a6beeaed0fa11c007feba49c027e8424f05de7e.tar.gz
ports-5a6beeaed0fa11c007feba49c027e8424f05de7e.zip
devel/clanlib: add LICENSE and missing depends
-rw-r--r--devel/clanlib/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index e588a792e59c..856367fce3bf 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -12,20 +12,23 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Cross-platform game SDK
LICENSE= ZLIB
+LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_i386= typedef redefinition with different types ('ptrdiff_t' (aka 'int') vs 'khronos_intptr_t' (aka 'long'))
+BROKEN_i386= typedef redefinition with different types ('ptrdiff_t' (aka 'int') vs 'khronos_intptr_t' (aka 'long'))
LIB_DEPENDS= libpng.so:graphics/png \
libmikmod.so:audio/libmikmod \
libvorbis.so:audio/libvorbis \
+ libogg.so:audio/libogg \
libfontconfig.so:x11-fonts/fontconfig \
- libpcre.so:devel/pcre
+ libpcre.so:devel/pcre \
+ libfreetype.so:print/freetype2
USES= compiler:c++11-lib gl gmake jpeg libtool localbase:ldflags \
pathfix pkgconfig sqlite tar:tgz xorg
-USE_XORG= x11
+USE_XORG= x11 xrender
USE_LDCONFIG= yes
-USE_GL= yes
+USE_GL= gl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-docs \