aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@mehnert.org>2023-05-27 13:37:32 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-05-29 23:25:16 +0000
commit5ac3886b7616aee99bec227268c08f98068a7a5b (patch)
treece149131ff39c297b8fd4a904ff208d2a08c323b
parent6f4e0f0f2e8d96ee1703076e8b3e8d6482ec3501 (diff)
downloadports-5ac3886b7616aee99bec227268c08f98068a7a5b.tar.gz
ports-5ac3886b7616aee99bec227268c08f98068a7a5b.zip
devel/ocaml-opam: update to 2.1.5
- attempt to patch the build for armv7 - realise that it still doesn't build and mark as BROKEN_armv[67] Changelog: https://github.com/ocaml/opam/blob/2.1/CHANGES PR: 271674
-rw-r--r--devel/ocaml-opam/Makefile6
-rw-r--r--devel/ocaml-opam/distinfo6
-rw-r--r--devel/ocaml-opam/files/patch-Makefile10
-rw-r--r--devel/ocaml-opam/files/patch-shell_bootstrap-ocaml.sh14
-rw-r--r--devel/ocaml-opam/files/patch-src__ext_ocaml-patches_0001-Fix-relocation-ocaml-32-bit.patch66
5 files changed, 38 insertions, 64 deletions
diff --git a/devel/ocaml-opam/Makefile b/devel/ocaml-opam/Makefile
index 7a231f9b2ff5..7452bf3fb013 100644
--- a/devel/ocaml-opam/Makefile
+++ b/devel/ocaml-opam/Makefile
@@ -1,6 +1,5 @@
PORTNAME= opam
-PORTVERSION= 2.1.2
-PORTREVISION= 1
+DISTVERSION= 2.1.5
CATEGORIES= devel
MASTER_SITES= https://github.com/ocaml/opam/releases/download/${DISTVERSION}/
PKGNAMEPREFIX= ocaml-
@@ -12,6 +11,9 @@ WWW= https://opam.ocaml.org/
LICENSE= LGPL21
+BROKEN_armv6= ld: error: can't create dynamic relocation R_ARM_ABS32 against symbol: caml_program in readonly segment
+BROKEN_armv7= ld: error: can't create dynamic relocation R_ARM_ABS32 against symbol: caml_program in readonly segment
+
RUN_DEPENDS= curl:ftp/curl \
gpatch:devel/patch
diff --git a/devel/ocaml-opam/distinfo b/devel/ocaml-opam/distinfo
index 5fb45c6fecbf..c20f25b31732 100644
--- a/devel/ocaml-opam/distinfo
+++ b/devel/ocaml-opam/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1640170441
-SHA256 (opam-full-2.1.2.tar.gz) = de1e3efffd5942e0101ef83dcdead548cc65a93e13986aecb4a264a059457ede
-SIZE (opam-full-2.1.2.tar.gz) = 9442446
+TIMESTAMP = 1685183447
+SHA256 (opam-full-2.1.5.tar.gz) = 15e40a75f6fa419164fb20bedd27c851146c2d576a63937cd13b317f3bc2ab93
+SIZE (opam-full-2.1.5.tar.gz) = 53353534
diff --git a/devel/ocaml-opam/files/patch-Makefile b/devel/ocaml-opam/files/patch-Makefile
index 76bc788026c4..9e275c51ad28 100644
--- a/devel/ocaml-opam/files/patch-Makefile
+++ b/devel/ocaml-opam/files/patch-Makefile
@@ -1,11 +1,11 @@
---- Makefile.orig 2021-12-07 16:13:53 UTC
+--- Makefile.orig 2023-05-27 12:33:21 UTC
+++ Makefile
-@@ -252,7 +252,7 @@ endif
+@@ -258,7 +258,7 @@
.PHONY: compiler cold
compiler:
-- env MAKE=$(MAKE) BOOTSTRAP_EXTRA_OPTS= BOOTSTRAP_OPT_TARGET=opt.opt BOOTSTRAP_ROOT=.. BOOTSTRAP_DIR=bootstrap ./shell/bootstrap-ocaml.sh $(OCAML_PORT)
-+ env CC="$(CC)" MAKE=$(MAKE) BOOTSTRAP_EXTRA_OPTS= BOOTSTRAP_OPT_TARGET=opt.opt BOOTSTRAP_ROOT=.. BOOTSTRAP_DIR=bootstrap ./shell/bootstrap-ocaml.sh $(OCAML_PORT)
+- env MAKE=$(MAKE) BOOTSTRAP_EXTRA_OPTS= BOOTSTRAP_TARGETS=world.opt BOOTSTRAP_ROOT=.. BOOTSTRAP_DIR=bootstrap ./shell/bootstrap-ocaml.sh $(OCAML_PORT)
++ env CC="$(CC)" MAKE=$(MAKE) BOOTSTRAP_EXTRA_OPTS= BOOTSTRAP_TARGETS=world.opt BOOTSTRAP_ROOT=.. BOOTSTRAP_DIR=bootstrap ./shell/bootstrap-ocaml.sh $(OCAML_PORT)
src_ext/secondary/ocaml/bin/ocaml:
- env MAKE=$(MAKE) BOOTSTRAP_EXTRA_OPTS="--disable-ocamldoc --disable-debug-runtime --disable-debugger" BOOTSTRAP_OPT_TARGET=opt BOOTSTRAP_ROOT=../.. BOOTSTRAP_DIR=src_ext/secondary ./shell/bootstrap-ocaml.sh $(OCAML_PORT)
+ env MAKE=$(MAKE) BOOTSTRAP_EXTRA_OPTS="--disable-ocamldoc --disable-debug-runtime --disable-debugger" BOOTSTRAP_TARGETS="world opt" BOOTSTRAP_ROOT=../.. BOOTSTRAP_DIR=src_ext/secondary ./shell/bootstrap-ocaml.sh $(OCAML_PORT)
diff --git a/devel/ocaml-opam/files/patch-shell_bootstrap-ocaml.sh b/devel/ocaml-opam/files/patch-shell_bootstrap-ocaml.sh
index afa9173af3b5..a70a0a9b9c99 100644
--- a/devel/ocaml-opam/files/patch-shell_bootstrap-ocaml.sh
+++ b/devel/ocaml-opam/files/patch-shell_bootstrap-ocaml.sh
@@ -1,19 +1,11 @@
---- shell/bootstrap-ocaml.sh.orig 2021-12-07 16:13:53 UTC
+--- shell/bootstrap-ocaml.sh.orig 2023-05-27 13:09:27 UTC
+++ shell/bootstrap-ocaml.sh
-@@ -8,7 +8,6 @@ elif command -v wget > /dev/null; then
- CURL=wget
- else
- echo "This script requires curl or wget"
-- exit 1
- fi
- BOOTSTRAP_DIR=${BOOTSTRAP_DIR:-bootstrap}
- BOOTSTRAP_ROOT=${BOOTSTRAP_ROOT:-..}
-@@ -43,6 +42,9 @@ else
+@@ -42,6 +42,9 @@
mkdir -p ${V}
fi
cd ${V}
+for p in ../../src_ext/ocaml-patches/*.patch; do
-+ patch -p1 < $p;
++ patch -p1 < $p;
+done;
PATH_PREPEND=
LIB_PREPEND=
diff --git a/devel/ocaml-opam/files/patch-src__ext_ocaml-patches_0001-Fix-relocation-ocaml-32-bit.patch b/devel/ocaml-opam/files/patch-src__ext_ocaml-patches_0001-Fix-relocation-ocaml-32-bit.patch
index feb111b6dbbe..e091694ffe0c 100644
--- a/devel/ocaml-opam/files/patch-src__ext_ocaml-patches_0001-Fix-relocation-ocaml-32-bit.patch
+++ b/devel/ocaml-opam/files/patch-src__ext_ocaml-patches_0001-Fix-relocation-ocaml-32-bit.patch
@@ -1,45 +1,25 @@
---- src_ext/ocaml-patches/0001-Fix-relocation-ocaml-32-bit.patch.orig 2021-12-25 16:24:31 UTC
+--- src_ext/ocaml-patches/0001-Fix-relocation-ocaml-32-bit.patch.orig 2023-05-27 13:17:37 UTC
+++ src_ext/ocaml-patches/0001-Fix-relocation-ocaml-32-bit.patch
-@@ -0,0 +1,42 @@
-+diff --git a/configure b/configure
-+index b1e287aed..4754e8ab2 100755
-+--- a/configure
-++++ b/configure
-+@@ -14120,6 +14120,17 @@ case $arch in #(
-+ esac ;;
+@@ -0,0 +1,22 @@
++--- a/configure.orig 2023-05-27 13:13:22 UTC
+++++ a/configure
++@@ -14070,6 +14070,10 @@
++ case $CC,$host in #(
++ gcc*,powerpc-*-linux*) :
++ mksharedlib="$CC -shared -mbss-plt \$(LDFLAGS)" ;; #(
+++ *,i[3456]86-*) :
+++ # Disable DT_TEXTREL warnings on Linux and BSD i386
+++ # See https://github.com/ocaml/ocaml/issues/9800
+++ mksharedlib="$CC -shared \$(LDFLAGS) -Wl,-z,notext" ;; #(
++ *) :
++ mksharedlib="$CC -shared \$(LDFLAGS)" ;;
+ esac
-+
-++# Disable DT_TEXTREL warnings on Linux i386
-++# See https://github.com/ocaml/ocaml/issues/9800
-++
-++case "$system" in #(
-++ linux_elf|bsd_elf) :
-++ mksharedlib="$mksharedlib -Wl,-z,notext"
-++ mkmaindll="$mkmaindll -Wl,-z,notext" ;; #(
-++ *) :
-++ ;;
-++esac
-++
-+ # Assembler
-+
-+ if test -n "$host_alias"; then :
-+diff --git a/configure.ac b/configure.ac
-+index 656ffe20c..1c9694805 100644
-+--- a/configure.ac
-++++ b/configure.ac
-+@@ -1070,6 +1070,15 @@ AS_CASE([$arch],
-+ [common_cflags="-no-pie $common_cflags"],
-+ [])])
-+
-++# Disable DT_TEXTREL warnings on Linux i386
-++# See https://github.com/ocaml/ocaml/issues/9800
-++
-++AS_CASE(["$system"],
-++ [linux_elf|bsd_elf],
-++ [mksharedlib="$mksharedlib -Wl,-z,notext"
-++ mkmaindll="$mkmaindll -Wl,-z,notext"],
-++ [])
-++
-+ # Assembler
-+
-+ AS_IF([test -n "$host_alias"], [toolpref="${host_alias}-"], [toolpref=""])
++@@ -14281,6 +14285,8 @@
++ arch=arm; model=armv6; system=linux_eabi ;; #(
++ armv6*-*-freebsd*) :
++ arch=arm; model=armv6; system=freebsd ;; #(
+++ armv7*-*-freebsd*) :
+++ arch=arm; model=armv7; system=freebsd ;; #(
++ earmv6*-*-netbsd*) :
++ arch=arm; model=armv6; system=netbsd ;; #(
++ earmv7*-*-netbsd*) :