aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGoran Mekić <meka@tilda.center>2023-05-28 16:15:53 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-06-08 10:51:07 +0000
commit5ae00f31b566bb627decdf590dd002e0c57dde3b (patch)
tree82fdbb5ea61561095f1a9253688581cd1be87d2d
parent8ffec20dfd5343afa84a818d3103f98deaea6005 (diff)
downloadports-5ae00f31b566bb627decdf590dd002e0c57dde3b.tar.gz
ports-5ae00f31b566bb627decdf590dd002e0c57dde3b.zip
net/py-bonsai: Module for handling LDAP operations in Python
This module uses libldap2 on Unix platforms and WinLDAP on Microsoft Windows. LDAP entries are mapped to a special Python case-insensitive dictionary, tracking the changes of the dictionary to modify the entry on the server easily. WWW: https://github.com/noirello/bonsai PR: 271696
-rw-r--r--net/Makefile1
-rw-r--r--net/py-bonsai/Makefile30
-rw-r--r--net/py-bonsai/distinfo3
-rw-r--r--net/py-bonsai/pkg-descr3
4 files changed, 37 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 65cc246499cb..9233d1ecbd7d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1032,6 +1032,7 @@
SUBDIR += py-amqp
SUBDIR += py-amqplib
SUBDIR += py-avahi
+ SUBDIR += py-bonsai
SUBDIR += py-cepa
SUBDIR += py-cjdns
SUBDIR += py-cloudflare-scrape
diff --git a/net/py-bonsai/Makefile b/net/py-bonsai/Makefile
new file mode 100644
index 000000000000..431efab98631
--- /dev/null
+++ b/net/py-bonsai/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= bonsai
+DISTVERSION= 1.5.1
+CATEGORIES= net devel python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= meka@tilda.center
+COMMENT= Module for handling LDAP operations in Python
+WWW= https://github.com/noirello/bonsai
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+MY_DEPENDS= openldap26-client>=0:net/openldap26-client
+BUILD_DEPENDS= ${MY_DEPENDS}
+RUN_DEPENDS= ${MY_DEPENDS}
+
+USES= localbase python:3.7+
+USE_PYTHON= autoplist concurrent distutils pytest
+
+OPTIONS_DEFINE= GEVENT TORNADO TRIO
+
+GEVENT_DESC= Support for async IO using gevent
+GEVENT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gevent>=0:devel/py-gevent@${PY_FLAVOR}
+TORNADO_DESC= Support for async IO using tornado
+TORNADO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tornado>=0:www/py-tornado@${PY_FLAVOR}
+TRIO_DESC= Support for async IO using trio
+TRIO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}trio>=0:net/py-trio@${PY_FLAVOR}
+
+.include <bsd.port.mk>
diff --git a/net/py-bonsai/distinfo b/net/py-bonsai/distinfo
new file mode 100644
index 000000000000..914634a907ac
--- /dev/null
+++ b/net/py-bonsai/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1685288184
+SHA256 (bonsai-1.5.1.tar.gz) = 101b0d166349bdcbf764a8139fd06b85b5524b4425e3f2bd6c2381f90369f735
+SIZE (bonsai-1.5.1.tar.gz) = 149639
diff --git a/net/py-bonsai/pkg-descr b/net/py-bonsai/pkg-descr
new file mode 100644
index 000000000000..cda2fc9bd6ac
--- /dev/null
+++ b/net/py-bonsai/pkg-descr
@@ -0,0 +1,3 @@
+This module uses libldap2 on Unix platforms and WinLDAP on Microsoft Windows.
+LDAP entries are mapped to a special Python case-insensitive dictionary,
+tracking the changes of the dictionary to modify the entry on the server easily.