aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-01-20 16:09:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-01-20 21:06:47 +0000
commit5b58ca16f59f6bc5a51dbf004e09af19ca55a4e6 (patch)
tree01883c40ee383a73801df332397dbabe1f4bbcda
parentfc70b79b196e18ed131c728f2f138fe2c04d1d46 (diff)
downloadports-5b58ca16f59f6bc5a51dbf004e09af19ca55a4e6.tar.gz
ports-5b58ca16f59f6bc5a51dbf004e09af19ca55a4e6.zip
math/py-pyrr: New port: 3D mathematical functions using NumPy
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pyrr/Makefile29
-rw-r--r--math/py-pyrr/distinfo3
-rw-r--r--math/py-pyrr/pkg-descr13
4 files changed, 46 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 236381a7fdf9..45f67ab3a56b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -995,6 +995,7 @@
SUBDIR += py-pyodeint
SUBDIR += py-pyodesys
SUBDIR += py-pyreadr
+ SUBDIR += py-pyrr
SUBDIR += py-pysmt
SUBDIR += py-pystan
SUBDIR += py-pysym
diff --git a/math/py-pyrr/Makefile b/math/py-pyrr/Makefile
new file mode 100644
index 000000000000..2453c7dd3711
--- /dev/null
+++ b/math/py-pyrr/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= pyrr
+DISTVERSION= 0.10.3
+CATEGORIES= math
+#MASTER_SITES= PYPI # no tests
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= 3D mathematical functions using NumPy
+WWW= https://github.com/adamlwgriffiths/Pyrr
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}multipledispatch>0:devel/py-multipledispatch@${PY_FLAVOR} \
+ ${PYNUMPY}
+
+USES= python
+USE_PYTHON= distutils autoplist pytest
+
+USE_GITHUB= yes
+GH_ACCOUNT= adamlwgriffiths
+GH_PROJECT= Pyrr
+
+NO_ARCH= yes
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+TEST_WRKSRC= ${WRKSRC}/tests
+
+.include <bsd.port.mk>
diff --git a/math/py-pyrr/distinfo b/math/py-pyrr/distinfo
new file mode 100644
index 000000000000..caad5f8ac76b
--- /dev/null
+++ b/math/py-pyrr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1674248099
+SHA256 (adamlwgriffiths-Pyrr-0.10.3_GH0.tar.gz) = 0c585cee150a7a2dd0cfc82531a26a9996a93f456367054be3401c542a99b4dd
+SIZE (adamlwgriffiths-Pyrr-0.10.3_GH0.tar.gz) = 66011
diff --git a/math/py-pyrr/pkg-descr b/math/py-pyrr/pkg-descr
new file mode 100644
index 000000000000..795f6f70a9a8
--- /dev/null
+++ b/math/py-pyrr/pkg-descr
@@ -0,0 +1,13 @@
+Pyrr provides 3D mathematical functions using the power of NumPy.
+
+Features:
+* Object Oriented and Procedural interfaces
+* Matrix (3x3, 4x4)
+* Quaternion
+* Vector (3D, 4D)
+* Plane
+* Ray
+* Line / Line Segment (3D)
+* Rectangle (2D)
+* Axis Aligned Bounding Box (AABB / AAMBB)
+* Geometric collision / intersection testing