aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJamie Landeg-Jones <jamie@catflap.org>2023-06-28 10:01:13 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2023-06-29 11:35:20 +0000
commit5b60ec37e75d77fe8b2ecc786c27fbdce8f6f571 (patch)
tree5333b6115452d704cfe3ea1342d99a0a0f60a0fa
parent563ab38aeb7691c7d4b40623c84d5abd083e907d (diff)
downloadports-5b60ec37e75d77fe8b2ecc786c27fbdce8f6f571.tar.gz
ports-5b60ec37e75d77fe8b2ecc786c27fbdce8f6f571.zip
emulators/rtc: deprecate and return to pool
Doesn't work in modern FreeBSD versions. PR: 272237 Reported by: jamie@catflap.org (maintainer)
-rw-r--r--emulators/rtc/Makefile6
-rw-r--r--emulators/rtc/files/rtc.c4
2 files changed, 7 insertions, 3 deletions
diff --git a/emulators/rtc/Makefile b/emulators/rtc/Makefile
index 19226b456aa2..66e5009b17f3 100644
--- a/emulators/rtc/Makefile
+++ b/emulators/rtc/Makefile
@@ -1,14 +1,18 @@
PORTNAME= rtc
PORTVERSION= 2020.07.07.1
+PORTREVISION= 1
CATEGORIES= emulators linux
MASTER_SITES= # none
DISTFILES= # none
-MAINTAINER= jamie@catflap.org
+MAINTAINER= ports@FreeBSD.org
COMMENT= Kernel module which provides /dev/rtc device support
LICENSE= BSD2CLAUSE
+DEPRECATED= Driver doesn't actually work with current FreeBSD versions
+EXPIRATION_DATE= 2023-12-31
+
USES= kmod uidfix
WRKSRC= ${WRKDIR}/files
diff --git a/emulators/rtc/files/rtc.c b/emulators/rtc/files/rtc.c
index 5c3d8cf1c5b2..13e0f467e2f2 100644
--- a/emulators/rtc/files/rtc.c
+++ b/emulators/rtc/files/rtc.c
@@ -66,8 +66,8 @@ struct rtc_softc {
struct {
int freq;
struct {
- int opened:1;
- int enabled:1;
+ unsigned int opened:1;
+ unsigned int enabled:1;
} flags;
struct callout rtc_handle;
struct timespec lasttime;