aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2022-10-24 06:51:22 +0000
committerDima Panov <fluffy@FreeBSD.org>2022-10-24 06:56:24 +0000
commit5c793405d0e9f0aa05553a2888d6e31b1a17edb1 (patch)
treeb8696a5d44179bdaa50246cbab6afe437e08dcd6
parent4f6cbad96370e27a80553846871edd5805d049ad (diff)
downloadports-5c793405d0e9f0aa05553a2888d6e31b1a17edb1.tar.gz
ports-5c793405d0e9f0aa05553a2888d6e31b1a17edb1.zip
graphics/ptex: update to 2.4.2 release (+)
* Drop custom do-install target, cmake automation do it well * Bump direct consumers Changes sinve 2.3.2 release: v2.4.0 May 18, 2021 API: headers and DSOs hide non-API symbols by default. v2.4.1 Aug 3, 2021 API: Windows symbol visibility fixes. v2.4.2 Aug 4, 2022 API: Windows Clang/14 support, visibility fixes and cmake enhancements. Approved by: maintaimer (implicit)
-rw-r--r--graphics/openimageio-ociov1/Makefile4
-rw-r--r--graphics/openimageio/Makefile2
-rw-r--r--graphics/opensubdiv/Makefile2
-rw-r--r--graphics/ptex/Makefile27
-rw-r--r--graphics/ptex/distinfo6
-rw-r--r--graphics/ptex/files/patch-CMakeLists.txt18
-rw-r--r--graphics/ptex/files/patch-src_ptex_PtexPlatform.h (renamed from graphics/ptex/files/patch-ptex__PtexPlatform.h)6
-rw-r--r--graphics/ptex/files/patch-src_ptex_PtexWriter.cpp (renamed from graphics/ptex/files/patch-ptex__PtexWriter.cpp)4
-rw-r--r--graphics/ptex/pkg-plist40
9 files changed, 62 insertions, 47 deletions
diff --git a/graphics/openimageio-ociov1/Makefile b/graphics/openimageio-ociov1/Makefile
index f269719643c1..7545652a30f1 100644
--- a/graphics/openimageio-ociov1/Makefile
+++ b/graphics/openimageio-ociov1/Makefile
@@ -1,7 +1,7 @@
PORTNAME= openimageio
DISTVERSIONPREFIX= Release-
DISTVERSION= 2.2.21.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics multimedia
PKGNAMESUFFIX= -ociov1
# special port to link oiio libs with ociov1
@@ -31,6 +31,8 @@ USE_GITHUB= yes
GH_ACCOUNT= OpenImageIO
GH_PROJECT= oiio
+PORTSCOUT= limit:^2\.2\.
+
CMAKE_ON= USE_OCIO
CMAKE_OFF= BUILDSTATIC INSTALL_FONTS LINKSTATIC NOTHREADS \
STOP_ON_WARNING USE_OPENSSL USE_QT USE_OPENGL \
diff --git a/graphics/openimageio/Makefile b/graphics/openimageio/Makefile
index 6bf8539792d3..8161c504e3a5 100644
--- a/graphics/openimageio/Makefile
+++ b/graphics/openimageio/Makefile
@@ -5,7 +5,7 @@ DISTVERSION= 2.4.4.2
# py-openimageio's PORTREVISION.
# Also, just to be on the safe side, when resetting,
# best keep PORTREVISION?= 0.
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= graphics multimedia
MAINTAINER?= FreeBSD@Shaneware.biz
diff --git a/graphics/opensubdiv/Makefile b/graphics/opensubdiv/Makefile
index a299dd239333..e867b92e27bf 100644
--- a/graphics/opensubdiv/Makefile
+++ b/graphics/opensubdiv/Makefile
@@ -1,7 +1,7 @@
PORTNAME= opensubdiv
DISTVERSIONPREFIX= v
DISTVERSION= 3_5_0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= graphics
MAINTAINER= FreeBSD@Shaneware.biz
diff --git a/graphics/ptex/Makefile b/graphics/ptex/Makefile
index 58911f4c5729..0dcbf6578aa0 100644
--- a/graphics/ptex/Makefile
+++ b/graphics/ptex/Makefile
@@ -1,7 +1,6 @@
PORTNAME= ptex
-PORTREVISION= 2
DISTVERSIONPREFIX= v
-DISTVERSION= 2.3.2
+DISTVERSION= 2.4.2
CATEGORIES?= graphics
MAINTAINER= FreeBSD@Shaneware.biz
@@ -18,28 +17,16 @@ USE_GITHUB= yes
GH_ACCOUNT= wdas
# yes really, the release tarbal doesn't know what version it is
-CMAKE_ARGS+= -DPTEX_VER:STRING=${DISTVERSION}
+CMAKE_ARGS+= -DPTEX_VER:STRING=${DISTVERSION} \
+ -DCMAKE_INSTALL_INCLUDEDIR:STRING=${LOCALBASE}/include/ptex \
+ -DCMAKE_INSTALL_DOCDIR:STRING=${DOCSDIR}
OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
+DOCS_CMAKE_BOOL= PTEX_BUILD_DOCS
-post-build-DOCS-on:
- @(cd ${WRKSRC}/src/doc && doxygen Doxyfile)
-
-do-install:
- ${INSTALL_LIB} ${BUILD_WRKSRC}/src/ptex/libPtex.so \
- ${STAGEDIR}${PREFIX}/lib
- ${INSTALL_DATA} ${BUILD_WRKSRC}/src/ptex/libPtex.a \
- ${STAGEDIR}${PREFIX}/lib
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/src/utils/ptxinfo \
- ${STAGEDIR}${PREFIX}/bin
- ${MKDIR} ${STAGEDIR}/${PREFIX}/include/ptex
- ${INSTALL_DATA} ${BUILD_WRKSRC}/src/ptex/*.h ${STAGEDIR}/${PREFIX}/include/ptex
-
-do-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- @cd ${BUILD_WRKSRC}/src/doc/ptex/ && \
- ${INSTALL_DATA} * ${STAGEDIR}${DOCSDIR}
+pre-build-DOCS-on:
+ @(cd ${WRKSRC}/src/doc && doxygen -u Doxyfile)
.include <bsd.port.mk>
diff --git a/graphics/ptex/distinfo b/graphics/ptex/distinfo
index b811d5accaf6..2e8f8483df32 100644
--- a/graphics/ptex/distinfo
+++ b/graphics/ptex/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1557636252
-SHA256 (wdas-ptex-v2.3.2_GH0.tar.gz) = 30aeb85b965ca542a8945b75285cd67d8e207d23dbb57fcfeaab587bb443402b
-SIZE (wdas-ptex-v2.3.2_GH0.tar.gz) = 308550
+TIMESTAMP = 1666543361
+SHA256 (wdas-ptex-v2.4.2_GH0.tar.gz) = c8235fb30c921cfb10848f4ea04d5b662ba46886c5e32ad5137c5086f3979ee1
+SIZE (wdas-ptex-v2.4.2_GH0.tar.gz) = 312942
diff --git a/graphics/ptex/files/patch-CMakeLists.txt b/graphics/ptex/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..b214fc582564
--- /dev/null
+++ b/graphics/ptex/files/patch-CMakeLists.txt
@@ -0,0 +1,18 @@
+--- CMakeLists.txt.orig 2022-08-05 02:02:51 UTC
++++ CMakeLists.txt
+@@ -3,6 +3,7 @@ option(PTEX_BUILD_SHARED_LIBS "Enable building Ptex sh
+
+ option(PTEX_BUILD_STATIC_LIBS "Enable building Ptex static libraries" ON)
+ option(PTEX_BUILD_SHARED_LIBS "Enable building Ptex shared libraries" ON)
++option(PTEX_BUILD_DOCS "Enable building Ptex documentation (require Doxygen)" OFF)
+ option(PRMAN_15_COMPATIBLE_PTEX "Enable PRMan 15 compatibility" OFF)
+
+ # The C++ standard can set either through the environment or by specifyign
+@@ -114,5 +115,7 @@ add_subdirectory(src/tests)
+ add_subdirectory(src/ptex)
+ add_subdirectory(src/utils)
+ add_subdirectory(src/tests)
++if (PTEX_BUILD_DOCS)
+ add_subdirectory(src/doc)
++endif ()
+ add_subdirectory(src/build)
diff --git a/graphics/ptex/files/patch-ptex__PtexPlatform.h b/graphics/ptex/files/patch-src_ptex_PtexPlatform.h
index e03bb56b14bc..999af3344485 100644
--- a/graphics/ptex/files/patch-ptex__PtexPlatform.h
+++ b/graphics/ptex/files/patch-src_ptex_PtexPlatform.h
@@ -1,6 +1,6 @@
---- src/ptex/PtexPlatform.h.orig 2015-02-12 16:37:58 UTC
+--- src/ptex/PtexPlatform.h.orig 2022-08-05 02:02:51 UTC
+++ src/ptex/PtexPlatform.h
-@@ -60,7 +60,9 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+@@ -70,7 +70,9 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY O
// linux/unix/posix
#include <stdlib.h>
@@ -9,4 +9,4 @@
+#endif
#include <string.h>
#include <pthread.h>
- // OS for spinlock
+
diff --git a/graphics/ptex/files/patch-ptex__PtexWriter.cpp b/graphics/ptex/files/patch-src_ptex_PtexWriter.cpp
index 8491ab115a4d..c8f9366a4877 100644
--- a/graphics/ptex/files/patch-ptex__PtexWriter.cpp
+++ b/graphics/ptex/files/patch-src_ptex_PtexWriter.cpp
@@ -1,6 +1,6 @@
---- src/ptex/PtexWriter.cpp.orig 2015-02-12 16:37:58 UTC
+--- src/ptex/PtexWriter.cpp.orig 2022-08-05 02:02:51 UTC
+++ src/ptex/PtexWriter.cpp
-@@ -66,6 +66,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+@@ -66,6 +66,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY O
#include <algorithm>
#include <iostream>
#include <sstream>
diff --git a/graphics/ptex/pkg-plist b/graphics/ptex/pkg-plist
index 4cc550dcf7eb..fa3a8e805fa1 100644
--- a/graphics/ptex/pkg-plist
+++ b/graphics/ptex/pkg-plist
@@ -1,28 +1,24 @@
bin/ptxinfo
-lib/libPtex.a
-lib/libPtex.so
-include/ptex/PtexCache.h
+include/ptex/PtexExports.h
include/ptex/PtexHalf.h
-include/ptex/PtexHalfTables.h
-include/ptex/PtexHashMap.h
include/ptex/PtexInt.h
-include/ptex/PtexIO.h
-include/ptex/PtexMutex.h
include/ptex/PtexPlatform.h
-include/ptex/PtexReader.h
-include/ptex/PtexSeparableFilter.h
-include/ptex/PtexSeparableKernel.h
-include/ptex/PtexTriangleFilter.h
-include/ptex/PtexTriangleKernel.h
-include/ptex/Ptexture.h
include/ptex/PtexUtils.h
include/ptex/PtexVersion.h
-include/ptex/PtexWriter.h
-%%PORTDOCS%%%%DOCSDIR%%/License_8txt.html
+include/ptex/Ptexture.h
+lib/libPtex.a
+lib/libPtex.so
+lib/libPtex.so.2.4
+share/cmake/Ptex/ptex-config-version.cmake
+share/cmake/Ptex/ptex-config.cmake
+share/cmake/Ptex/ptex-exports-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/Ptex/ptex-exports.cmake
%%PORTDOCS%%%%DOCSDIR%%/PtexCache_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/PtexCache_8cpp_source.html
%%PORTDOCS%%%%DOCSDIR%%/PtexCache_8h.html
%%PORTDOCS%%%%DOCSDIR%%/PtexCache_8h_source.html
+%%PORTDOCS%%%%DOCSDIR%%/PtexExports_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/PtexExports_8h_source.html
%%PORTDOCS%%%%DOCSDIR%%/PtexFilters_8cpp.html
%%PORTDOCS%%%%DOCSDIR%%/PtexFilters_8cpp_source.html
%%PORTDOCS%%%%DOCSDIR%%/PtexHalfTableGen_8cpp.html
@@ -79,6 +75,7 @@ include/ptex/PtexWriter.h
%%PORTDOCS%%%%DOCSDIR%%/apiintro.html
%%PORTDOCS%%%%DOCSDIR%%/apiintro_8txt.html
%%PORTDOCS%%%%DOCSDIR%%/bc_s.png
+%%PORTDOCS%%%%DOCSDIR%%/bc_sd.png
%%PORTDOCS%%%%DOCSDIR%%/bdwn.png
%%PORTDOCS%%%%DOCSDIR%%/classAutoLock-members.html
%%PORTDOCS%%%%DOCSDIR%%/classAutoLock.html
@@ -217,12 +214,14 @@ include/ptex/PtexWriter.h
%%PORTDOCS%%%%DOCSDIR%%/dir_ae2047f671a609e8080f0f626fd72399.html
%%PORTDOCS%%%%DOCSDIR%%/doc.png
%%PORTDOCS%%%%DOCSDIR%%/doc_2CMakeLists_8txt.html
+%%PORTDOCS%%%%DOCSDIR%%/docd.png
%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
-%%PORTDOCS%%%%DOCSDIR%%/doxygen__log_8txt.html
%%PORTDOCS%%%%DOCSDIR%%/doxygen.svg
+%%PORTDOCS%%%%DOCSDIR%%/doxygen__log_8txt.html
%%PORTDOCS%%%%DOCSDIR%%/dynsections.js
%%PORTDOCS%%%%DOCSDIR%%/files.html
%%PORTDOCS%%%%DOCSDIR%%/filterfootprint.html
+%%PORTDOCS%%%%DOCSDIR%%/filterfootprint_8txt.html
%%PORTDOCS%%%%DOCSDIR%%/folderclosed.png
%%PORTDOCS%%%%DOCSDIR%%/folderopen.png
%%PORTDOCS%%%%DOCSDIR%%/functions.html
@@ -322,12 +321,15 @@ include/ptex/PtexWriter.h
%%PORTDOCS%%%%DOCSDIR%%/namespacemembers_vars.html
%%PORTDOCS%%%%DOCSDIR%%/namespaces.html
%%PORTDOCS%%%%DOCSDIR%%/nav_f.png
+%%PORTDOCS%%%%DOCSDIR%%/nav_fd.png
%%PORTDOCS%%%%DOCSDIR%%/nav_g.png
%%PORTDOCS%%%%DOCSDIR%%/nav_h.png
+%%PORTDOCS%%%%DOCSDIR%%/nav_hd.png
%%PORTDOCS%%%%DOCSDIR%%/open.png
%%PORTDOCS%%%%DOCSDIR%%/pages.html
%%PORTDOCS%%%%DOCSDIR%%/ptex_2CMakeLists_8txt.html
%%PORTDOCS%%%%DOCSDIR%%/splitbar.png
+%%PORTDOCS%%%%DOCSDIR%%/splitbard.png
%%PORTDOCS%%%%DOCSDIR%%/structAtomicCompareAndSwapImpl.html
%%PORTDOCS%%%%DOCSDIR%%/structAtomicCompareAndSwapImpl_3_01T_00_01sizeof_07uint32__t_08_4-members.html
%%PORTDOCS%%%%DOCSDIR%%/structAtomicCompareAndSwapImpl_3_01T_00_01sizeof_07uint32__t_08_4.html
@@ -383,10 +385,16 @@ include/ptex/PtexWriter.h
%%PORTDOCS%%%%DOCSDIR%%/structPtex_1_1FaceInfo.html
%%PORTDOCS%%%%DOCSDIR%%/structPtex_1_1Res-members.html
%%PORTDOCS%%%%DOCSDIR%%/structPtex_1_1Res.html
+%%PORTDOCS%%%%DOCSDIR%%/style.css
%%PORTDOCS%%%%DOCSDIR%%/sync_off.png
%%PORTDOCS%%%%DOCSDIR%%/sync_on.png
%%PORTDOCS%%%%DOCSDIR%%/tab_a.png
+%%PORTDOCS%%%%DOCSDIR%%/tab_ad.png
%%PORTDOCS%%%%DOCSDIR%%/tab_b.png
+%%PORTDOCS%%%%DOCSDIR%%/tab_bd.png
%%PORTDOCS%%%%DOCSDIR%%/tab_h.png
+%%PORTDOCS%%%%DOCSDIR%%/tab_hd.png
%%PORTDOCS%%%%DOCSDIR%%/tab_s.png
+%%PORTDOCS%%%%DOCSDIR%%/tab_sd.png
%%PORTDOCS%%%%DOCSDIR%%/tabs.css
+%%PORTDOCS%%%%DOCSDIR%%/uvellipse.png