aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2023-02-24 23:23:25 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2023-02-24 23:23:25 +0000
commit5ce41514802cd442c01388c30a97e1fde16d836f (patch)
tree306de5ef063323a2d70300b28b7357926676819e
parentf9e56d1b6e1952f49adda0e800c7410b6b466dbc (diff)
downloadports-5ce41514802cd442c01388c30a97e1fde16d836f.tar.gz
ports-5ce41514802cd442c01388c30a97e1fde16d836f.zip
biology/htslib: Update to 1.17
Numerous enhancements and fixes Changes: https://github.com/samtools/htslib/releases Reported by: portscout
-rw-r--r--biology/htslib/Makefile2
-rw-r--r--biology/htslib/distinfo6
-rw-r--r--biology/htslib/files/patch-Makefile37
3 files changed, 13 insertions, 32 deletions
diff --git a/biology/htslib/Makefile b/biology/htslib/Makefile
index 383f90e08114..9f85da45917a 100644
--- a/biology/htslib/Makefile
+++ b/biology/htslib/Makefile
@@ -1,5 +1,5 @@
PORTNAME= htslib
-DISTVERSION= 1.16
+DISTVERSION= 1.17
CATEGORIES= biology devel
# Github generated distfiles are incomplete, so use custom tarball
MASTER_SITES= https://github.com/samtools/htslib/releases/download/${DISTVERSION}/
diff --git a/biology/htslib/distinfo b/biology/htslib/distinfo
index 88b848aeb2fb..24c398cacc3c 100644
--- a/biology/htslib/distinfo
+++ b/biology/htslib/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1672094487
-SHA256 (htslib-1.16.tar.bz2) = 606b7c7aff73734cf033ecd156f40529fa5792f54524952a28938ca0890d7924
-SIZE (htslib-1.16.tar.bz2) = 4466776
+TIMESTAMP = 1677245487
+SHA256 (htslib-1.17.tar.bz2) = 763779288c40f07646ec7ad98b96c378c739171d162ad98398868783b721839f
+SIZE (htslib-1.17.tar.bz2) = 4619884
diff --git a/biology/htslib/files/patch-Makefile b/biology/htslib/files/patch-Makefile
index 7f91465d2ccd..eb6fb7f85901 100644
--- a/biology/htslib/files/patch-Makefile
+++ b/biology/htslib/files/patch-Makefile
@@ -1,33 +1,14 @@
---- Makefile.orig 2021-03-20 15:53:14 UTC
+--- Makefile.orig 2023-02-24 13:35:28 UTC
+++ Makefile
-@@ -53,13 +53,14 @@ man5dir = $(mandir)/man5
- man7dir = $(mandir)/man7
- pkgconfigdir= $(prefix)/libdata/pkgconfig
-
--MKDIR_P = mkdir -p
--INSTALL = install -p
--INSTALL_DATA = $(INSTALL) -m 644
--INSTALL_DIR = $(MKDIR_P) -m 755
--INSTALL_LIB = $(INSTALL_DATA)
--INSTALL_MAN = $(INSTALL_DATA)
+@@ -60,9 +60,9 @@ INSTALL = install -p
+ INSTALL_DATA = $(INSTALL) -m 644
+ INSTALL_DIR = $(MKDIR_P) -m 755
+ LIB_PERM = 644
+-INSTALL_LIB = $(INSTALL) -m $(LIB_PERM)
++INSTALL_LIB = $(BSD_INSTALL_LIB)
+ INSTALL_MAN = $(INSTALL_DATA)
-INSTALL_PROGRAM = $(INSTALL)
-+# Use ports BSD_INSTALL_PROGRAM to strip if WITH_DEBUG is not set
-+MKDIR_P = mkdir -p
-+INSTALL = install -p
-+INSTALL_DATA = ${BSD_INSTALL_DATA}
-+INSTALL_DIR = $(MKDIR_P)
-+INSTALL_LIB = ${BSD_INSTALL_LIB}
-+INSTALL_MAN = ${BSD_INSTALL_MAN}
-+INSTALL_PROGRAM = ${BSD_INSTALL_PROGRAM}
++INSTALL_PROGRAM = $(BSD_INSTALL_PROGRAM)
# Set by config.mk if plugins are enabled
plugindir =
-@@ -102,7 +103,7 @@ BUILT_THRASH_PROGRAMS = \
- test/thrash_threads6 \
- test/thrash_threads7
-
--all: lib-static lib-shared $(BUILT_PROGRAMS) plugins $(BUILT_TEST_PROGRAMS) \
-+all: lib-static lib-shared $(BUILT_PROGRAMS) plugins \
- htslib_static.mk htslib-uninstalled.pc
-
- ALL_CPPFLAGS = -I. $(CPPFLAGS)