aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2014-05-20 06:06:35 +0000
committerAlex Kozlov <ak@FreeBSD.org>2014-05-20 06:06:35 +0000
commit5d6a8e4ab8c7a865ca3e5ca93db879ddc9eb4fe0 (patch)
treea3f77a0d965b1e0633bce4bd914a678be49a43c0
parentaa64a516608801a751cff7155b12de0f8e960697 (diff)
downloadports-5d6a8e4ab8c7a865ca3e5ca93db879ddc9eb4fe0.tar.gz
ports-5d6a8e4ab8c7a865ca3e5ca93db879ddc9eb4fe0.zip
- Add/update license when possible
- Modernize ports Makefiles - Update MASTER_SITES/distfile for converters/chmview
Notes
Notes: svn path=/head/; revision=354597
-rw-r--r--archivers/ha/Makefile2
-rw-r--r--archivers/liblzxcomp/Makefile2
-rw-r--r--converters/chmview/Makefile13
-rw-r--r--converters/chmview/distinfo4
-rw-r--r--graphics/fli2gif/Makefile6
-rw-r--r--graphics/pngquant/Makefile5
-rw-r--r--graphics/xmountains/Makefile2
-rw-r--r--misc/kenny/Makefile6
-rw-r--r--ports-mgmt/pchecker/Makefile4
-rw-r--r--security/dropbear/Makefile3
-rw-r--r--www/googlebook_dl/Makefile2
-rw-r--r--x11-wm/vtwm/Makefile4
-rw-r--r--x11/printscreen/Makefile6
13 files changed, 28 insertions, 31 deletions
diff --git a/archivers/ha/Makefile b/archivers/ha/Makefile
index 1508c66acc48..d0daaffd181b 100644
--- a/archivers/ha/Makefile
+++ b/archivers/ha/Makefile
@@ -12,6 +12,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ak@FreeBSD.org
COMMENT= File archiver based on HSC compression method
+LICENSE= GPLv2
+
PROJECTHOST= ak-various-projects
NO_WRKSUBDIR= yes
diff --git a/archivers/liblzxcomp/Makefile b/archivers/liblzxcomp/Makefile
index b6452332f8b5..b2ea7ab98ea1 100644
--- a/archivers/liblzxcomp/Makefile
+++ b/archivers/liblzxcomp/Makefile
@@ -10,6 +10,8 @@ DISTNAME= lzx_compress
MAINTAINER= ak@FreeBSD.org
COMMENT= LZX compression library
+LICENSE= LGPL21
+
USES= uidfix
USE_LDCONFIG= yes
diff --git a/converters/chmview/Makefile b/converters/chmview/Makefile
index 50d2e7769499..a3931d0c68f8 100644
--- a/converters/chmview/Makefile
+++ b/converters/chmview/Makefile
@@ -3,9 +3,9 @@
PORTNAME= chmview
PORTVERSION= 2.0b4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= converters textproc
-MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITES= https://googledrive.com/host/0BwCT-sp3iBCaeDRPYm1jTjl1Qmc/
MAINTAINER= ak@FreeBSD.org
COMMENT= Extractor from .chm files
@@ -14,15 +14,10 @@ LICENSE= GPLv2
LIB_DEPENDS= libchm.so:${PORTSDIR}/misc/chmlib
-PROJECTHOST= ak-various-projects
-
-USE_XZ= yes
-USE_DOS2UNIX= chmview.c utf8.c utf8.h
+USES= tar:xz
WRKSRC= ${WRKDIR}/src
+MAKEFILE= ${FILESDIR}/Makefile
PLIST_FILES= bin/chmview
-post-extract:
- @${CP} ${FILESDIR}/Makefile ${WRKSRC}
-
.include <bsd.port.mk>
diff --git a/converters/chmview/distinfo b/converters/chmview/distinfo
index 1ad394e1078f..20bfe2527d42 100644
--- a/converters/chmview/distinfo
+++ b/converters/chmview/distinfo
@@ -1,2 +1,2 @@
-SHA256 (chmview-2.0b4.tar.xz) = cc860a5de9e1f379d199b9809471ca045790425389f0a32908c80bd480de0e1d
-SIZE (chmview-2.0b4.tar.xz) = 12008
+SHA256 (chmview-2.0b4.tar.xz) = a3949044a1771e17482589ae1239e8101f2409b52adccc267f8c4eaf31861903
+SIZE (chmview-2.0b4.tar.xz) = 11952
diff --git a/graphics/fli2gif/Makefile b/graphics/fli2gif/Makefile
index 4ac0ab1d0613..03034d3621ed 100644
--- a/graphics/fli2gif/Makefile
+++ b/graphics/fli2gif/Makefile
@@ -20,12 +20,12 @@ PLIST_FILES= bin/${PORTNAME}
PORTDOCS= fli2gif.txt
post-extract:
- @cd ${WRKSRC} && ${UNZIP_CMD} -q source.zip \
+ @(cd ${WRKSRC} && ${UNZIP_CMD} -q source.zip \
&& ${LN} -sf GIF.CPP gif.cpp \
- && ${LN} -sf FLIPLAY.CPP fliplay.cpp
+ && ${LN} -sf FLIPLAY.CPP fliplay.cpp)
do-build:
- @cd ${WRKSRC} && ${CXX} ${CXXFLAGS} -o ${PORTNAME} *.cpp
+ (cd ${WRKSRC} && ${CXX} ${CXXFLAGS} -o ${PORTNAME} *.cpp)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fli2gif ${STAGEDIR}${PREFIX}/bin
diff --git a/graphics/pngquant/Makefile b/graphics/pngquant/Makefile
index b3557c520acf..e5cef4977181 100644
--- a/graphics/pngquant/Makefile
+++ b/graphics/pngquant/Makefile
@@ -10,15 +10,14 @@ MASTER_SITES= http://pngquant.org/
MAINTAINER= ak@FreeBSD.org
COMMENT= Converts 32-bit RGBA PNGs into 8-bit RGBA-palette PNGs
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
MAKE_ARGS+= CC="${CC}"
CPPFLAGS+= $$(libpng-config --I_opts)
diff --git a/graphics/xmountains/Makefile b/graphics/xmountains/Makefile
index 423efa81d8d5..97c59515f99f 100644
--- a/graphics/xmountains/Makefile
+++ b/graphics/xmountains/Makefile
@@ -27,7 +27,7 @@ post-extract:
@${LN} -sf ${PORTNAME}.man ${WRKSRC}/${PORTNAME}.6
do-build:
- cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} *.c -lX11 -lm -o ${PORTNAME}
+ (cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} *.c -lX11 -lm -o ${PORTNAME})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
diff --git a/misc/kenny/Makefile b/misc/kenny/Makefile
index 99d1c19b336a..e598cae8bf95 100644
--- a/misc/kenny/Makefile
+++ b/misc/kenny/Makefile
@@ -13,6 +13,8 @@ EXTRACT_SUFX= .gz
MAINTAINER= ak@FreeBSD.org
COMMENT= Translate text both to and from KennySpeak
+LICENSE= ART10
+
PROJECTHOST= ak-various-projects
CONFLICTS= filters-*
@@ -36,7 +38,7 @@ post-extract:
@${POD2MAN} ${WRKDIR}/${PORTNAME} > ${WRKDIR}/${PORTNAME}.1
do-install:
- @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- @${INSTALL_MAN} ${WRKDIR}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKDIR}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/ports-mgmt/pchecker/Makefile b/ports-mgmt/pchecker/Makefile
index b59468b71581..5b498f0a8715 100644
--- a/ports-mgmt/pchecker/Makefile
+++ b/ports-mgmt/pchecker/Makefile
@@ -10,9 +10,9 @@ PROJECTHOST= ak-various-projects
MAINTAINER= ak@FreeBSD.org
COMMENT= Tool that checks the ports tree for various errors
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
-USE_XZ= yes
+USES= tar:xz
NO_ARCH= yes
NO_BUILD= yes
diff --git a/security/dropbear/Makefile b/security/dropbear/Makefile
index 9a035b717fef..6c7272440f3a 100644
--- a/security/dropbear/Makefile
+++ b/security/dropbear/Makefile
@@ -10,8 +10,7 @@ MAINTAINER= ak@FreeBSD.org
COMMENT= SSH 2 server, designed to be usable in small memory environments
GNU_CONFIGURE= yes
-USE_BZIP2= yes
-USES= gmake
+USES= gmake tar:bzip2
USE_RC_SUBR= ${PORTNAME}
diff --git a/www/googlebook_dl/Makefile b/www/googlebook_dl/Makefile
index 87a8f7ee77a2..14b422354190 100644
--- a/www/googlebook_dl/Makefile
+++ b/www/googlebook_dl/Makefile
@@ -10,7 +10,7 @@ DISTFILES= # none
MAINTAINER= ak@FreeBSD.org
COMMENT= Command-line utility for downloading books from Google Books
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
RUN_DEPENDS= wget:${PORTSDIR}/ftp/wget
diff --git a/x11-wm/vtwm/Makefile b/x11-wm/vtwm/Makefile
index a83207ab2267..4220301ac5af 100644
--- a/x11-wm/vtwm/Makefile
+++ b/x11-wm/vtwm/Makefile
@@ -14,9 +14,7 @@ LICENSE= MIT
LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
-USE_XZ= yes
-
-USES= pkgconfig
+USES= pkgconfig tar:xz
GNU_CONFIGURE= yes
USE_XORG= x11 xext xft xinerama xpm xmu xrandr
diff --git a/x11/printscreen/Makefile b/x11/printscreen/Makefile
index 150c395dbebb..27d300931b40 100644
--- a/x11/printscreen/Makefile
+++ b/x11/printscreen/Makefile
@@ -3,14 +3,14 @@
PORTNAME= printscreen
PORTVERSION= 1.4
PORTREVISION= 1
-CATEGORIES= x11
+CATEGORIES= graphics x11
MASTER_SITES= # none
DISTFILES= # none
MAINTAINER= ak@FreeBSD.org
COMMENT= Simple screenshot program for X11
-LICENSE= BSD
+LICENSE= BSD2CLAUSE
RUN_DEPENDS= xwd:${PORTSDIR}/x11/xwd \
xwdtopnm:${PORTSDIR}/graphics/netpbm
@@ -22,6 +22,6 @@ NO_BUILD= yes
PLIST_FILES= bin/printscreen
do-install:
- @${INSTALL_SCRIPT} ${FILESDIR}/printscreen.in ${STAGEDIR}${PREFIX}/bin/printscreen
+ ${INSTALL_SCRIPT} ${FILESDIR}/printscreen.in ${STAGEDIR}${PREFIX}/bin/printscreen
.include <bsd.port.mk>