aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-12-19 17:21:40 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-12-19 17:21:40 +0000
commit5db3c2dcec28af2b0a68035162846e5c63fc7467 (patch)
tree7bc7dc6bb5ebc2bf69cff2521a47f2482a27e06c
parenta8e5bf8a25f762071d953c60faf23273046d5351 (diff)
downloadports-5db3c2dcec28af2b0a68035162846e5c63fc7467.tar.gz
ports-5db3c2dcec28af2b0a68035162846e5c63fc7467.zip
graphics/fotoxx: update the port to version 23.82
Reported by: portscout
-rw-r--r--graphics/fotoxx/Makefile2
-rw-r--r--graphics/fotoxx/distinfo6
-rw-r--r--graphics/fotoxx/files/patch-zfuncs.cc4
3 files changed, 6 insertions, 6 deletions
diff --git a/graphics/fotoxx/Makefile b/graphics/fotoxx/Makefile
index 23d5fd77d45c..508077d34434 100644
--- a/graphics/fotoxx/Makefile
+++ b/graphics/fotoxx/Makefile
@@ -1,5 +1,5 @@
PORTNAME= fotoxx
-PORTVERSION= 23.80
+PORTVERSION= 23.82
CATEGORIES= graphics
MASTER_SITES= https://kornelix.net/downloads/downloads/
DISTNAME= ${PORTNAME}-${PORTVERSION}-source
diff --git a/graphics/fotoxx/distinfo b/graphics/fotoxx/distinfo
index e4f40cdfb41e..98715c3b8ba0 100644
--- a/graphics/fotoxx/distinfo
+++ b/graphics/fotoxx/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1701557310
-SHA256 (fotoxx-23.80-source.tar.gz) = 0ed4b7e91d3eb87a62dbff57d6e919facf3ad444924c5af3ef67ab4a31373073
-SIZE (fotoxx-23.80-source.tar.gz) = 16259363
+TIMESTAMP = 1702722295
+SHA256 (fotoxx-23.82-source.tar.gz) = 323c34903fa4fd96b38a3f5997af970e4ed4f33200b579fdb36165f248d31eb3
+SIZE (fotoxx-23.82-source.tar.gz) = 16257916
diff --git a/graphics/fotoxx/files/patch-zfuncs.cc b/graphics/fotoxx/files/patch-zfuncs.cc
index ce218c6ee7bf..8af1fb535815 100644
--- a/graphics/fotoxx/files/patch-zfuncs.cc
+++ b/graphics/fotoxx/files/patch-zfuncs.cc
@@ -78,7 +78,7 @@
@@ -1060,7 +1096,7 @@ double get_seconds()
timespec time1;
double secs;
-
+
- clock_gettime(CLOCK_MONOTONIC_RAW,&time1);
+ clock_gettime(CLOCK_MONOTONIC,&time1);
secs = time1.tv_sec;
@@ -164,7 +164,7 @@
@@ -6109,9 +6154,16 @@ int zinitapp(ch *appvers, int argc, ch *argv[])
if (argc > 1 && strmatchV(argv[1],"-ver","-v",0)) exit(0); // exit if nothing else wanted
- progexe = 0;
+ progexe = 0;
+#if defined(__linux__)
cc = readlink("/proc/self/exe",buff,300); // get my executable program path
if (cc <= 0) zexit(1,"readlink() /proc/self/exe) failed");