aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-03-29 14:20:06 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-03-29 14:20:06 +0000
commit5e120c6c3391e338ecc7704884aa69a0a5eed605 (patch)
treede926646bbfa2820485f006f013ce53c364cd756
parent865b4f435194dc1914144698296796c033ef3e8e (diff)
downloadports-5e120c6c3391e338ecc7704884aa69a0a5eed605.tar.gz
ports-5e120c6c3391e338ecc7704884aa69a0a5eed605.zip
- fix build for png-1.4.1
Notes
Notes: svn path=/head/; revision=251728
-rw-r--r--graphics/swfmill/Makefile2
-rw-r--r--graphics/swfmill/files/patch-readpng.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/swfmill/Makefile b/graphics/swfmill/Makefile
index b1af7e4c7404..ed80b4130e3b 100644
--- a/graphics/swfmill/Makefile
+++ b/graphics/swfmill/Makefile
@@ -26,6 +26,6 @@ CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}" PKG_CONFIG=${LOCALBASE}/bin/pkg-config
USE_LDCONFIG= YES
post-patch:
- @${REINPLACE_CMD} -e 's|libpng|libpng12|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|libpng|libpng14|' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/graphics/swfmill/files/patch-readpng.c b/graphics/swfmill/files/patch-readpng.c
new file mode 100644
index 000000000000..ba18494b46ea
--- /dev/null
+++ b/graphics/swfmill/files/patch-readpng.c
@@ -0,0 +1,11 @@
+--- src/swft/readpng.c.orig 2006-07-20 15:57:17.000000000 +0200
++++ src/swft/readpng.c 2010-03-29 16:19:53.000000000 +0200
+@@ -69,7 +69,7 @@
+ * have used slightly more general png_sig_cmp() function instead */
+
+ fread(sig, 1, 8, infile);
+- if (!png_check_sig(sig, 8))
++ if (png_sig_cmp(sig, 0, 8))
+ return 1; /* bad signature */
+
+