aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-10-22 15:34:02 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-10-22 15:58:24 +0000
commit5e1f43b9894684b9380870b8fe93040f13e8c079 (patch)
treea44b43e4bd0016ec2651473ec165223e09e0003b
parenteb140a77db1a6580b1120deba3a0ed9403183770 (diff)
downloadports-5e1f43b9894684b9380870b8fe93040f13e8c079.tar.gz
ports-5e1f43b9894684b9380870b8fe93040f13e8c079.zip
misc/xgboost: Update 1.4.2 -> 1.5.0
-rw-r--r--misc/xgboost/Makefile2
-rw-r--r--misc/xgboost/distinfo6
-rw-r--r--misc/xgboost/files/patch-CMakeLists.txt38
-rw-r--r--misc/xgboost/pkg-plist1
4 files changed, 29 insertions, 18 deletions
diff --git a/misc/xgboost/Makefile b/misc/xgboost/Makefile
index 0952a6570754..3f5a842820da 100644
--- a/misc/xgboost/Makefile
+++ b/misc/xgboost/Makefile
@@ -1,6 +1,6 @@
PORTNAME= xgboost
DISTVERSIONPREFIX= v
-DISTVERSION= 1.4.2
+DISTVERSION= 1.5.0
CATEGORIES= misc # machine-learning
MAINTAINER= yuri@FreeBSD.org
diff --git a/misc/xgboost/distinfo b/misc/xgboost/distinfo
index faf68eede2b1..65a28cd370ab 100644
--- a/misc/xgboost/distinfo
+++ b/misc/xgboost/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1629576075
-SHA256 (dmlc-xgboost-v1.4.2_GH0.tar.gz) = e251dae332ce6168f7c900ba8ca2e84c75c0e227ef51611d2badbdd451847dc3
-SIZE (dmlc-xgboost-v1.4.2_GH0.tar.gz) = 1582010
+TIMESTAMP = 1634915550
+SHA256 (dmlc-xgboost-v1.5.0_GH0.tar.gz) = 24a78308986b1c2b00fa9c1dc25e7899854ff5fc5337e57a9fc49dad002c7ddd
+SIZE (dmlc-xgboost-v1.5.0_GH0.tar.gz) = 1640493
SHA256 (NVlabs-cub-af39ee2_GH0.tar.gz) = 3444f1d0af16d3680bf5089c1a91e707769d946580b80f12463860366fb6884b
SIZE (NVlabs-cub-af39ee2_GH0.tar.gz) = 413215
SHA256 (rapidsai-gputreeshap-5bba198_GH0.tar.gz) = bad0d98eddff46e298f4c6be71b140ac8573b2d1740f109f3151097c56f18463
diff --git a/misc/xgboost/files/patch-CMakeLists.txt b/misc/xgboost/files/patch-CMakeLists.txt
index 3a9624514124..7fbe42423d27 100644
--- a/misc/xgboost/files/patch-CMakeLists.txt
+++ b/misc/xgboost/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2020-12-22 07:22:32 UTC
+--- CMakeLists.txt.orig 2021-10-15 04:21:04 UTC
+++ CMakeLists.txt
-@@ -101,11 +101,11 @@ endif (PLUGIN_RMM AND NOT ((CMAKE_CXX_COMPILER_ID STRE
+@@ -104,11 +104,11 @@ endif (PLUGIN_RMM AND NOT ((CMAKE_CXX_COMPILER_ID STRE
if (PLUGIN_RMM AND NOT (CMAKE_SYSTEM_NAME STREQUAL "Linux"))
message(SEND_ERROR "`PLUGIN_RMM` must be used with Linux.")
endif (PLUGIN_RMM AND NOT (CMAKE_SYSTEM_NAME STREQUAL "Linux"))
@@ -17,24 +17,16 @@
if (BUILD_STATIC_LIB AND (R_LIB OR JVM_BINDINGS))
message(SEND_ERROR "Cannot build a static library libxgboost.a when R or JVM packages are enabled.")
endif (BUILD_STATIC_LIB AND (R_LIB OR JVM_BINDINGS))
-@@ -150,11 +150,11 @@ endif (USE_OPENMP)
+@@ -160,7 +160,7 @@ endif (USE_NCCL)
# dmlc-core
msvc_use_static_runtime()
-add_subdirectory(${xgboost_SOURCE_DIR}/dmlc-core)
--set_target_properties(dmlc PROPERTIES
-- CXX_STANDARD 14
-- CXX_STANDARD_REQUIRED ON
-- POSITION_INDEPENDENT_CODE ON)
+#add_subdirectory(${xgboost_SOURCE_DIR}/dmlc-core)
-+#set_target_properties(dmlc PROPERTIES
-+# CXX_STANDARD 14
-+# CXX_STANDARD_REQUIRED ON
-+# POSITION_INDEPENDENT_CODE ON)
+
if (MSVC)
- target_compile_options(dmlc PRIVATE
- -D_CRT_SECURE_NO_WARNINGS -D_CRT_SECURE_NO_DEPRECATE)
-@@ -172,7 +172,7 @@ add_subdirectory(rabit)
+ if (TARGET dmlc_unit_tests)
+@@ -177,7 +177,7 @@ endif (RABIT_BUILD_MPI)
# core xgboost
add_subdirectory(${xgboost_SOURCE_DIR}/src)
@@ -43,3 +35,21 @@
# Exports some R specific definitions and objects
if (R_LIB)
+@@ -218,7 +218,7 @@ set_target_properties(runxgboost PROPERTIES OUTPUT_NAM
+ #-- End CLI for xgboost
+
+ # Common setup for all targets
+-foreach(target xgboost objxgboost dmlc runxgboost)
++foreach(target xgboost objxgboost runxgboost)
+ xgboost_target_properties(${target})
+ xgboost_target_link_libraries(${target})
+ xgboost_target_defs(${target})
+@@ -269,7 +269,7 @@ install(DIRECTORY ${xgboost_SOURCE_DIR}/include/xgboos
+ #
+ # https://github.com/dmlc/xgboost/issues/6085
+ if (BUILD_STATIC_LIB)
+- set(INSTALL_TARGETS xgboost runxgboost objxgboost dmlc)
++ set(INSTALL_TARGETS xgboost runxgboost objxgboost)
+ else (BUILD_STATIC_LIB)
+ set(INSTALL_TARGETS xgboost runxgboost)
+ endif (BUILD_STATIC_LIB)
diff --git a/misc/xgboost/pkg-plist b/misc/xgboost/pkg-plist
index 6e7fd12db23a..3b9b92585a29 100644
--- a/misc/xgboost/pkg-plist
+++ b/misc/xgboost/pkg-plist
@@ -11,6 +11,7 @@ include/xgboost/intrusive_ptr.h
include/xgboost/json.h
include/xgboost/json_io.h
include/xgboost/learner.h
+include/xgboost/linalg.h
include/xgboost/linear_updater.h
include/xgboost/logging.h
include/xgboost/metric.h