aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-12-25 09:20:38 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-12-25 09:20:38 +0000
commit5e279ec3d32423c4fc605bb6c4d0ac1e95682c25 (patch)
tree669ebda902227609dff07b873a823eb8f8b385c8
parente1e3fe2e3012e5a9c1713a364e7135c58268fc34 (diff)
downloadports-5e279ec3d32423c4fc605bb6c4d0ac1e95682c25.tar.gz
ports-5e279ec3d32423c4fc605bb6c4d0ac1e95682c25.zip
Add py-pyhull 1.5.6, computation of convex hull, Delaunay triangulation
and Voronoi diagram. PR: 205593 Submitted by: Yuri Victorovich <yuri@rawbw.com>
Notes
Notes: svn path=/head/; revision=404409
-rw-r--r--math/Makefile1
-rw-r--r--math/py-pyhull/Makefile24
-rw-r--r--math/py-pyhull/distinfo2
-rw-r--r--math/py-pyhull/pkg-descr5
4 files changed, 32 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 11b7e913d42e..69414be34f18 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -609,6 +609,7 @@
SUBDIR += py-pybloom
SUBDIR += py-pycosat
SUBDIR += py-pyfst
+ SUBDIR += py-pyhull
SUBDIR += py-pymc
SUBDIR += py-roman
SUBDIR += py-scientific
diff --git a/math/py-pyhull/Makefile b/math/py-pyhull/Makefile
new file mode 100644
index 000000000000..a00972a029da
--- /dev/null
+++ b/math/py-pyhull/Makefile
@@ -0,0 +1,24 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= pyhull
+PORTVERSION= 1.5.6
+CATEGORIES= math python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Computation of convex hull, Delaunay triangulation and Voronoi diagram
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYNUMPY}
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/pyhull/_pyhull.so
+
+.include <bsd.port.mk>
diff --git a/math/py-pyhull/distinfo b/math/py-pyhull/distinfo
new file mode 100644
index 000000000000..ccf35277afc1
--- /dev/null
+++ b/math/py-pyhull/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyhull-1.5.6.tar.gz) = 4d14bf6e6ba695de4d4ae28d2c15b97eb2dabc1e840bb9d1120ed1ffa2c52cb1
+SIZE (pyhull-1.5.6.tar.gz) = 298717
diff --git a/math/py-pyhull/pkg-descr b/math/py-pyhull/pkg-descr
new file mode 100644
index 000000000000..019f39586e9c
--- /dev/null
+++ b/math/py-pyhull/pkg-descr
@@ -0,0 +1,5 @@
+A Python wrapper to Qhull (www.qhull.org) for the computation
+of the convex hull, Delaunay triangulation and Voronoi diagram.
+
+WWW: https://github.com/materialsvirtuallab/pyhull
+WWW: https://pypi.python.org/pypi/pyhull